Windows 10 Technical Preview

Moderator: jknoth

Antworten
Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Windows 10 Technical Preview

Beitrag von Viper9000 » 11. Dez 2014, 15:21

Hallo zusammen,

ich habe mal versucht Windows 10 via Empirum zu verteilen. Die OS Installation lief als "getarnte" 8.1 eigentlich gut durch. Es kam nur der Dialog zur Editionsauswahl, weil es diese SKU so nicht in Matrix gibt.

Leider will der Agent nicht so wirklich. Lässt sich zwar installieren, holt aber keine Software.

Hat jemand schon mal einen Test gemacht?

Gruß

Benutzeravatar
hdroege
Beiträge: 129
Registriert: 14. Dez 2004, 09:30
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von hdroege » 16. Dez 2014, 13:12

Hallo,
wir hatten uns den aktuellen Build angeschaut und der Agent hatte problemlos Software installiert.
Nicht funktionieren aktuell der Kiosk (eris_ui) und die Notifikations (die Einblendungen bei Benachrichtungen).

Wir werden das natürlich weiter testen und die Ursachen analysieren. Sobald die Preview etwas weniger Veränderungen erfährt werden wir die Punkte auch lösen.

Mit freundlichen Grüßen
Horst Droege
Chief Product Architect

Matrix42 AG
Elbinger Strasse 7
60487 Frankfurt

http://www.matrix42.com/de
Twitter: @i_horst

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of matrix42 AG or of the support team.

Frommert
Beiträge: 30
Registriert: 02. Dez 2010, 08:35
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Frommert » 26. Jan 2015, 10:45

Gibt es schon Erfahrungen mit der Build 9926?

Frommert
Beiträge: 30
Registriert: 02. Dez 2010, 08:35
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Frommert » 28. Jan 2015, 10:30

Also in der 9926 gibt es die gleichen Fehler wie oben beschrieben, ERIS_UI und Notifications werden nicht angezeigt. Software wird aber problemlos installiert. Dank Continuum auf einem 2in1 und den vielen neuen Features macht Win10 trotz vieler Bugs bereits richtig Spaß. Vor allem das Touch Bedienung und Maus/Tastatur Bedienung deutlich gängiger sind ist ein Riesen Fortschritt gegenüber Win8...

Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Viper9000 » 09. Feb 2015, 15:48

Hallo zusammen,

ich habe die aktuelle Preview wieder mal getestet. Lässt sich ohne Probleme als getarntes Windows 8.1 durchinstallieren bis auf den SKU Dialog. Dies könnte man auch noch per EIS Skript abfangen.

Bei uns läuft der Dienst, allerdings erscheint kein Tray usw.

Wie ist eure Erfahrung?


Gruß Viper

Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Re: Windows 10 Technical Preview und Surface Pro 3

Beitrag von Viper9000 » 10. Mär 2015, 21:52

Hallo,

ersten Feedback Windows 10 und Microsoft Surface Pro 3 und Empirum. Wir haben die ersten Pro 3 mit Win10 über Empirum betankt. Folgendes kann ich als Hinweis mitgeben.

OS:
Da Win10 Technical Preview als SKU noch Windows 8.1 Enterprise bzw. Windows 8.1 Pro führt (je nachdem welches iso man nimmt), denkt Empirum, es handelt sich um ein Windows 8.1. Ich habe allerdings vorher immer ein richtiges 8.1 importiert und die Quelldateien sowohl für das OS als auch für das Language Pack de-de auf Dateiebene getauscht. Die Standard unattended XML funktioniert. Auch alle anderen Mechanismen hinsichtlich Treiberverwaltung funktionieren, wenn man sie als 8.1 Treiber pflegt.

Da wir multilingual installieren, ist mir aufgefallen, dass das Systemlocale nicht sauber auf Deutsch (trotz richtiger Variablen) gesetzt wird. Es steht auf Englisch. Das Userlocale stimmt aber.

Softwareverteilung:
Der Empriumagent denkt auch, dass es ein Windows 8.1 wäre. Er verteilt die Software vor dem Windows Logon ordnungsgemäß. Der Eris_ui im Benutzerinterface stürzt aber immer ab. Damit nicht ständig Berichte an Microsoft gesendet werden, habe ich den run Befehl für den Eris_ui in der Registry entfernt. Nachteil der ganzen Sache AW Anteile werden nicht geschrieben. Workaround run Eintrag mit einer kleinen Batch die einmalig die Setup.inf des jeweiligen Paketes mit AW Anteilen ausführt.

Hardware spezifische Dinge:
Die Installation des Surface Pro 3 ist etwas gewöhnungsbedürftig. Man kann eine Netzwerkinstallation nur via USB Netzwerkadapter (nicht via Dockingstation) (sinnvoll den 1GB USB Adapter kaufen) machen. Die Mac dieses Adapters muss man erst über ein anderes Gerät ermitteln, da diese nicht auf dem Adapter steht. Die EPE Phase dauert während der OS Installation beim ersten Mal sehr lange. Ursache ist eine veraltete UEFI BIOS Version seitens MS. Also unbedingt die Treiber für das Surface pflegen. Beim zweiten Durchlauf ist es deutlich schneller. Übrigens bietet MS Firmwareupdate für das Surface via inf-Treiber an. Das Empirum Inventory ersetzt leider die USB Netzwerkadapter MAC durch die eingebaute WLAN MAC. Nun ja Schönheitsfehler. Nerviger ist, dass das UEFI EPE noch keinen Secure Boot unterstützt. Dadurch muss man vor jeder Installation Secure Boot über das BIOS manuell abschalten. Damit entfällt auch die Möglichkeit während der Windows Installation automatisch Bitlocker zu aktivieren und ohne weitere Eingaben den Key ins AD zu schreiben und zu verschlüsseln. Diese Funktion ist neu und erleichtert deutlich die Bitlockeraktivierungen.

Ich hoffe, dass Matrix42 die Einschränkungen hinsichtlich UEFI und vollwertigen Win10 Support zeitnah lösen wird. Wir planen auf jeden Fall einen zeitnahen Rollout nach der Veröffentlichung, da wir 8.1 in der Masse gerne überspringen wollen.

Gruß Viper

kad
Beiträge: 360
Registriert: 10. Dez 2009, 10:42
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von kad » 20. Mär 2015, 11:06

Hallo

Wir testen zurzeit auch das Surface 3 Pro über Empirum zu installieren nach dem Matrix42 Update Feauture Pack.
Testen tun wir aber noch mit windows 8.1

Ich war eigentlich erstaunt, dass die Installation relativ schnell problemlos durchlief. Was bei uns aber ganz anders ist als von dir beschrieben. Ich habe es bisher nur mit der Dockingstation geschafft eine Netzwerkinstallation erfolgreich durchzuführen.

Mit dem MS USB Ethernet Adaptzer funktioniert es nicht, es kommt dann nach einiger Zeit die Meldung: no suitable device found und bricht dann ab. Der Treiber lässt sich in Empirum auch nicht einbinden mit der Spy Datei, es kommt nach
dem auswählen des Treibers die Meldung. kein passender Treiber gefunden, obwohl es der richtige ist (Anhand Vergleich im Gerätemanager----msu30x64w8.inf)
Keine Ahnung wie ich den Treiber reinkriege, damit die Installation klappt. Bei der Dockingstation habe ich übrigens nicht einmal einen Treiber für die EPE Phase eingebunden und es hat dennoch funktioniert.....

oder gibt es da einen speziellen Driver für den USB Adapter?

Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Viper9000 » 20. Mär 2015, 15:37

Hallo,

danke für das Feedback. Wenn ich ehrlich bin, habe ich es am Docker noch gar nicht versucht, da es so im Guide stand (denke ich). Lade dir das aktuelle Treiberpack vom Januar 2015 runter.

http://www.microsoft.com/en-us/download ... x?id=38826

Surface Ethernet Adapter.zip bzw. Surface Gigabit Ethernet Adapter.zip

Ich probiere jetzt die Netzwerkinstallation über den Docker. Vielleicht ist der alte Guide mittlerweile überholt.

Gruß Viper

kad
Beiträge: 360
Registriert: 10. Dez 2009, 10:42
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von kad » 20. Mär 2015, 16:10

Ja mit diesen Treibern funktioniert es auch nicht. Also über den klassischen Weg:
Hardware Assistent--Spy-Datei auswählen, entsprechendes Spy File des Surface ausgewählt und dann wie gehabt die nicht erkannte Netzwerkkarte mit einem Treiber versucht zu aktualisieren.

Es kommt wieder in Empirum die Fehlermeldung: Es wurdekein passender Eintrag gefunden, egal welchen der beiden Treiber ich versuche!!?? Wie hast du das denn geschafft? oder hast du einen anderen weg gewählt um den treiber für die EPE Phase zu konfigurieren?

Gruss

Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Viper9000 » 20. Mär 2015, 20:36

Hi,

dieser Treiber hat nix mit EPE zu tun. Du pflegst nie einen EPE Treiber mit der Empirum Treiberverwaltung. Hast du den aktuellen Kernel?

Gruß Viper

PS: Geht tatsächlich über den Docker. Hatten am Anfang keinen und haben es später nie mehr versucht.

kad
Beiträge: 360
Registriert: 10. Dez 2009, 10:42
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von kad » 23. Mär 2015, 09:43

Hallo

Ja ok da hab ich was missverstanden betreffend EPE und Treiber. Also den aktuellen Kernel habe ich (3.14.4 gentoo 3.69)
Oder gibt es einen neueren?

Danke und Gruss

Viper9000
Beiträge: 307
Registriert: 13. Okt 2005, 20:44
Kontaktdaten:

Re: Windows 10 Technical Preview

Beitrag von Viper9000 » 23. Mär 2015, 10:24

Hi,

nehmen wir auch:

und folgende Parameter:
ramdisk_size=328192 init=/bin/minit CONSOLE=/dev/tty1 vga=0x317 root=/dev/ram0 rw quiet irqpoll reboot=bios EIS_REINSTALLALLOW=0 EIS_DEBUGMODE=10 EIS_PALIGN=16384 EPE_ZEROMBR=1 EPE_SEC=ntlm EPE_LOAD_MODULES=cdc_ether,r8152

Gruß

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 11 Gäste