Seite 1 von 1

Verständnisfrage os.ini.pxe

Verfasst: 25. Feb 2020, 09:35
von clippa
Hallo Forum,

wir haben gelegentlich das Problem, dass ein Client keinen PXE Boot macht da von der vorherigen Installation noch eine os.ini.pxe existiert welche IsActive=False setzt. Nach dem Löschen der Datei startet PXE/WinPE.

Die os.ini.pxe wird ja auch von keinem der Syncjobs gelöscht, wie ist hier die genaue Funktion bzw. Vorgehensweise? Wird die zu verwendende Datei, also os.ini oder os.ini.pxe, durch den "timestamp" oder die "UpdateTime" gesteuert?
Was könnten wir tun um das Problem zu vermeiden?

Danke,
Chris

Empirum 19.0.2
Depots im offline Modus
OS_QuickSync Day+Night

Re: Verständnisfrage os.ini.pxe

Verfasst: 26. Feb 2020, 09:01
von Joachim Bienwald
Hallo Chris,

die beiden Dateien enthalten Zeitstempel-Angaben. Anhand dieser Angaben kann der PXE Dienst entscheiden welche Information verwendet werden soll. Hat die os.ini.pxe einen neueren Zeitstempel wird der Aktivierungswert aus dieser Datei genommen. Wird der Client neu aktiviert, sollte der Zeitstempel in der os.ini neuer sein und die os.ini.pxe wird ignoriert. Bis irgendwann der Client wieder ein PXE-Off an den PXE Dienst auf dem Depot schickt und der PXE-Dienst die os.ini.pxe aktualisiert.

Gruß
Joachim

Re: Verständnisfrage os.ini.pxe

Verfasst: 26. Feb 2020, 09:50
von clippa
Vielen Dank Joachim!
Dann werde ich beim nächsten Problem mal darauf achten.

Re: Verständnisfrage os.ini.pxe

Verfasst: 03. Mär 2020, 11:25
von clippa
Jetzt habe ich wieder so einen Fall, der Rechner wurde am 21.02. neu instaliert und soeben erneut aktiviert.

Die os.ini.pxe ist vom 21.02.:
timestamp=1582289292
UpdateTime=2020.02.21 08:55:39

Die os.ini ist vom Zeitpunkt der Aktivierung, also 03.03.:
timestamp=1582271739
UpdateTime=2020.02.21 08:55:39

Dass der nicht startet ist klar, wegen dem timestamp. Aber hätte nicht die UpdateTime aktualisiert werden müssen, auf den Zeitpunkt der Aktivierung?