Seite 1 von 1

Win 7 Image Deploy oobe bricht ab

Verfasst: 20. Mär 2020, 09:48
von Christian Harms
Hallo zusammen,
Ich hab ein Win 7 Image erzeugt. Beim Zurückspielen auf ein System oder das gleich erhalte ich die Fehlermeldung das die oobe Phase nicht verarbeitet werden kann. Die Antwortdatei ist die emp. Standard und wurde nicht verändert. Binde ich die VHD ein und Starte diese läuft diese normal durch. Nur beim Verteilen gibt es denn fehler.

Hat jemand eine Idee ?


Mit freundlichen Grüßen

Christian Harms

Re: Win 7 Image Deploy oobe bricht ab

Verfasst: 23. Mär 2020, 16:49
von Christian Harms
Anbei der Inhalt der Antwortdatei:

<?xml version='1.0' encoding='utf-8'?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="specialize" wasPassProcessed="true">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OEMInformation>
<Manufacturer>Matrix42 AG</Manufacturer>
<SupportURL>http://www.matrix42.de</SupportURL>
</OEMInformation>
<ComputerName></ComputerName>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Identification>
<JoinWorkgroup>test</JoinWorkgroup>
</Identification>
</component>
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "net user Administrator /active:No" "Enable built-in Administrator account""</Path>
<Order>1</Order>
<Description>Prepare System.</Description>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "reg add ""HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"" /v EnableLUA /t REG_DWORD /d 0 /f" "Registry - Disable LUA""</Path>
<Order>2</Order>
<Description>Prepare System.</Description>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "reg add ""HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3"" /v 1806 /t REG_DWORD /d 0 /f" "Registry - Add security settings for current user""</Path>
<Description>Security Setting - Internet Zone - Enable launching applications</Description>
<Order>3</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "reg add ""HKLM\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3"" /v 1806 /t REG_DWORD /d 0 /f" "Registry - Add security settings for local machine""</Path>
<Description>Security Setting - Internet Zone - Enable launching applications</Description>
<Order>4</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "reg add ""HKLM\SOFTWARE\Policies\Microsoft\Internet Explorer\Security"" /v DisableSecuritySettingsCheck /t REG_DWORD /d 1 /f" "Registry - Disable security check""</Path>
<Description>Security Setting - Disable security check</Description>
<Order>5</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "netsh advfirewall firewall add rule name=""Matrix42 UAF Host"" dir=in action=allow program=""C:\UAF\Matrix42.Platform.Service.Host.exe"" enable=yes" "Adding firewall settings""</Path>
<Description>Allow Matrix42 UAF Host in Windows Firewall</Description>
<Order>6</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "reg add ""HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU"" /v NoAutoUpdate /t REG_DWORD /d 1 /f" "Registry - Disable Auto update""</Path>
<Description>Disable automatic updates</Description>
<Order>7</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
<RunSynchronousCommand wcm:action="add">
<Path>cmd /c "C:\UAF\ExecuteCommand.cmd "C:\UAF\EmpirumPEAgent.bat" "Installing Empirum PE Agent service""</Path>
<Description>Installing PE Agent as a Windows service.</Description>
<Order>8</Order>
<WillReboot>OnRequest</WillReboot>
</RunSynchronousCommand>
</RunSynchronous>
</component>
</settings>
<settings pass="windowsPE" wasPassProcessed="true">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>de-DE</UILanguage>
</SetupUILanguage>
<InputLocale>de-DE</InputLocale>
<SystemLocale></SystemLocale>
<UILanguage>de-DE</UILanguage>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserData>
<AcceptEula>true</AcceptEula>
<FullName>LocalAdmin</FullName>
<Organization>
</Organization>
<ProductKey>*SENSITIVE*DATA*DELETED*</ProductKey>
</UserData>
<DiskConfiguration>
<WillShowUI>OnError</WillShowUI>
<Disk>
<DiskID>0</DiskID>
<WillWipeDisk>false</WillWipeDisk>
<ModifyPartitions>
<ModifyPartition>
<Order>1</Order>
<PartitionID>1</PartitionID>
<Letter>C</Letter>
</ModifyPartition>
</ModifyPartitions>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
<InstallFrom>
<Path>\\xxx\EmpInst$\Sys\win7\x64\pro\1_fa8540b5-432e-4f22-a1ae-7a2cb58a81d3\de-DE\VISTADVD\sources\install.wim</Path>
<MetaData wcm:action="add">
<Key>/IMAGE/INDEX</Key>
<Value>1</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
</settings>
<settings pass="oobeSystem" wasPassProcessed="true">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<ProtectYourPC>3</ProtectYourPC>
<SkipUserOOBE>true</SkipUserOOBE>
<NetworkLocation>Work</NetworkLocation>
</OOBE>
<!-- changes expected by package script -->
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "C:\UAF\vcredist_x64.exe /q /norestart" "Installing C++ redistributable""</CommandLine>
<Description>Installing C++ redistributable</Description>
<Order>1</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "C:\UAF\NDP461-KB3102436-x86-x64-AllOS-ENU.exe /q /lang:enu" "Installing .Net Framework 4.6.1""</CommandLine>
<Description>Installing DotNet Framework 4.6.1</Description>
<Order>2</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "C:\Windows\System32\wusa.exe C:\UAF\Win7AndW2K8R2-KB3191566-x64.msu /quiet /norestart" "Installing Windows Management Framework 5.1""</CommandLine>
<Description>Installing WMF 5.1</Description>
<Order>3</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "reg.exe ADD ""HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"" /v AutoLogonCount /t REG_DWORD /d 0 /f" "Ensure no more auto logons""</CommandLine>
<Description>Ensure no more auto logons</Description>
<Order>4</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "sc create ""Matrix42 UAF Host for PE Agent"" binpath= ""C:\UAF\Matrix42.Platform.Service.Host.exe"" start= auto" "Setup Host service to run PE Agent in Windows""</CommandLine>
<Description>Setup Host service to run PE Agent in Windows</Description>
<Order>5</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "reg.exe ADD ""HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System"" /v EnableLUA /t REG_DWORD /d 1 /f" "Disable UAC for first logon commands""</CommandLine>
<Description>Enable UAC after first logon commands</Description>
<Order>6</Order>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cmd /c "C:\UAF\ExecuteCommand.cmd "shutdown /r /t 0 /f" "Reboot computer (implicitly: log off auto logon user)""</CommandLine>
<Description>Reboot computer (implicitly: log off auto logon user)</Description>
<Order>7</Order>
</SynchronousCommand>
</FirstLogonCommands>
<AutoLogon>
<Password>*SENSITIVE*DATA*DELETED*</Password>
<!-- changes expected by package script -->
<LogonCount>7</LogonCount>
<!-- changes expected by package script -->
<Enabled>true</Enabled>
<Username>LocalAdmin</Username>
</AutoLogon>
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>*SENSITIVE*DATA*DELETED*</Password>
<DisplayName>Local Admin</DisplayName>
<Group>Administrators</Group>
<Name>LocalAdmin</Name>
</LocalAccount>
</LocalAccounts>
<AdministratorPassword>*SENSITIVE*DATA*DELETED*</AdministratorPassword>
</UserAccounts>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
</settings>
<settings pass="offlineServicing" wasPassProcessed="true">
<component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DriverPaths>
<PathAndCredentials wcm:keyValue="1" wcm:action="add">
<Path>C:\EmpirumAgent\Drivers</Path>
</PathAndCredentials>
</DriverPaths>
</component>
</settings>
</unattend>