Patch Managementv3 - kein Scan, kein Fix

Willkommen in unserer deutschsprachigen Anwendergemeinde.
Stellen Sie ruhig ihre Fragen oder teilen Sie ihr Wissen mit anderen.

Moderator: hdroege

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 27. Dez 2017, 15:07

Hallo zusammen,
bin neu hier im Forum und relativ neu in Empirum.
Mir geht es um das Patchmanagement v3.
(Sorry für die Frage die kommt...auf die es vielleicht eine ganz einfache Antwort gibt(?!))

Ich hoffe sehr auf ein wenig Unterstützung...zumindest Gedankenanstoß.

Folgende ist meine Situation:
Nachdem ich:
1- Software Pakete (Scan und Fix) hinzugefügt,
2- Patch-Gruppe zu einer Zuweisungsgruppe mit pcs hinzugefügt,
3- unter den Verteilungsoptionen beider SW-Pakete passende Zeiträume festgelegt habe
4- die ganze Zuweisungsgruppe aktiviert habe,
funktionieren das scannen und das fix immer noch nicht. Ich habe mehrmals das best-practice pmv3 gelesen und die Einstellungen überprüft.

Hat jemand noch eine Idee?

Danke für Eure Antworten,
SM

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 28. Dez 2017, 14:42

Was genau geht denn nicht?
Starten die Pakete nicht?
Gibt es Meldungen im SWDepotLog oder SetupErrorLog?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 29. Dez 2017, 11:26

Hallo,
weder im SWDEpotLog noch im SetupErrorLog gibt es Meldungen bezogen auf meinen "Anstoß". Ab und zu ist ein scan oder ein fix zu lesen aber das hat mMn nichts mit meine Konfiguration zu tun.

Ob die Pakete starten das ist eine gute Frage. Ich erkenne wenig/nichts.
Ich habe, auf dem pc (...NB-006) wo die Patches drauf sollen, im Ordner C:\EmpirumAgent\PatchManagement_v3\Logs\, eine log-Datei gelesen (siehe attachment PM3Client.log). In dieser Logdatei ist der Begriff "fix" zu lesen und es werden mehrere Patchgruppen genannt. Meine ist/Mir geht es um die Test_NB Patchgruppe.

Übrigens:
1. Die andere Patchgruppen (alle außer Test_NB) sind entweder von andere Mitarbeiter erstellt worden und/oder von Empirum selbst.
2. (Info nebenbei: an der Stelle bin ich mir persönlich nicht sicher ob die P_All-Patches Patchgrupe standarmäßig von Empirum immer vorhanden ist/beim patchen immer hinzukommt).
3. Die andere Patchgruppen (alle außer Test_NB) befinden sich innerhalb Management > Administration > Zuweisungsgruppen.
4. Meine Gruppe(n) befindet sich innerhalb Management > Konfiguration > Konfigurationsgruppen. Siehe attachment "Untergeordnete Gruppe...".


Für mich sieht es so aus (laut eben genannte Logdatei "PM3Client.log") als ob Empirum alle/mehrere Patchgruppen (bzw. dessen Patches) aufeinmal fürs "fixen" in Betracht nimmt.
Unter den Verteilungsoptionen der Scan- und Fix-Softwarepakete innerhalb meiner Untergeordneten Gruppe (...-NB-006) habe ich individuelle Zeitangaben eingestellt die nichts mit den Zeitangaben in PM3Client.log zu tun haben.
Laut meiner Konfiguration (Siehe attachment "Untergeordnete Gruppen...") muss Empirum nur die Test_NB nehmen wenn ich meine Gruppe aktiviere. Mehr habe ich selbst nicht angestoßen.

Verstehe ich da was falsch? ich weiß dass Empirum in Prinzip das fixt je nachdem was das Ergebnis aus dem Scan geworden ist. Z.B. je nachdem was die lastScanResult.xml liefert. In der lastscanresult.xml sind jede Menge missing pathes zu lesen. Die lastScanresult hat diese missing Angaben schon mehrere Wochen anscheinend. Das da was gefixt wurde bzw dass die patches installiert wurden, davon erkenne ich nix.

Es klingt sogar vll ein wenig verwirrend alles und ich bin quasi ein Neuling im Gebiet.
Dateianhänge
Untergeordnete Gruppe innerhalb Konfigurationsgruppen.png
(6.28 KiB) 237-mal heruntergeladen
PM3Client.log - Editor.png
(8.11 KiB) 238-mal heruntergeladen

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 29. Dez 2017, 11:38

Also werden anscheinend missing patches erkannt.
Dann geben Sie diese Patches mal für die zugeordnete Patchgruppe frei.
Entweder unter Konfiuration/Patch Management oder direkt in den Eigenschaften des Clients.
Dann noch mal SCAN und FIX via REINSTALL anstoßen (Rechtsklick auf Client).
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 29. Dez 2017, 12:50

Hallo vielen Dank für die Antwort.

Ich habe über die client properties unter Registerkarte "patches", missing patches aufgeklappt dann folgendes gemacht:
einige patches angewählt dann Rechtsklick > Add to group > MeinePatchgruppe. Gebe ich die patches so für die zugeordnete Gruppe frei? So wie Sie es meinen?

G

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 29. Dez 2017, 12:57

Genau.
Sollten Sie die Untergruppe TEST nutzen bitte darauf freigeben.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 29. Dez 2017, 13:04

Hallo,
ich verwende die Untergruppe Test innerhalb der zugeodneten Patchgruppe. Allerdings habe ich die missing patches direkt der Inkludieren Untergruppe hinzugefügt.

Ich muss sagen im SWDepoLog sehe ich leider nichts.
Die lastscanresult hat nichts bzw hat das heutige Änderungsdatum nicht.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 29. Dez 2017, 14:23

Dann haben Sie das Reinstall vom Scan nicht richtig gestartet.
Sehen Sie sich mal in diesem Video an wie man das zu Testzwecken via Reinstall anstößt:
https://youtu.be/Ye3qyy-vEDg

Generelle Empfehlung: Sollten Sie noch nicht auf Empirum 17.0.2 sein unbedingt updaten.
Das gesamte Patch Management wurde erheblich verbessert (Auto-Freigabe-Prozess, Reports, Geschwindigkeit).
Und man muss eh alles noch mal neu konfigurieren wenn man auf dieses neue PM schwenkt.
Also keine Arbeit mit einer Vorgängerversion verschwenden!
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 05. Jan 2018, 11:23

Vielen Dank für Ihre Antworten und fürs Video/Link.

Ich werde die Tage dann nochmal reinschauen und gucken ob ein Fix startet.

Bisher konnte ich folgendes beobachten:

- In der Logdatei C:\EmpirumAgent\PatchManagement_v3\Logs\PM3ClientClientname.log steht (nach dem scannen) zum Schluß folgendes: "No fixable missing patches found"

- Mit PC > Reinstall > Scan, wird sehr wohl ein Scan durchgeführt (ca 45 min später)

- In der Registerkarte Patches (pc > properties) werden jede Menge missing patches aufgelistet.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 05. Jan 2018, 11:40

Dann sollten Sie zum Testen einen echten Push auslösen da anscheinend der Checkintervall im Agenten bei Ihnen auf 45 min. steht. Oder ein Testtemplate für den Agent mit 1 min. Intervall erstellen und dem Testclient zuweisen.

Ist Ihr System denn auf Version 17.0.2?
Sollte es unbedingt sein wenn Sie das Patch-Thema nun angehen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 05. Jan 2018, 14:12

Hallo,

nein meine Version ist die 16.1.0.4332.

Dieser Checkintervall damit ist doch dieser Polling Intervall gemeint oder?

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 05. Jan 2018, 15:26

Dann würde ich vor weiteren Tests auf jeden Fall updaten da das jetzt von Ihnen verwendete PM eh in einigen Monaten nicht mehr funktionieren wird und das neue auch viel besser ist.

Ja, das ist der Polling Intervall.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 06. Jan 2018, 21:13

Hallo,

in dem Video/Link was Sie gepostet haben, wird in Min 0:48 eine Synchronisation gemacht. Was genau wird da synchronisiert?
Könnten Sie mir das bitte beantworten?

Bei uns, unter Back End Tasks, wurde der letzte erfolgreiche Katalog Sync am 11.12.17 gemacht. In DBUtil unter patchmanagement v3 ist die Konfiguration so dass eine Synchronisation täglich statt finden soll.
Auch das verstehe ich nicht.

Sorry für die Fragen.

Danke,

S

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7411
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von Hendrik_Ambrosius » 07. Jan 2018, 10:45

Damit wird die Liste der verfügbaren Patches synchronisiert.
Dann ist bei Ihnen auf jeden Fall etwas nicht OK.
Aber auch der Sync ist mit der 17.0.2 erheblich schneller und besser geworden > updaten!
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

tweetail
Beiträge: 25
Registriert: 25. Dez 2017, 15:58
Kontaktdaten:

Re: Patch Managementv3 - kein Scan, kein Fix

Beitrag von tweetail » 07. Jan 2018, 14:42

Das Gefühl habe ich auch, das irgendwas nicht ok ist.

Ok die Liste der verfügbaren patches synchronisiert.

Noch eine Frage:

Zwischen welche PC´s/Server findet die synchronisation statt?




Danke für die Antwort.

Antworten

Zurück zu „Deutsch“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste