Installierte Version wird nicht angezeigt

Antworten
CB_PS
Beiträge: 23
Registriert: 06. Dez 2010, 13:48
Kontaktdaten:

Installierte Version wird nicht angezeigt

Beitrag von CB_PS » 06. Jan 2014, 13:33

Hallo,
habe hier Probleme mit einem MSI-Paket. Flash 11.9.900.170, allerdings war das mit der Version vorher meines Wissens auch schon so...
Packetierung und Installation läuft ohne Probleme, allerdings wird das Installierte Paket weder im Swdepot noch im Computerstatus in der MMC angezeigt. Die Windows Programmübersicht weiß auch nichts davon.
Der Flashplayer ist wirklich installiert, die Adobe-Seite bestätigt mir, dass ich auf dem neuesten Stand bin.

Kennt jemand das Problem?

Grüße aus PS

marc.schneider
Beiträge: 224
Registriert: 29. Mär 2010, 12:26
Wohnort: Magdeburg
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von marc.schneider » 08. Jan 2014, 14:39

Hallo CB_PS,

hast Du die MSI mal manuell ausgeführt? Wenn dies einwandfrei funktioniert, dann bitte die vollständige setup.inf posten.

Beste Grüße aus Magdeburg
Marc
Ärztekammer Sachsen-Anhalt
39120 Magdeburg
http://www.aeksa.de
--
Matrix42 Empirum v19.0.3 UEM-Agent 2003.2
Datenbank: MSSQL 2017
Master-Server: Win Server 2012 R2
Web-Depot: Win Server 2012 R2 (nur via https erreichbar)
Clients: Win10 x64

CB_PS
Beiträge: 23
Registriert: 06. Dez 2010, 13:48
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von CB_PS » 10. Jan 2014, 07:28

Hallo,

die MSI wird normal ausgeührt und Installiert. Ohne Paket drumherum, aber auch mit /S3 als Schalter zum beobachten.

Das Problem besteht sowohl beim Flash mit ActiveX als auch beim Flash als Plugin.

Code: Alles auswählen

[SetupInfo]
Author                  =x
CreationDate            =06.01.2014 09:13:55 
Method                  = MSI
Command line options    =/S3

[Setup]
Version=14.2
ShowCaption=1
BlockInput=0
Platform=x86

[Application]
ProductName=Flash Player
DeveloperName=Adobe
Version=11.9.900.170
Revision=0
SetupName=%ProductName% %Version% %SetupWizard%
UninstallKeyName=%DeveloperName% %ProductName% %Version%
UninstallDisplayName=%ProductName% %Version%
UninstallString=%ReinstallString% /U
ReinstallString="%CommonSetupDir%\Setup.exe" "%App%\%SetupInfDir%\Setup.inf"
ReinstallMode=1
SrcDir=..
ApplicationDir=%ProgramFilesDir%\%ProductName%
SetupInfDir=Install
DataDir=%Personal%
AskUninstallOld=1
ShellLinks=1
CommonShellLinks=1

[Environment]
V_MSIInstallerID=82E240141ACC741468F9E929B8830FC4
ReInstSuccessMessage1031=Die Konfiguration wurde erfolgreich abgeschlossen.
ReInstSuccessMessage1031_1=Die Konfiguration wurde abgeschlossen.
ReInstSuccessMessage1033=Configuration completed successfully.
ReInstSuccessMessage1033_1=Configuration completed.
MSILogFile=%Temp%\MSI_%ProductName%.%Version%.%Revision%.log
CommonSetupDir=%CommonFilesDir%\Setup%SetupBits%
V_MachineValuesPath=\\%EmpirumServer%\Values$\MachineValues\%DomainName%
V_UserValuesPath=%HKLM,"Software\matrix42\Software Depot","HomeServer"%\Values$\UserValues\%UserDomain%

[Disks]
1=%Disk1%

[Options]
Installer = %InstallerName%, COPYALWAYS, Installer, "%InstallerDesc%"
Product   = %ProductName%,   COPYALWAYS, Product,   "%ProductDesc%"

[Installer]
1:..\..\..\..\User\Setup.exe,          %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupDeu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupEnu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:%SetupInfDir%\Setup.inf,                             , NORMAL,                                             0
1:%Temp%\Setup64.exe,                  %CommonSetupDir%\Setup.exe, OPTIONAL NOSIZEWARNING SETUP ALWAYS WINDOWS64,      0

[Product]
#Set:Product, DONTDELETE
#Set:Uninstall, DELETE
#Set:ChangeMSISourcelist, DONTDELETE

[Set:Product]
Del "%MSILogFile%"
If DoesRegKeyExist ("HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "1" | DoesRegKeyExist ("HKLM,SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "1" Then "RepairMSI" Else "InstallMSI" EndIf

[RepairMSI]
Call MsiExec /Fvomus "%SRC%\install_flash_player_11_active_x.msi"   REBOOT=REALLYSUPPRESS ARPSYSTEMCOMPONENT=1 /quiet /norestart /Li "%MSILogFile%"
If %ErrorLevel% == "3010" Then "RebootRequired" EndIf
If DoesTextInFileExist ("%ReInstSuccessMessage1031%", "%MSILogFile%") == "0" & DoesTextInFileExist ("%ReInstSuccessMessage1031_1%", "%MSILogFile%") == "0" & DoesTextInFileExist ("%ReInstSuccessMessage1033%", "%MSILogFile%") == "0" & DoesTextInFileExist ("%ReInstSuccessMessage1033_1%", "%MSILogFile%") == "0" Then "AbortMSIInst" EndIf
Del "%MSILogFile%"

[InstallMSI]
Call MsiExec /I "%SRC%\install_flash_player_11_active_x.msi"   REBOOT=REALLYSUPPRESS ARPSYSTEMCOMPONENT=1 /quiet /norestart /Li "%MSILogFile%"
If %ErrorLevel% == "3010" Then "RebootRequired" EndIf
If DoesRegKeyExist ("HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "0" & DoesRegKeyExist ("HKLM,SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "0" Then "AbortMSIInst" EndIf
Del "%MSILogFile%"

[Set:Uninstall]
-Del "%MSILogFile%"
If DoesRegKeyExist ("HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "1" | DoesRegKeyExist ("HKLM,SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{41042E28-CCA1-4147-869F-9E928B38F04C},UnInstallString") == "1" Then "AbortMSIUnInst" EndIf
If %ErrorLevel% == "3010" Then "RebootRequired" EndIf
-Call MsiExec /X {41042E28-CCA1-4147-869F-9E928B38F04C} REBOOT=REALLYSUPPRESS /quiet /norestart /Li "%MSILogFile%"

[RebootRequired]
SetReboot 1
-SetReboot 1

[AbortMSIInst]
ErrorLogMsg %ErrorLogMessage% ErrorLevel: %ErrorLevel%
Abort

[AbortMSIUnInst]
-Abort
-ErrorLogMsg %ErrorLogMessage% ErrorLevel: %ErrorLevel%

[SET:ChangeMSISourcelist]
ReplaceRegValue (HKCR,"Installer\Products\%V_MSIInstallerID%\Sourcelist","LastUsedSource","\\%EmpirumServer%","\\%%EmpirumServer%%", 1)
ReplaceRegValue (HKCR,"Installer\Products\%V_MSIInstallerID%\Sourcelist\Net","1","\\%EmpirumServer%","\\%%EmpirumServer%%", 1)
Grüße aus PS

Benutzeravatar
r.wiegel
Beiträge: 855
Registriert: 05. Feb 2010, 13:45
Wohnort: Regensburg
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von r.wiegel » 10. Jan 2014, 08:53

Hallo,

in der Setup.inf vermisse ich UserKeyName und MachineKeyName sowie weitere Zeilen...

Viele Grüße
Roman
Viele Grüße
Roman Wiegel
IT-Consultant

MR Datentechnik - Vertriebs- und Service GmbH
Client Management

marc.schneider
Beiträge: 224
Registriert: 29. Mär 2010, 12:26
Wohnort: Magdeburg
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von marc.schneider » 10. Jan 2014, 09:18

allerdings wird das Installierte Paket weder im Swdepot noch im Computerstatus in der MMC angezeigt. Die Windows Programmübersicht weiß auch nichts davon.
Beschreib' mal bitte genauer was Du damit meinst. Bei mir funktioniert Dein Paket (Installation) einwandfrei.

Beste Grüße
Marc
Ärztekammer Sachsen-Anhalt
39120 Magdeburg
http://www.aeksa.de
--
Matrix42 Empirum v19.0.3 UEM-Agent 2003.2
Datenbank: MSSQL 2017
Master-Server: Win Server 2012 R2
Web-Depot: Win Server 2012 R2 (nur via https erreichbar)
Clients: Win10 x64

Marcus_B
Beiträge: 126
Registriert: 15. Jul 2008, 13:02
Wohnort: Berlin
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von Marcus_B » 14. Jan 2014, 09:01

Hallo,

Roman hat recht,
Dort fehlen einige Einträge, welche standardmäßig in den Vorlagen hinterlegt sind.
Am besten noch einmal mit einer MAtrix42 eigenen Vorlage installieren.

Viele Grüße
Marcus

CB_PS
Beiträge: 23
Registriert: 06. Dez 2010, 13:48
Kontaktdaten:

Re: Installierte Version wird nicht angezeigt

Beitrag von CB_PS » 15. Jan 2014, 08:43

Hallo,
die fehlenden Einträge warens wohl. :)
Normalerweise werden aber die meisten unserer Pakete zur Übersichtlichkeit so stark gekürzt...

Viele Grüße & Dankeschön

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 6 Gäste