!GELÖST!- Softwareinstallation nach Download hängt

Antworten
Yilmaz
Beiträge: 188
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

!GELÖST!- Softwareinstallation nach Download hängt

Beitrag von Yilmaz » 23. Mai 2018, 16:15

Hallo Zusammen,

sobald ich ein Paket zuweise und aktiviere wird diese auch auf den Client heruntergeladen aber die Installation/Deinstallation startet nicht.
Habe den Aktivierung-Dienst neugestartet ohne Erfolg. Dem Client ist auch der richtige Server zugewiesen in der Zuweisungsgruppe.

Unter Log anzeigen steht Modus=Download, Ergeniss=Success

Woran kann es liegen?
Zuletzt geändert von Yilmaz am 28. Mai 2018, 15:49, insgesamt 1-mal geändert.
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Frank Dethlefsen
Beiträge: 433
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Softwareinstallation nach Download hängt

Beitrag von Frank Dethlefsen » 23. Mai 2018, 17:22

Moin!

Nicht selten fehlt hier die Betriebssystemfreigabe in den Paketeigenschaften. Achtung: Auf der Registerkarte, in dem das Paket eingehängt ist, muss die Betriebssystemfreigabe auch gegeben sein.

Des Weiteren könnte es eine stichtagsgesteuerte Verteilung in der Zukunft sein. Der Download wird aber schon vorher gemacht.

Des Weiteren könnte in den Paketeigenschaften unter Sonstiges ggf. „nur nach Benutzer" oder „nur vor Benutzeranmeldung" gesetzt sein. Das führt ggf. auch zu einem Download.

Im Agent-Template sollte man die Option "Direkt nach Download installieren aktivieren". Andernfalls kann die Installation bis zum nächsten Pollintervall verzögert werden.

Es gibt noch weitere Konstellationen. Leider ist der Agent hier nicht sehr gesprächig. Ein Blick in die Logdatei C:\Windows\System32\Empirum\Eris.log könnte ggf. weitere Gründe hervorbringen.
:roll:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Yilmaz
Beiträge: 188
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Softwareinstallation nach Download hängt

Beitrag von Yilmaz » 24. Mai 2018, 11:12

Hallo Frank,

also die unten genannten Punkte habe ich mal nachgeprüft:
- Paketeigenschaften sind die Betriebssysteme die auch verwendet werden angehakt . Auch auf der Registerkarte, in dem das Paket eingehängt ist, ist ebenfalls die Betriebssystem Freigabe angehakt.

- Es ist kein stichtagsgesteuerte Verteilung genutzt.

- Auch unter Sonstiges ggf. „nur nach Benutzer" oder „nur vor Benutzeranmeldung" ist nicht gesetzt.

- Im Agent-Template ist die Option "Direkt nach Download installieren aktivieren" gesetzt.

- In der Eris.log konnte ich für das Paket die Aktion den Eintrag finden:
[Debug] [MxLog.LogS] SW.Engine DDC: STROEER, DJ1E43J, *, Braintribe\iDMSClient\1.0, , UNINSTALL USER: Felle HOST: DJ1E43JDOM: STROEER STATUS: ADD (5272)
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Frank Dethlefsen
Beiträge: 433
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Softwareinstallation nach Download hängt

Beitrag von Frank Dethlefsen » 24. Mai 2018, 13:05

Sind vielleicht in der Registerkarte unter Sicherheit Gruppen AD-Gruppen hinterlegt, in dem das Paket eingefügt ist?

ist vielleicht im Agent-Template ein Installationszeitraum aktiviert.

Man kann im Log sehen, das es um einen Uninstall geht. Ist vielleicht schon eine neuere Version installiert?
Wenn ja, dann ist das vielleicht ein bekannter Fehler, der mit dem PostHotfixInstaller 17.0.2 gelöscht wird
Siehe PRB30657: An older version of a package can not be uninstalled via Empirum Advanced Agent.
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Yilmaz
Beiträge: 188
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Softwareinstallation nach Download hängt

Beitrag von Yilmaz » 24. Mai 2018, 13:59

Hallo Frank,

danke für die Lösungsansätze. Der Fehler lag daran das eine Deinstallation angestoßen wurde aber die Software als manuelle Installation durch den User erfolgt ist.
Daher konnte das Paket die Deinstallation nicht starten, da der Productname, Developername etc. nicht mehr übereinstimmte.

Nach einem Reinstall wurde das Paket installiert und auch erfolgreich deinstalliert werden.
Das Problem lag beim User an seiner Installation.

Danke nochmals für die Unterstützung.
Gruss
Yilmaz
2nd-Level Support

Antworten

Zurück zu „Empirum“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste