Installations-Prompt auch ungewollt (nach) Deinstallation

Antworten
Sascha Offe
Beiträge: 39
Registriert: 05. Aug 2015, 00:04
Kontaktdaten:

Installations-Prompt auch ungewollt (nach) Deinstallation

Beitrag von Sascha Offe » 24. Jul 2017, 17:21

Folgendes: Paket soll beim (Update)Installieren eines Paketes den Anwender nach Erlaubnis fragen (weil offene Programminstanzen vom setup zwangsweise beendet werden).

Funnktioniert soweit auch.
Bei der Deinstallation soll der User nicht gefragt werden.

Am Ende der Deinstallation (nachdem die Dateien usw. weg sind) ploppt aber doch wieder der Installation-Prompt auf (den man auch nicht Abbrechen kann), Paket wird also wieder installiert (nein, kein Enforce o.ä. in den Dsitrubution Commands).

Hab schon div. Workbrounds versucht (überall DONTDELETE, ein Exit hinzugefügt...), ohne Erfolg.

Code: Alles auswählen

AskUninstallOld=0
DisableCancelButton=0
...

[Product]

#Set:Product
#Set:Installation, DONTDELETE
#Set:AskUser, DONTDELETE
#Set:StartInstallation, DONTDELETE
#Set:Deinstallation, DELETE
#Reg:OnUninstallProduct, DELETE
#Reg:Product
#Ini:Product
#Security:Product

[Set:Product]

[Set:Installation]
If %WindowsUser% <> "" Then "Set:AskUser" Else "Set:StartInstallation" EndIf

[Set:AskUser]
Prompt AskTheUser

[Set:StartInstallation]
...

[Set:Deinstallation]
-Exit
-CallHidden "%Src%\setup.exe"
-AddMeter -1

Sascha Offe
Beiträge: 39
Registriert: 05. Aug 2015, 00:04
Kontaktdaten:

Re: Installations-Prompt auch ungewollt (nach) Deinstallatio

Beitrag von Sascha Offe » 25. Jul 2017, 14:10

Hm, hab das jetzt in einem Testpaket versucht näher zu untersuchen: Zusammengestaucht auf ein Minimum (statt des richtigen Setups des Programm lege ich nur einen leeren Ordner an bzw. lösche ihn wieder) -- dabei tritt das Verhalten natürlich nicht auf :roll:

Naja, vlt. finde ich doch noch was im eigentlichen Paket.

Sascha Offe
Beiträge: 39
Registriert: 05. Aug 2015, 00:04
Kontaktdaten:

Re: Installations-Prompt auch ungewollt (nach) Deinstallatio

Beitrag von Sascha Offe » 26. Jul 2017, 13:18

Konnte es bislang nicht mehr nachstellen (bei Installationen auf echter Hardware). Vielleicht lag es an meiner Test-VM...

Ende des Monologs ;-)

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 29 Gäste