PXE Boot Sub-Depot

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 09:52

Hallo zusammen,

ich benötige mal eure Hilfe. Seit einigen Wochen funktioniert, der PXE Boot über das Sub-Depot nicht mehr.

Option 060 und 043 sind wie folgt konfiguriert

Option 060 PXEClient
Zeichenfolgenwert: PXEClient
Beschreibung: option

Option 43 Herstellerspezifische Informationen
Dateneingabe ... Matrix42 ... (wurde mit PXEOpt43Gen.exe generiert und eingetragen)
Beschreibung Eingebettete, herstellerspezifische Optionen

Der Dienst für das Sub-Depot ist in DBUtil wie folgt konfiguriert
Servermodus: nur PXE (Der Depot-Server ist ein einfacher Mitgliedsserver)
Standard PXE/Image : Default
Dienstmodus: Online

Diese Einstellungen sind identisch mit dem Hauptserver wo PXE funktioniert.

Anbei ein Auszug mit Debugview

00010320 97.00914001 [1712] ThreadId=448 Received datagram from 192.168.21.106:2070
00010321 97.00921631 [1712] ThreadId=448 Found Opcode ReadRequest from 192.168.21.106:2070
00010322 97.00930023 [1712] ThreadId=448 b31aca1c-80f6-49c5-bb08-d2c96a7c116f: Creating connection
00010323 97.00949860 [1712] ThreadId=448 b31aca1c-80f6-49c5-bb08-d2c96a7c116f: Process starting to Listen
00010324 97.00958252 [1712] ThreadId=448 b31aca1c-80f6-49c5-bb08-d2c96a7c116f: Processing RRQ from 192.168.21.106:2070
00010325 97.00967407 [1712] ThreadId=448 Search file for file request <1|2|EPE|mx42.pxe>
00010326 97.00988770 [1712] ThreadId=448 Found full file name E:\Empirum\EmpInst\Wizard\Image\PXEImages\mx42.pxe for file request <1|2|EPE|mx42.pxe>
00010327 97.01004791 [1712] ThreadId=448 sending tsize = 14288
00010328 97.01013184 [1712] ThreadId=448 Sending OACK to 192.168.21.106:2070
00010329 97.01053619 [1712] ThreadId=448 Received TFTP error code0 message TFTP Aborted from 192.168.21.106:2070
00010330 97.01060486 [1712] ThreadId=448 b31aca1c-80f6-49c5-bb08-d2c96a7c116f: Process stopping Listening.
00010331 97.01072693 [1712] ThreadId=448 b31aca1c-80f6-49c5-bb08-d2c96a7c116f: TFTP session stopped
00010332 97.01092529 [1712] ThreadId=2388 Received datagram from 192.168.21.106:2071
00010333 97.01100922 [1712] ThreadId=2388 Found Opcode ReadRequest from 192.168.21.106:2071
00010334 97.01108551 [1712] ThreadId=2388 b57ea7e8-fb3f-4c27-b74f-e225f180fecb: Creating connection
00010335 97.01123810 [1712] ThreadId=2388 b57ea7e8-fb3f-4c27-b74f-e225f180fecb: Process starting to Listen
00010336 97.01132202 [1712] ThreadId=2388 b57ea7e8-fb3f-4c27-b74f-e225f180fecb: Processing RRQ from 192.168.21.106:2071
00010337 97.01140594 [1712] ThreadId=2388 Search file for file request <1|2|EPE|mx42.pxe>
00010338 97.01158142 [1712] ThreadId=2388 Found full file name E:\Empirum\EmpInst\Wizard\Image\PXEImages\mx42.pxe for file request <1|2|EPE|mx42.pxe>
00010339 97.01171112 [1712] ThreadId=2388 Blksize option = 1456
00010340 97.01179504 [1712] ThreadId=2388 Sending OACK to 192.168.21.106:2071
00010341 97.01935577 [1712] ThreadId=2388 Successfully sent file E:\Empirum\EmpInst\Wizard\Image\PXEImages\mx42.pxe (14288 bytes) to 192.168.21.106:2071 in 15 milliseconds (952 bytes/msec).
00010342 97.01942444 [1712] ThreadId=2388 Removing state for 192.168.21.106:2071
00010343 97.01950073 [1712] ThreadId=2388 b57ea7e8-fb3f-4c27-b74f-e225f180fecb: Process stopping Listening.
00010344 97.01960754 [1712] ThreadId=2388 b57ea7e8-fb3f-4c27-b74f-e225f180fecb: TFTP session stopped
00010345 97.09476471 [1712] ThreadId=1768 Removing session b31aca1c-80f6-49c5-bb08-d2c96a7c116f
00010346 97.09488678 [1712] ThreadId=1768 Removing session b57ea7e8-fb3f-4c27-b74f-e225f180fecb

Vielen Dank für eure Mühe
Max

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 10:45

Moin!

Wenn die DHCP Option 43 und 60 verwendet wird, muss der PXE-Dienst im Servermode Kompatibilitätsmodus laufen.
In DBUtil umstellen und den PXE-Dienst auf dem Subdepot neustarten.

http://helpfiles.matrix42-web.de/2015_D ... nts|_____0

:roll:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 11:05

Vielen Dank für die schnelle Rückmeldung. Leider keine Veränderung. Kann ich am Sup-Depot Server erkennen in welchem Modus sich der Dienst befindet ?

Muss evtl. erst ein Sync gelaufen sein, damit der Sup-Depot Server die Dienste Konfiguration bekommt ?

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 11:14

Mach mal ein Foto von der Meldung am Client.
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 11:44

Ich habe jetzt im DBUtil noch mal Änderungen ab Dienstanmeldung vorgenommen aber der Dienst auf dem Sub-Depot startet immer noch als Lokales System.

In DBUtil ist der Onlinemodus aktiviert

Client aus DB gelöscht. Jetzt erscheint er aber nicht mehr unter PXE -> nicht qualifiziert

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 13:42

Kommt beim Client immernoch "Managed by Empirum" ohne Fehlermeldung?
Gibt es die MAC vielleicht noch mal in der DB?
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 13:46

Ja immer noch und nein, das Problem tritt bei allen Test-Systemen auf.

MAC gibt es nicht nochmal.

DebugView ist immer noch

00010329 97.01053619 [1712] ThreadId=448 Received TFTP error code0 message TFTP Aborted from 192.168.21.106:2070

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 14:02

Wer hat denn die IP 192.168.21.106 ?
Laut Screenshot sollte das doch eine 10.x.x.90 sein?
Gibt es vielleicht eine Test- und Prod-Empirum-Umgebung?
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 14:06

00010329 97.01053619 [1712] ThreadId=448 Received TFTP error code0 message TFTP Aborted from 192.168.x.x:2070

Die Meldung bekomme ich in meinem DBGView.log auch ohne das Probleme auftreten.....
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 14:16

Frank Dethlefsen hat geschrieben:Wer hat denn die IP 192.168.21.106 ?
Laut Screenshot sollte das doch eine 10.x.x.90 sein?
Gibt es vielleicht eine Test- und Prod-Empirum-Umgebung?
Ist auch so, ich habe die IP-Adressen vor der Veröffentlichung verändert.

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 12. Mai 2017, 14:23

Gibt es vielleicht, warum auch immer eine zweite Verwaltungsdatenbank?

Andernfalls ist mir erst mal "Game Over". :evil:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 14:26

Frank Dethlefsen hat geschrieben:Gibt es vielleicht, warum auch immer eine zweite Verwaltungsdatenbank?

Andernfalls ist mir erst mal "Game Over". :evil:
Nein, nur auf dem Empirum-Server.

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 12. Mai 2017, 14:36

Weiß nicht, ob es relevant ist. Der TFTP Dienst startet am Empirum-Server deutlich schneller als am SubDepot Server.

skd
Beiträge: 60
Registriert: 12. Mai 2015, 10:11
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von skd » 15. Mai 2017, 09:54

So jetzt geht es ...

Betriebssystem Template und Bootimage aus Konfigurationsgruppe entfernt und wieder hinzugefügt.

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: PXE Boot Sub-Depot

Beitrag von Frank Dethlefsen » 15. Mai 2017, 13:20

Beruhigt mich das es nicht der TFTP-Service war... :wink:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Antworten

Zurück zu „Verschiedenes“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast