Kein Sync der MachineValue ins Depot Server Verzeichnis

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 08. Jun 2017, 14:50

Hallo Zusammen,

folgendes Problem ist mir aufgefallen das Synchronisieren bzw. schreiben der DDC/ini Dateien aus dem MachineValue Ordner nicht auf einige Depotserver gesynct werden.

Z.B. Masterserver\Configurator\Value\MachienValue\Domaine nach Masterserver\...\Values\DepotServer\MachineValues\

Die Ordner sind nicht bei allen Depotservern nur bei einigen leer bis auf die Depotserver.ini
Die Sync-Templates habe ich den Depotservern zugewiesen und erfolgreich installiert und laufen.
Sobald ich eine Datei in das Verzeichnis kopiere (manuell) und über Sync-Monitor synchronisiere schreib dieser das auch rein.

Das läuft aber nicht automatisch. Woran kann es sein?
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 08. Jun 2017, 15:01

Wird von %SYNC_SERVER1%\Configurator\Values\%Computername% oder %SYNC_SERVER1%\Configurator\Values gesynct?
Bei ersterem müssen die Clients dem Depotserver über das "Empirum Server" Tab in den Eigenschaften des Clients oder der Gruppe zugewiesen sein. Sonst werden dort keine DDCs und INIs geschrieben.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 08. Jun 2017, 15:21

Hallo Herr Ambrosius,

folgende Variablen sind gesetzt:

Quelle:
%SYNC_SERVER1%\Configurator\Values\%Computername%
Ziel:
%SYNC_SERVER2%\Configurator\Values

Den Clients ist auch unter Eigenschaften der Empirumserver zugewiesen
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 08. Jun 2017, 15:48

Und sind auf dem Masterserver in den %Computername% Verzeichnissen die INIs und DDCs drin?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 08. Jun 2017, 15:56

Die DDCs und ini-Dateien stehen alle unter \..\Configurator\Value\MachineValue\Domainname\

Unter den jeweligen Depotnamen sind die DDCs und ini-Dateien nicht aufgeführt \..\Configurator\Value\MachineValue\Depotname\

Der Ordner Domainname existiert nicht.
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 08. Jun 2017, 16:38

Dann haben Sie den Clients keine Empirumserver zugewiesen.
Danach sollten die Dateien erstellt und anschließend auch gesynct werden.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 08. Jun 2017, 17:14

Also den Clients ist der Empirumserver zugewiesen:

siehe Screenshot
Dateianhänge
2017-06-08 17_11_46-Eigenschaften für Computer_ DE1CD19253.zip
(1.6 KiB) 124-mal heruntergeladen
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 08. Jun 2017, 20:03

Dann mal Debugview auf den Aktivierungsdienst lauschen lassen, einem der Clients ein Paket zuweisen und aktivieren.
Mal sehen was er dann sagt.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 08. Jun 2017, 20:48

Wie kann ich im Debugview auf Activation Dienst filtern?
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 09. Jun 2017, 12:57

Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 12. Jun 2017, 14:12

Hallo Herr Ambrosius,

hier die Log aus dem dbgview:
Dateianhänge
Log_Activation_DE1CD19252.zip
Log Datei
(1.6 KiB) 103-mal heruntergeladen
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 12. Jun 2017, 23:02

Ich kann da überhaupt keine DDC Aktion im Log finden. Haben Sie wirklich vor dem Aktivieren ein Paket zugewiesen?
Hat sich die DDC unter \..\Configurator\Value\MachineValue\Domainname\ geändert?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Yilmaz
Beiträge: 182
Registriert: 27. Jun 2016, 12:40
Kontaktdaten:

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Yilmaz » 13. Jun 2017, 09:46

Ja, ich habe ein Paket zugewiesen dem Client undden Filter auf den Activation Dienst gesetzt auf dem Masterserver.

Unter ..\Value\MachineValue\Domainname\ wird eine DDC geschrieben.
Unter ..\Value\Depotserver\MachineValue\ wird keine Ordner erzeugt mit Domainname und DDC.

Habe mal einen Client erneut aktivert (DE1CL19245) und dbgview Log gesetzt. Vielleicht ist jetzt mehr zu erkennen?
Dateianhänge
DE1CD19245.zip
(5.29 KiB) 106-mal heruntergeladen
Gruss
Yilmaz
2nd-Level Support

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 13. Jun 2017, 20:32

Leider fehlen im Log die entscheidenden Zeilen nach "In SaveChanges". Bei mir sieht das z.B. so aus:

00001042 5.08989429 [2416] MATRIXACTIVATION : ProcessActivationQueue-ActivationQueue-Dump: IDPK - 1553, ObjectID - 64, ObjectType - 1, Activity - 1, Status - 1, ActFlag - 6, ServerID - 1, ObjectName - PCD1000, DomainName - IMAGOVERUM, MACAddress - 000C29C5970D, OSIniPath - \\SRVWSM001\EmpInst$\Wizard\OS\Auto\3A24B05F\OS.INI
00001043 5.08997917 [2416] MATRIXACTIVATION: before ProcessClient
00001044 5.09257603 [2416] MATRIXACTIVATIONOption OnlyAssignedServers for client 64 in GroupID 62B349BA-0F35-4AD4-82FE-57D5BC3A3880 is true
00001045 5.09572506 [2416] MATRIXACTIVATIONOption OnlyAssignedServers for client 64 in GroupID 85DF0390-E625-457E-AA4D-5BB12B9E8689 is true
00001046 5.09864807 [2416] MATRIXACTIVATIONOption OnlyAssignedServers for client 64 in GroupID EC0DF6A7-295E-4FCB-B36E-A007254FC115 is true
00001047 5.14169407 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before LoadDepotServerList
00001048 5.14171028 [2416] MATRIXACTIVATION: after LoadDepotServerList - ServerCount: 2
00001049 5.14184618 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before GetDepotFilesPath
00001050 5.14187765 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before AddFolderToPath
00001051 5.14195919 [2416] MATRIXACTIVATION:WriteFirstDDCFile: m_sDDCRootFolder:\\SRVWSM001\Values$\
00001052 5.14199114 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before MakeSureFolderExists
00001053 5.14532089 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before CreateDDCFile
00001054 5.14658213 [2416] MATRIXACTIVATION:WriteFirstDDCFile: before pDDC->SaveChanges()
00001055 5.14666843 [2416] In SaveChanges
00001056 5.14984941 [2416] MATRIXACTIVATION: Try to copy file to destination: \\SRVWSM001\Values$\DEPOT1\MachineValues\IMAGOVERUM\PCD1000.ddc
00001057 5.15609217 [2416] MATRIXACTIVATION: Try to copy file to destination: \\SRVWSM001\Values$\Temp\DEPOT1\MachineValues\IMAGOVERUM\PCD1000.ddc
00001058 5.16187191 [2416] MATRIXACTIVATION: before MakeSureVariablesAreUpToDate
00001059 5.16287279 [2416] MATRIXACTIVATION: before WriteClientVariables
00001060 5.16290188 [2416] MATRIXACTIVATION: WriteOSVariable - client_id: 64
00001061 5.16367531 [2416] MATRIXACTIVATION: Write Computer Variables to the ini file
00001065 5.30580378 [2416] MATRIXACTIVATION: Do not write 'SUBDEPOT' to the ini file
00001066 5.30586767 [2416] MATRIXACTIVATION: Do not write 'SUBDEPOT_SERVICES' to the ini file

Da sieht man klar, dass 2 DDC Dateien geschrieben werden. Einmal für das Depot und einmal für QuickSync des Depots.
Zuletzt geändert von Hendrik_Ambrosius am 13. Jun 2017, 20:38, insgesamt 1-mal geändert.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Kein Sync der MachineValue ins Depot Server Verzeichnis

Beitrag von Hendrik_Ambrosius » 13. Jun 2017, 20:35

Was mir gerade noch auffiel: In Ihrem Log steht: "after LoadDepotServerList - ServerCount: 1 "
In meinem Log steht dort eine zwei.
Habe als Empirumserver den Hauptserver und das Depot zugewiesen.
Haben Sie vielleicht nur den Hauptserver und kein Depot unter "Empirumserver" eingetragen?
Sonst ist die Zählung vom Activation Service schon falsch.
Anscheinend erscheint das Schreiben der DDC für den Hauptserver auch nicht im Log.
Das würde auch meine Theorie bestätigen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Antworten

Zurück zu „Verschiedenes“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast