Seite 1 von 1

SAML2 Login URL

Verfasst: 03. Apr 2020, 21:24
von ctearney
We are attempting to configure the SAML2 authentication the login URL needed on the SAML2 providers side is not working. The documentation states using the below but we get an IIS page error once we get handed off from the SAML2 provider to this URL. Also looking at IIS these paths don't exist.

Set the Saml2 response validation url to https://[EnterYourServerDomainName]/m42services/
api/sts/login
• Set the Logout Url to: https:// [EnterYourServerDomainName]/m42services/api/sts/logout

Re: SAML2 Login URL

Verfasst: 18. Mai 2020, 19:30
von ctearney
got it all sorted out. We enabled the External URL settings within the app and then set up a basic Rewrite Rule for Reverse Proxy. This worked well if we manually entered credentials into the login screen but when trying to use the SAML link it failed as the SAML link was being rewritten to the URL of the Self Service Portal. We got that sorted out as well and all is working!

Does anyone know if it is possible (or where is it possible) to hide the "username" & "password" fields that are presented on the login page? We want to force people to the SAML link by making it the only login option. In the Admin Section there are the options for single sign-on and use browser credentials but neither of these impact the view of the username/password fields.