Patch Management v2 Status "deleting"

Moderator: moderators

Gesperrt
ChristophS
Beiträge: 9
Registriert: 11. Nov 2016, 11:17
Kontaktdaten:

Patch Management v2 Status "deleting"

Beitrag von ChristophS » 11. Nov 2016, 11:52

Hallo Zusammen,

wir setzen bei uns im Hause das Matrix42 Workplace Management in der Version 15.1.1.1285 in der DB Version 6.11 ein.
Die Datenbank läuft über einen lokal installierten Microsoft SQL Server 2012.

Ich habe per DButil das Patch Management soweit per Anleitung erfolgreich eingerichtet und habe mich nun daran gemacht, die entsprechenden Patches herunterzuladen.

Leider war ich bei der Auswahl der Patches etwas zu vorschnell und habe dabei auch den Download der 24 Windows 10 Upgrades für Windows 7 bzw. Windows 8.1 gestartet. Da dieser Vorgang das Volumen der Festplatte sprengen würde, habe ich per Rechtsklick -> Delete die Downloads abbrechen wollen.

Seit diesem Zeitpunkt stehen in der Übersicht die 24 Upgrades auf "Deleting".

Wenn ich jetzt im Patchverzeichnis nachsehe (D:\Empirum\Configurator\Packages\PatchManagement_v2\Patches) werden die Dateien weiterhin runtergeladen und bei Fertigstellung sofort gelöscht.

Da dachte ich mir dann ok, warte ich halt bis er alle heruntergeladen wurden, anschließend werden die Daten direkt gelöscht und der Status in der Patch Management Oberfläche ändert sich dann.

Was mir aber Sorgen bereitet ist, dass diese Situation nun seit 3 Tage anhält und seit dem durchgehend 100 mbit aus dem Internet geladen werden. Per Windows Resource Monitor -> Disk -> Disk Activity kann ich sehen, dass das immer die Windows 10 Upgrade Dateien sind.

Da sage ich mir dann, dass die Downloads längst fertig sein müssten und es hier wohl ein Problem gibt.

Gibt es eine Möglichkeit auf Datenbank Ebene die entsprechenden Tabellen zurückzusetzen? Über die Management Console ist das wohl nicht möglich.

Eine ähnliche Fragestellung gab es bereits in dem Thread: https://forum.matrix42.com/viewtopic.ph ... en&p=31165 das Script funktioniert bei uns leider nicht. Es kommt die Meldung, dass die Objekte nicht gefunden werden. Das Thread ist ja auch schon von 2010, schätze hier hat sich etwas geändert.

Des weiteren habe ich probiert über die DButil den Patch Management Dienst zu de- und installieren. Aber das Ergebnis war wieder der oben beschriebene Zustand.

Vielen Dank und ein schönes Wochenende
Christoph

f48614
Beiträge: 221
Registriert: 24. Apr 2007, 14:38
Kontaktdaten:

Re: Patch Management v2 Status "deleting"

Beitrag von f48614 » 14. Nov 2016, 11:33

Hallo Christoph,

einen kompletter reset von PMv2 ist über das Löschen der folgenden Tabellen möglich.

DELETE PM2_ClientData;
DELETE PM2_Job;
DELETE PM2_History;
DELETE PM2_Detectoid;
DELETE PM2_UpdateFile;
DELETE PM2_File;
DELETE PM2_CategoryUpdate;
DELETE PM2_Category;
DELETE PM2_ClassConfiguration;
DELETE PM2_Configuration;
DELETE PM2_Driver;
DELETE PM2_SupersedesUpdate;
DELETE PM2_UpdateInfo;
DELETE PM2_UpdateBundle;
DELETE PM2_Update;

Danach einfach über DButil ein neuen Download erzwingen.

Gruß
Thomas
Empirum v18.0 + EPE 4.7.1
Testsystem Empirum v18.0

ChristophS
Beiträge: 9
Registriert: 11. Nov 2016, 11:17
Kontaktdaten:

Re: Patch Management v2 Status "deleting"

Beitrag von ChristophS » 14. Nov 2016, 12:55

Hallo Thomas,

danke für den Tipp. Habe jetzt alle Tabellen gelöscht, bis auf "PM2_File" und "PM2_Configuration", dort kommt die Fehlermeldung "Drop failed for Table 'dbo.PM2_Configuration'. (Microsoft.SqlServer.Smo)".

Habe daraufhin mal über die DButil das Patchmanagement de- und wieder installiert und den Synchronisation angestoßen. Aber Klassen und Produkte werden bis jetzt nicht angezeigt und die gelöschten Tabellen auch nicht wieder angelegt.

Noch eine Idee?

Vielen Dank und Gruß
Christoph

f48614
Beiträge: 221
Registriert: 24. Apr 2007, 14:38
Kontaktdaten:

Re: Patch Management v2 Status "deleting"

Beitrag von f48614 » 14. Nov 2016, 13:09

Hast Du den PMv2 Dienst schonmal neu installiert ?
Evtl. auch noch die Activation Queue leeren und den Aktivierungsdienst neu starten. Ich weiß leider nicht mehr ob es eine dedizierte ActivationQueue_PM2 gab. Habe schon auf v16.1 aktualisiert und da gibt es PMv2 nicht mehr.
Empirum v18.0 + EPE 4.7.1
Testsystem Empirum v18.0

ChristophS
Beiträge: 9
Registriert: 11. Nov 2016, 11:17
Kontaktdaten:

Re: Patch Management v2 Status "deleting"

Beitrag von ChristophS » 14. Nov 2016, 14:36

Ich habe den debug view mal gestartet und dort stand drin, sinngemäß, dass das Patch Management nicht durchlaufen kann weil die entsprechenden Tabellen nicht da sind. Ich habe mir die Datenbank jetzt erstmal aus einem Backup wiederhergestellt und somit den Ursprungszustand wiederhergestellt.

Ich glaube sinnvoller wäre es den Inhalt der Tabellen zu löschen und nicht die Tabellen als solches, oder?

Viele Grüße
Christoph

ChristophS
Beiträge: 9
Registriert: 11. Nov 2016, 11:17
Kontaktdaten:

Re: Patch Management v2 Status "deleting"

Beitrag von ChristophS » 15. Nov 2016, 12:31

So, ich bin jetzt wie folgt vorgegangen.

- Ich habe zunächst den Empirum Patchmanagement (Windows-)Dienst beendet.
- Per SQL Management Studio die folgenden Tabellen, bis auf die NULL Zeile gelöscht (nur den Inhalt, nicht die Tabellen als solches):
PM2_ClientData
PM2_Job
PM2_History
PM2_Detectoid
PM2_UpdateFile
PM2_File
PM2_CategoryUpdate
PM2_Category
PM2_ClassConfiguration
PM2_Configuration
PM2_Driver
PM2_SupersedesUpdate
PM2_UpdateInfo
PM2_UpdateBundle
PM2_Update
- Den Empirum Patchmanagement (Windows-)Dienst wieder gestartet
- Per DButil eine Synchronisation gestartet
- Danach waren wenig später die Klassen und Produkte wieder auswählbar
- Dann hat es ca. 15 Minuten gedauert, bis die Datenbank wieder gefüllt war und per Management Console alles wieder verfügbar war

Vielen Dank für die Hilfe.

Gruß
Christoph

Gesperrt

Zurück zu „Patch Management (EOL)“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste