Paket Erstellung - Probleme bei Verteilung

Antworten
Sven61179
Beiträge: 18
Registriert: 08. Mär 2017, 15:01
Kontaktdaten:

Paket Erstellung - Probleme bei Verteilung

Beitrag von Sven61179 » 16. Feb 2018, 10:34

Hallo zusammen,

ich habe ein Paket erstellt wo über ein Batchaufruf eine Datei in den Autostart des Benutzers kopiert werden soll

"C:\Users\%username%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\" /y


die Installation funktioniert einwandfrei wenn man diese über das SW Swdepot aufruft,
dann befindet sich die gewünschte Datei auch im Autostart des Benutzers, bei der Verteilung über den Agent , wird diese nicht in den entsprechenden Autostart Pfad des Benutzer kopiert, hier bin ich jetzt den Unweg gegangen die Datei in den Autostart "aller Benutzer zu kopieren"

liegt es daran das die Installation über die Agent Verteilung unter einem anderen "Benutzer" erfolgt ?
Wie kann man das Problem entsprechend lösen das die Datei nur in den entsprechenden Autostart des Benutzer kopiert wird ? sprich %username% annimmt.

Benutzeravatar
r.wiegel
Beiträge: 833
Registriert: 05. Feb 2010, 13:45
Wohnort: Regensburg
Kontaktdaten:

Re: Paket Erstellung - Probleme bei Verteilung

Beitrag von r.wiegel » 16. Feb 2018, 11:04

Die Installation mit dem Agent läuft im System-Kontext.
Entweder können Sie die Variable %Windowsuser% + Paketeigenschaften "Nur nach Benutzeranmeldung" nehmen oder wenn die Änderung für alle Benutzer gelten sollte, dann die Aktion in Userteil verschieben (mit /AW).
Da kann auch das Diff-Verfahren weiterhelfen.
Viele Grüße
Roman Wiegel
IT-Consultant

MR Datentechnik - Vertriebs- und Service GmbH
Client Management

Antworten

Zurück zu „Sonstige Themen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast