Seite 1 von 1

Patches do not download/approve/assign to class

Verfasst: 02. Mai 2014, 20:59
von ctearney
I have had this occur twice now this year, I will go into the console to assign patches that I know were released by Microsoft the day prior but they are not there. After forcing a sync and restarting the service there are still no new patches. So I have learned to locate a patch that is not yet approved and try to do approve it and move it to a class. If the patch sits at the "Approving" state then I know something is not working.

At this point I will run the clear PM2 SQL Script, uninstall/ reintall the PM service and restart the primary server. Once rebooted I will initiate a force synch of PM. Normally this has worked but not this time.

I did all of the above and all I can see are the Languages/Classifications/Products that I select in DBUtil appear in the console. But there are no patches listed for each, even the D:\Empirum\Configurator\Packages\PatchManagement_v2\Data\Products directory is empty.

If I look in DBUGVIEW when I force a sync I can see the PM2 service start doing something but then it stalls. Anyone have a suggestion on what may be causing this and what can be done to resolve?

**PS. I sent an email to get a quote on PM3 so hopefully I wont need to worry about PM2 for much longer. :P

[5832] MATRIXEMPPM2SRV : NovellInit()
[5832] MATRIXEMPPM2SRV : LoadLibrary()
[5832] MATRIXEMPPM2SRV : vor init module
[5832] MATRIXEMPPM2SRV Attempting connection to database: DataSource:ADTI UserID:dbo
[5832] MATRIXEMPPM2SRV: Pulse :15000
[5832] MATRIXEMPPM2SRVReading novell login settings

Re: Patches do not download/approve/assign to class

Verfasst: 03. Mai 2014, 20:19
von Hendrik_Ambrosius
Looks like the services is not even starting the download?!
Please start debugview again, force a sync and check the log.
There should be more entries in there!

Re: Patches do not download/approve/assign to class

Verfasst: 05. Mai 2014, 15:40
von ctearney
I kept Debugview up for about 10 minutes and that is all the entries for the MATRIXEMPPM2SRV service.

Re: Patches do not download/approve/assign to class

Verfasst: 05. Mai 2014, 19:58
von ctearney
Problem fixed. There was a hotfix associated to the issue which once applied resolved the issue. partially. I state partially because after applying the hotfix I began to see patches populate in the EMC but the status for the autodownload patches were not updating to from "downloading" to "downloaded".

I noticed in the log files from debugview that the system was trying to alter the ..\ Configurator$\Packages\PatchManagement_v2\Data folder but was receiving an access denied. I ran the "Clear PM2 Jobs" SQL script and then deleted the Data folder after which I manually initiated a patch download and then approval. This did the trick. So the hotfix on top of clearing the Data folder resolved the issue.

Hopefully this will be the last time this occurs until we can get moved over to the PM3 service.