TIPP: VMware Workstation (9.0.2) als Testumgebung

Antworten
madmaki
Beiträge: 34
Registriert: 24. Aug 2008, 07:50
Wohnort: Berlin
Kontaktdaten:

TIPP: VMware Workstation (9.0.2) als Testumgebung

Beitrag von madmaki » 01. Mai 2013, 18:00

Hallo zusammen,

beim Stöbern in diesem Forum ist mir aufgefallen, dass viele Probleme im (produktiven) Empirum-Umfeld vermeidbar sind, wenn man sich einer "ordentlichen" Testumgebung bedient !!
Ich möchte mit diesem Beitrag nicht "klugscheißern", sondern vielmehr meine Tesstellung beschreiben und damit vielleicht anderen Usern helfen !!

Hardware (real):
1. Ich nutze VMware Workstation 9.0.2 auf einem PC mit 16GB RAM, Quad-Core CPU (Intel Core 2 Quad Q9550, 2.83 GHz mit VT-x) und insgesamt 3 HDDs
2. auf HDD 1 ist das OS und sämtliche SW installiert, auf HDD 2 sind sämtliche orig. SW-Sourcen (ISO-Images) und auf HDD 3 die VM-Container der virtuellen Maschinen
3. VMware Wkst., sind insgesamt 14 GB RAM für virtuelle Maschinen zugeordnet

Empirumserver (virtuell):
- Server 2003 R2, der gleichzietig DNS, ADS und DHCP Server ist
- 2 CPUs und 4GB RAM zugeordnet
- 2 HDDs:
HDD 1 (60GB) als LW "C:"=> Server-OS,
und
HDD 2 (150GB) als LW "D:" => Empirum Installation und Empirum Datenbank
Sofort nach der nackten installation des OS die VMware-Tools installieren !!
Dann gibts auch keine Probleme mit der/den virtuellen Netzwerkkarte/n.

Die übrigen Test-Clients habe ich einfach nach den OS-Default-Einstellungen von VMware angelgt.

ACHTUNG:
Es ist unerläßlich, dass der (virtuelle) Server absolut sauber durchkonfiguriert und gestestet ist, bevor Ihr Empirum darauf installiert.
Ein Custom Network (z.B. VMnet1) bei der Netzwerkkarte einstellen, bei den VMware-Preferences für dieses LAN den DHCP ausschalten und dem Server ein feste IP vergeben !!
Dann zuerst DNS installieren , konfigurieren und testen (nslookup), dann AD (dcpromo) und abschließend DHCP !!
DNS nicht während der AD-Installation mitinstallieren, das ist Murks, sondern immer vorab als erstes !!
Außerdem nach der ADS-Installation die TCP/IP-Einstellungen korrigieren, da MS dort die IP für den DNS-Server weghaut !!
Ich deaktivieren auch immer IPv6, weil das kein Mensch in einer kleinen Testumgebung braucht.


Wenn also der Server absolut fehlerfrei funktioniert, dann könnt Ihr Euch an Empirum ranmachen :D

Obige Hinweise halte ich gerade auch für eine Produktivumgebung für unerlässlich.
Viele, viele Probleme nach der Art "Installation geht nicht, da Server nicht gefunden"etc. pp. treten garnicht erst auf, wenn die Netzwerkumgebung inkl. Server richtig und sauber eingerichtet ist.

Viele Grüße
madmaki
(MCITP Server 2008)

Antworten

Zurück zu „Hilfe und FAQ“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast