Lenovo Access Connection

Antworten
Benutzeravatar
FruF
Beiträge: 202
Registriert: 26. Jan 2009, 12:33
Kontaktdaten:

Lenovo Access Connection

Beitrag von FruF » 06. Nov 2009, 16:02

Wir haben mit Access Connection nur Probleme, brauchen es aber.
(System Update gibt es nicht mehr raus, und wenn es mal klappt kommt immer Fehler Popup am Start)
Hat das jemand mal paketiert ?
Laut Deployment PDF hab ich die Schalter gesetzt.

Call "Setup.exe" -S -SMS -f2x

-Call "Setup.exe" -S -f1 uninst.iss anything -f2x

Tut auch so als ob es installeirt macht aber im Grunde nix.
Grund (??) : Er will ne Windows Datei ersetzen, und das Popup ist wohl nicht
eingeplant. (Windows Schutz für den Treiber)

Die Idee : Einfach die Datei vor der Installation löschen
lässt Windows einfrieren =) also keine gute Idee

Irgendjemand schonmal erfolgreich gewesen?


Danke !

FruF

mIsixth
Beiträge: 282
Registriert: 07. Mai 2008, 08:38
Kontaktdaten:

ACC

Beitrag von mIsixth » 10. Nov 2009, 11:48

Salue,

wir haben das teil auf allen unseren notebooks im einsatz.
funktioniert eigentlich recht gut. das problem, das wir haben, ist den richtigen treiber für die richteige acc-version zum richtigen model zu installieren.

ausserdem must du noch installieren:
.NET 3.0 (mind. ab acc 5.2)
power manager treiber
hotkey features.

das alles bevor du acc installierst. könnte sein, dass das popup damit zusammen hängt.

ich habe die ganze latte als custom treiber (empirum job) in unseren hw-profilen drin.

Sascha Bernhard
Beiträge: 162
Registriert: 20. Aug 2007, 13:53
Kontaktdaten:

Beitrag von Sascha Bernhard » 16. Nov 2009, 15:03

Hi
Ich verteile es mit:
call "%src%\setup\setup.exe" -S -SMS
läuft eigentlich einwandfrei auf Windows XP

mIsixth
Beiträge: 282
Registriert: 07. Mai 2008, 08:38
Kontaktdaten:

Access Connections

Beitrag von mIsixth » 17. Nov 2009, 19:29

Salue,

anbei mein script. so funktioniert das ding auf allen hw modellen.
wichtig ist auch, dass lenovo nicht nur den treiber installiert, sondern auch einen teil der intel/pro set wireless software. welchen treiber für welche karte, kann man bei lenovo nachlesen.

[SetupInfo]
Author = at95191
CreationDate = 11.11.2009 13:34:11
InventoryID =
Description = Think Vantage Access Connections
Method = unattended, scripted
Tested on = winXP
Dependencies =
Command line options = /S0
Last Change =
Build =

[VarDefInfo]
; <Variable>, <Type>, <Allow>

[Setup]
Version=10.5
ShowCaption=1
BlockInput=0
Platform=x86

[Requirements]

[Application]
ProductName=Access Connections
DeveloperName=ThinkVantage
Version=5.33
Revision=0
SetupName=%ProductName% %Version% %SetupWizard%
Text1="%ProductName% %Version%", Arial, 30, , 00FFFF, 4, , LEFT BOLD ITALIC
Text2="%DeveloperName%", Arial, 24, , 00FFFF, 4, , LEFT BOLD ITALIC
Text8="%Company%", Arial, 18, , 00FFFF, 4, 10, RIGHT BOLD ITALIC
Text9="%InstallationFor% %WindowsUser%", Arial, 16, , 007F00, 4, -18, BOTTOM ITALIC LEFT
BackgroundColor=FF0000,000000
CopyDialogRect=0%, 0%, 100%, 100%, HCENTER VCENTER
UserKeyName=%DeveloperName%\%ProductName%
MachineKeyName=%DeveloperName%\%ProductName%\%Version%
UninstallKeyName=%DeveloperName% %ProductName% %Version%
UninstallDisplayName=%ProductName% %Version%
UninstallString=%ReinstallString% /U
ReinstallString="%CommonSetupDir%\Setup.exe" "%App%\%SetupInfDir%\Setup.inf"
ReinstallMode=1
SrcDir=..
ApplicationDir=%ProgramFilesDir%\matrix42\%ProductName%
SetupInfDir=Install
AskUninstallOld=1
ShellLinks=1
CommonShellLinks=1
CreateUnresolvableShellLinks=1
UseStringSection=Strings:09
UseSysStringSection=SysStrings:09
DateWarning=1
SizeWarning=1
Reboot=1
PreventExternalReboot=1
StartServicesOnReboot=0
CallTimeOut=7200
AbortAfterCallTimeOut=1
DisableCancelButton=1
ShowEndMessage=1
EndMessage=%EndMessageDesc%


[Strings:07]
Disk1=Installationsmedium 1
EndMessageDesc=Die Installation wurde erfolgreich abgeschlossen!
ErrorLogMessage=Die Installation/Deinstallation wurde mit einer Fehlermeldung abgebrochen!
InstallationFor=Installation für:
InstallerDesc=Dienstprogramm zum Installieren einzelner Komponenten.
InstallerName=Installationsprogramm
SetupWizard=Installations-Assistent
Uninstallation=deinstallieren
ErrorText=Fehler
CallingText=beim Aufruf von

[Strings:09]
Disk1=Installation media 1
EndMessageDesc=Installation was completed successfully!
ErrorLogMessage=The installation/uninstallation aborted with an error message!
InstallationFor=Installation for:
InstallerDesc=Service program to install single components.
InstallerName=Setup program
SetupWizard=Installation Wizard
Uninstallation=Uninstallation
ErrorText=Error
CallingText=launching

[SysStrings:07]
Users=Benutzer

[SysStrings:09]
Users=Users

[Environment]
CommonSetupDir=%CommonFilesDir%\Setup%SetupBits%
V_MachineValuesPath=%SoftwareDepotServerName%\Values$\MachineValues\%DomainName%
V_UserValuesPath=%HKLM,"Software\matrix42\Software Depot","HomeServer"%\Values$\UserValues\%UserDomain%

; Maschinenabhängige Variablen
; machine dependent variables
;VM_<Variable>=%%%V_MachineValuesPath%\%ComputerName%.ini,%ComputerName%,<Variable>%%
VM_LEASSERIAL=%%%V_InfoPath%\GetInfo.ini,Computer,InventoryID%%

; Userabhängige Variablen
; user dependent variables
;VU_<Variable>=%%%V_UserValuesPath%\%WindowsUser%.ini,%WindowsUser%,<Variable>%%

; !!! Setzen der entsprechenden ReplaceEnv Befehle für die Variablen im Abschnitt [Product] nicht vergessen!!!
; !!! Don't forget to set the appropriate ReplaceEnv instructions for the variables in the section [Product]!!!

[Encryption]

[Disks]
1=%Disk1%

[Options]
Installer = %InstallerName%, COPYALWAYS, Installer, "%InstallerDesc%"
Product = %ProductName%, COPYALWAYS, Product, "%ProductDesc%"

[OptionDependencies]

[OptionGroups]

[Installer]
1:..\..\..\..\User\Setup.exe, %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupDeu.chm, %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupEnu.chm, %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\Mx42SynSem.dll, %System%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP WINDOWS32, 0
1:..\..\..\..\User\x64\Mx42SynSem.dll, %System%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP WINDOWS64, 0
1:%SetupInfDir%\Setup.inf, , NORMAL, 0
1:%Temp%\Setup64.exe, %CommonSetupDir%\Setup.exe, OPTIONAL NOSIZEWARNING SETUP ALWAYS WINDOWS64, 0

[FileCheckMachine]
ReplaceEnv V_MachineValuesPath
If DoesFileExist ("%V_MachineValuesPath%\%ComputerName%.ini") == "0" Then "FileIsntThere" EndIf

[FileCheckClient]
ReplaceEnv V_UserValuesPath
If "%UserDomain%" <> "%ComputerName%" Then "CheckClientFile" EndIf

[CheckClientFile]
If DoesFileExist ("%V_UserValuesPath%\%WindowsUser%.ini") == "0" Then "FileIsntThere" EndIf

[FileIsntThere]
ErrorLogMsg Values$\MachineValues\%DomainName%\%ComputerName%.ini or Values$\UserValues\%UserDomain%\%WindowsUser%.ini not found!
Abort


[Product]
;#FileCheckMachine, MACHINE
;#FileCheckClient, CLIENT
;ReplaceEnv <Variable>

#Set:Product
#Set:PowerDriver, DONTDELETE
#Set:HotKeyFeature, DONTDELETE
#Set:Installation, DONTDELETE
#Set:Deinstallation, DELETE
#Reg:OnUninstallProduct, DELETE
#Reg:Product
#Ini:Product
#Security:Product

[Set:Product]
;Run Inventory
Del "%System%\Empirum\GetInfo.ini"
CallHidden "%System%\Empirum\EmpInventory.exe" /O"%System%\Empirum\GetInfo.ini" /DMI /WMI /V2 /M /T
If %ErrorLevel% <> "0" Then "SET:InstallationError" Else "Set:WLANDRIVER" EndIf
;Check DotNet
If DoesRegKeyExist ("HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{CE2CDD62-0124-36CA-84D3-9F4DCF5C5BD9},UnInstallString") == "0" Then "InstallDotNet" EndIf

[SET:Installation]
AddMeter 50
Call "%Src%\Setup.exe" -s -SMS -f2"%APP%\Install.log"
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[SET:Deinstallation]
If "%Src%\Setup.exe" <> "" Then "SET:Deinstallation2" EndIf

[SET:Deinstallation2]
If %ErrorLevel% <> "0" Then "SET:DeInstallationError" EndIf
-Call "%Src%\Setup.exe" -s -SMS -f1"%S%\Uninstall.iss" -f2"%APP%\Uninstall.log"
-AddMeter 50

[Reg:OnUninstallProduct]
-HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NetworkOptions",0x00010001,105
-HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NotificationOptions",0x00010001,7
-HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","Enabled",0x00010001,0
-HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","Enabled",0x00010001,0
-HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","InstanceCount",0x00010001,0
-HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NetworkOptions",0x00010001,121

[Reg:Product]
HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NetworkOptions",0x00010001,105
HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NotificationOptions",0x00010001,7
HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","Enabled",0x00010001,0
HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","Enabled",0x00010001,0
HKLM,"SOFTWARE\Lenovo\TVTGINA\Volatile","InstanceCount",0x00010001,0
HKLM,"SOFTWARE\Lenovo\Access Connections\Options","NetworkOptions",0x00010001,121

[Ini:Product]

[Security:Product]
LocalGroup.AddMember ("Network Configuration Operators", "%$Local%")

[Shell:Product]

[SET:InstallationError]
ErrorLogMsg %ErrorText% %ErrorLevel% %CallingText% Setup.exe
Abort

[SET:DeInstallationError]
-Abort
-ErrorLogMsg %ErrorText% %ErrorLevel% %CallingText% Setup.exe

[InstallDotNet]
AddMeter 50
CallHidden "%SRC%\dotnetfx35.exe" /q /norestart
If %ErrorLevel% <> "0" & %ErrorLebel% <> "3010" Then "SET:InstallationError" EndIf

[Set:WLANDRIVER]
If DoesTextInFileExist ("3945ABG","%System%\Empirum\GetInfo.ini") == "1" Then "3945ABG" EndIf
If DoesTextInFileExist ("5100 AGN","%System%\Empirum\GetInfo.ini") == "1" Then "5100AGN" EndIf
If DoesTextInFileExist ("2915ABG","%System%\Empirum\GetInfo.ini") == "1" Then "2915ABG" EndIf


[3945ABG]
AddMeter 50
CallHidden "%SRC%\3945ABG\XP\x32\Install\Setup.EXE" /quiet /norestart
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[5100AGN]
AddMeter 50
CallHidden "%SRC%\5100AGN\x32\Install\Setup.EXE" /quiet /norestart
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[2915ABG]
AddMeter 50
CallHidden "%SRC%\2915ABG\x32\Install\Setup.EXE" /quiet /norestart
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[Set:PowerDriver]
AddMeter 50
CallHidden "%SRC%\IBMPM\Setup.exe" -s -SMS
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[Set:HotKeyFeature]
;If DoesRegKeyExist ("HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OnScreenDisplay,DisplayVersion") == "0" Then "DoInstall" Else "DoNotInstall" EndIf

[DoNotInstall]

[DoInstall]
AddMeter 50
CallHidden "%SRC%\HOTKEY\Setup.exe" /S
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

Antworten

Zurück zu „Suche“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast