Problem mit Abhängigkeiten nach Update auf 14.2

Moderatoren: MVogt, moderators

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 18. Apr 2012, 14:55

Hallo,

ich bräuchte bitte etwas Unterstützung von jemandem, der bereits auf die Version 14.2 aktualisiert hat (möchte gerne wissen, ob es ein programm- oder ein kundenspezifisches Problem ist).

Ich möchte bspw. verhindern, dass Acrobat 9 Standard auf einem Rechner installiert wird, wenn bereits Acrobat 9 Professional installiert ist. Bislang ließ sich das problemlos wie folgt realisieren:
Acrobat 9 Standard - Abhängigkeit "NOT Acrobat 9 Professional"
Acrobat 9 Professional - Abhängigkeit "NOT Acrobat 9 Standard"

Wenn ich das unter der 14.2 konfigurieren will, erhalte ich beim konfigurieren der zweiten Abhängigkeit die Fehlermeldung "Das Einfügen dieses Paketes ist aufgrund eines Zirkelbezuges nicht möglich!".

In der Vorgängerversion bereits eingetragene Abhängigkeiten dieser Art sind aktiv - wenn ich sie ändern will, erhalte ich dieselbe Fehlermeldung.

Könnte das bitte jemand bei sich gegentesten?

Vielen Dank!

Viele Grüße,
Lennart Freyberg
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Benutzeravatar
Frank Dethlefsen
Beiträge: 428
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von Frank Dethlefsen » 18. Apr 2012, 15:44

Hallo!

Ich kenne die Meldung, ins besondere aus der V14 1 Version P1+P2+Posthotfixe.

Versuch mal folgendes, gehe ins Depot auf die Registerkarte, in der die Software drin ist.
Rechte Maustaste > Software-Abhängigigkeiten > Software auswählen > Bearbeiten > Abhängigkeit pflegen > Speichern.
Wenn das geht, hat man zu mindestens einen Workaorund.

Ich vermute einen Bug >>> Matrix42 Support.
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 18. Apr 2012, 16:07

Hallo Frank,

die ganze Leidensgeschichte will ich hier nicht aufschreiben, daher nur die Kurzfassung:

Testsystem von v12 auf v14 SP1 P2 aktualisiert - keine Probleme.
Produktivsystem von v12 auf v14 SP1 P2 aktualisiert - Abhängigkeitsprobleme.

Direkt einen Call eröffnet (war Ende Februar), am gleichen Tag neue DLLs bekommen, ausgetauscht, keine Verbesserung. Da der Support das Problem bislang nicht lösen konnte, habe ich gestern alle Abhängigkeiten aus der Datenbank gelöscht und neu eingerichtet (die Klickorgie hat echt Spaß gemacht). Dabei hatte ich die Probleme nicht wieder.

Gleichzeitig habe ich gestern unser Testsystem von v14 SP1 P2 auf v14 SP2 aktualisiert und habe nun dort die im Ausgangspost genannten Probleme. Der Support weiß darüber Bescheid - aber da ich diesbezüglich mittlerweile ziemlich desillusioniert bin, würde ich gerne wissen, ob ich die Klickorgie auf dem Testsystem wiederholen muss, oder ob es sich um ein grundsätzliches Problem handelt.

Der von Dir genannte Workaround ist mir bekannt, funktionierte aber weder auf dem Produktivsystem mit v14 SP1 P2, noch auf dem Testsystem mit v14 SP2.

Viele Grüße,
Lennart Freyberg
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

frenzlc
Beiträge: 237
Registriert: 16. Dez 2004, 09:41
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von frenzlc » 19. Apr 2012, 15:48

Hallo,

interessant das noch mehr das Problem haben.
Wir hängen auch schon seit Anfang des Jahres mit dem Zickelbezug fest ohne nennenswerte Hilfe von dem ach so tollem Support zu bekommen. Hängt angeblich irgendwo bei der Entwicklung fest.
Was auch witzig ist das der Support von einem einmaligen Phänomen sprach was mich wieder zu der Schlussfolgerung führt die reden nicht miteinander.

Ist bei jedem Update das selbe irgentwas funktioniert danach Monatelang nicht mehr so macht das einfach keinen spass mehr.
Von wegen manage save relax

Gruß
Carsten

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 20. Apr 2012, 09:23

Hallo,

laut Support gibt es in der 14.2 ein Problem mit der im Ausgangspost genannten gegenseitigen Referenzierung. Dies ist in der Entwicklung mit Prio 6 eingetütet (Standard sei Prio 8). Ein Zeithorizont zur Realisierung konnte mir nicht genannt werden.

Bezüglich Bugbehebung: Am besten Schwamm drüber - sonst regt man sich nur auf... (inakzeptabel ist gerade das freundlichste Wort, was mir einfällt).

Grüße,
Lennu
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Benutzeravatar
Frank Dethlefsen
Beiträge: 428
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von Frank Dethlefsen » 20. Apr 2012, 09:47

Bie einem frischen installiertem EmpirumV14.2 scheint das Problem nicht aufzutauchen.
Insofern wenn alle EMC-Programmteile aktuelle sind, muss es Datenbank sein. Vielleicht sind es verweiste Datensätze in der Tabelle SwDependencies...?
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 20. Apr 2012, 10:18

Hallo,

Du kannst bei einer frisch installierten 14.2 gegenseitige Abhängigkeiten eintragen? Bin aus zwei Gründen verwirrt: Hatte zum einen auf unserem Testsystem (14.2) die Tabelle SwDependencies (Abhängigkeiten) und SwSequences (Reihenfolge) geleert und das Problem bestand weiterhin. Zum anderen hat der Support das als vorhandenen Bug bestätigt...

Grüße,
Lennu
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Benutzeravatar
Frank Dethlefsen
Beiträge: 428
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von Frank Dethlefsen » 20. Apr 2012, 10:27

Hallo Lennart!

Gegenseitige Abhängigkeiten?
Software A ist von B abhängig.
Software B ist von A abhängig.
Ist das damit gemeint?
ist das nicht ein Paradoxon bzw. ein Hehne-Ei-Problem?

Gruß Frank
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 20. Apr 2012, 10:30

Hallo Frank,

die richtige Formulierung wäre eher "gegenseitiger Ausschluss" gewesen:
Software A: NOT Software B
Software B: NOT Software A

Der von Dir beschriebene Fall ist in der Tat technisch schwer abzubilden ;-)

Grüße,
Lennart
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Benutzeravatar
Frank Dethlefsen
Beiträge: 428
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von Frank Dethlefsen » 20. Apr 2012, 10:43

Ich konnte das auf einem frischem Empirum V14.2 reproduzieren.
Leider funktioniert der Workaround auch nicht über die Registerkarte.
Ich mache auch mal ein Call auf.
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 20. Apr 2012, 10:46

Hallo,

mein Call-ID ist 53044, falls Du darauf verweisen willst.

Grüße,
Lennu
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

PHN
Beiträge: 20
Registriert: 16. Feb 2010, 11:40
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von PHN » 23. Apr 2012, 14:29

Hallo zusammen,

danke für die Info, jetzt weiß ich wieder, warum ich noch nicht auf SP2 aktualisiert habe...

Aber mal eine andere Frage:
Warum ist es überhaupt nötig, bei beiden Paketen jeweils das andere aus Ausnahme einzutragen?
Bei mir klappt es ganz gut, nur zu sagen, A nicht B.
Egal, welches dann als zweites kommt, es wird nicht installiert...

Viele Grüße
PHN

Benutzeravatar
Captain_Slow
Beiträge: 115
Registriert: 01. Mär 2010, 15:40
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von Captain_Slow » 23. Apr 2012, 18:46

hi all
wir hatten das Problem definitiv auch schon mit der 14 SP1.
evtl sogar schon vorher - ist aber nicht aufgefallen.

Damals wurden wir aber regelrecht abgewatscht , man könne das nicht nachstellen und daher werder der Call geschlossen. :twisted:
DAS war unter einigen Calls das skurilste Verhalten dieses "Helpdesks"

ein enttäuschter (zahlender) Kunde
Empirum V17.0.2
MS SQL 2012
MS Windows Server 2012 R2

---------------------------------------------------------------
"...und die Hölle sieht genauso aus wie der Himmel ?!"

"Ja ! ... aber du bist der Admin !"

frenzlc
Beiträge: 237
Registriert: 16. Dez 2004, 09:41
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von frenzlc » 29. Mai 2012, 10:49

Hallo, gibts da schon was neues?

Voll witzisch hab gerade auf der Matrix42 Homepage folgenden Spruch gefunden:
Unser Anspruch: 100% Zufriedene Kunden.
:lol: :lol: :lol:

Benutzeravatar
lennu
Beiträge: 580
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: Problem mit Abhängigkeiten nach Update auf 14.2

Beitrag von lennu » 29. Mai 2012, 11:55

Hallo,

der Fehler ist durch Patch 1 für v14 SP2 beseitigt.

Grüße,
Lennu
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste