Advcanced Agent und [Requirements] wirft Failure

Moderatoren: MVogt, moderators

Antworten
mattba
Beiträge: 13
Registriert: 11. Aug 2014, 14:39
Kontaktdaten:

Advcanced Agent und [Requirements] wirft Failure

Beitrag von mattba » 18. Mai 2016, 11:05

Hallo zusammen,

wir haben den Advanced Agent (Empirum v16 Update 3) erst seit kurzem im Einsatz und machen somit gerade die ersten Erfahrungen damit. Bislang haben wir den Legacy Agent benutzt und waren damit sehr zufrieden, der AA macht uns jedoch etwas Kummer. Neben diversen Kleinigkeiten haben wir auch mit einem konkreten Problem zu kämpfen. So haben wir in manchen Softwarepaketen in der Setup.inf folgende Zeilen eingefügt:

[Requirements]
DoesProcessExist ("thunderbird.exe") == "0"

Mit dem Legacy Agent hat dies tadellos funktioniert: solange der entsprechende Prozess existierte wurde die Meldung geworfen und der Agent hat es mit jedem Pull-Intervall neu versucht.
Der Advanced Agent wirft anstelle der "Requirements-Meldung" nun aber einen Failure und hört dementsprechend nach Erreichen der maximalen Fehleranzahl auf das Paket zu installieren. Wohlgemerkt: Empirum-Server und Softwarepaket sind identisch!

Um die Softwareverwaltung völlig im Hintergrund arbeiten zu lassen, sind alle Pakete mit "/S" im Depot eingetragen und der Z-Dialog des AA ist deaktiviert. Einen Softwarekiosk betreiben wir nicht, die Nutzer bekommen das Swdepot also nicht zu sehen.

Meine Fragen:
- Ist dieses Verhalten so gewollt?
- Kann das vorherige Verhalten des Legacy Agent wiederherstellt werden?

Im Anhang befinden sich Screenshots der Logeinträge und der Kopf einer Setup.inf.

Vielen Dank fürs Lesen!
Matthias
Dateianhänge
Setup.inf
(2.46 KiB) 33-mal heruntergeladen
legacyagent.png
(147.58 KiB) 22-mal heruntergeladen
advancedagent.png
(490.11 KiB) 31-mal heruntergeladen

mattba
Beiträge: 13
Registriert: 11. Aug 2014, 14:39
Kontaktdaten:

Re: Advcanced Agent und [Requirements] wirft Failure

Beitrag von mattba » 31. Mai 2016, 08:39

Neue Beobachtung: entfernt man den Haken vor "Maximale Anzahl fehlgeschlagener Installationsversuche" in der Advanced Agent-Konfiguration, wird die Installation bei Nichterfüllen der Bedingung erwartungsgemäß weiterhin (endlos) versucht. So weit so gut. Leider ist mir jetzt aufgefallen, dass in diesem Fall keine E-Mail-Benachrichtigungen mehr über das Alarmmanagement gesendet werden. Und zwar überhaupt keine mehr, also auch nicht bei "echten" Failures von denen man gerne zeitnah erfahren würde.

Kann das jemand nachvollziehen?

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste