UEMAgent.bat Fehler

Moderatoren: MVogt, moderators

Antworten
Sven_Puth
Beiträge: 444
Registriert: 07. Apr 2011, 15:55
Kontaktdaten:

UEMAgent.bat Fehler

Beitrag von Sven_Puth » 20. Aug 2018, 11:00

Hallo zusammen,

nur für den Fall dass noch jemand darüber stolpert:
Es kann passieren, dass die UEMAgent.bat keinen UEM Agent installiert und einen Fehler auswirft, die Setup.inf würde nicht gefunden werden.

Das liegt daran, dass das Skript alle Verzeichnisse durchgeht und die letzte "Version" installieren möchte. Da im UEM Agent Package Ordner aber neben den Einzelversionen auch ein MSI Verzeichnis liegt kann dieses das Skript stören. So versucht das Skript die Setup.inf aus dem MSI Ordner zu installieren.
Verschiebt man den MSI Ordner weg oder benennt ihn für die alphabetische Sortierung um, sollte alles wieder passen.
Tria-media - IT Solutions

Benutzeravatar
Frank Dethlefsen
Beiträge: 425
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: UEMAgent.bat Fehler

Beitrag von Frank Dethlefsen » 21. Aug 2018, 09:27

Moin!

Hatte das Problem auch schon. Bei mir lagen Dateien in dem Ordner die Stress machten.

Ich habe das dann so gelöst:

Code: Alles auswählen

...
FOR /F "delims=" %%I IN ('DIR /B /AD /ON "\\%EmpirumServer%\Configurator$\Packages\matrix42\UEM Agent Windows" ^| find "."') DO SET UEMAgentVersion=%%I
...
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste