UEM-Agent (1809)

Moderatoren: MVogt, moderators

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

UEM-Agent (1809)

Beitrag von SchragnerD » 15. Nov 2018, 14:28

Hallo zusammen,
ich wollte bei einer Testgruppe den UEM-Agent installieren. Hat nicht funktioniert, der Advanced Agent ist deinstalliert, der neue aber nicht installiert...

Aktuell ist bei uns der Advanced Agent direkt unter "Konfigurationsgruppen" zugewiesen damit dieser auf allen PCs auf dem aktuellen stand ist.
Nun habe ich bei einer Gruppe (IT-Organisation) den UEM-Agent dazu gepackt und einen Computer aktiviert.

Leider ist nun der Advanced Agent weg, der UEM-Agent aber nicht installiert.

Hat jemand eine Idee warum das so ist? Ist das vielleicht sogar der Falsche Weg den UEM-Agent auszurollen?
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

MaMa82
Beiträge: 296
Registriert: 10. Jun 2011, 13:56
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von MaMa82 » 15. Nov 2018, 14:48

Hallo,

prinzipiell würde ich empfehlen die aktuellste Version des UEM zu nutzen.
(siehe Marketplace - akt. 1810/54)
Das zugehörige Dokument ist unter
https://helpfiles.matrix42-web.de/EXT/U ... ows_EN.pdf
zu finden.
Hierin wird auch das Rollout beschrieben.

Da sich UEM und Advanced Agent ausschließen - entweder clean via OS-Install unterscheiden oder alternativ wie im Dokument beschrieben. :mrgreen: :lol:
Grüße MaMa82


PS: EDV steht nicht für "Elektronische Datenverarbeitung", sondern vielmehr für "ENDE DER VERNUNFT"! :roll:

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: UEM-Agent (1809)

Beitrag von Hendrik_Ambrosius » 16. Nov 2018, 12:56

Kann es sein, dass Windows 10 1809 im Einsatz ist? Dann auf jeden Fall den 1810er UEM Agent nehmen!
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von SchragnerD » 16. Nov 2018, 13:00

Ich versuche den UEM-Agent wie in der Anleitung beschrieben zu installieren.
Auf den Test-Clients ist Windows 10 1803 im Einsatz.

Ich habe nun ebenfalls den UEM Agent 1810 verwendet.
Leider bleibt das Ergebnis wie bereits beschrieben. Der Advanced Agent ist deinstalliert, der UEM-Agent fehlt :(

Code: Alles auswählen

Im Windows Log habe ich folgenden Fehler gefunden:
Name der fehlerhaften Anwendung: Matrix42.Platform.Service.Host.exe, Version: 1.0.22.0, Zeitstempel: 0x5a953c68
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 10.0.17134.319, Zeitstempel: 0x1e206b26
Ausnahmecode: 0xe0434352
Fehleroffset: 0x000000000003a388
ID des fehlerhaften Prozesses: 0x2650
Startzeit der fehlerhaften Anwendung: 0x01d47d8d253e893c
Pfad der fehlerhaften Anwendung: C:\Program Files\Matrix42\Universal Agent Framework\Matrix42.Platform.Service.Host.exe
Pfad des fehlerhaften Moduls: C:\Windows\System32\KERNELBASE.dll
Berichtskennung: f02c3d9f-52af-4b4f-bb29-eac2eebe2438
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: UEM-Agent (1809)

Beitrag von Hendrik_Ambrosius » 16. Nov 2018, 13:17

Ist er nach einem Agent-Push da?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von SchragnerD » 16. Nov 2018, 13:21

Agent-Push funktioniert bei uns wegen einer Sonderkonstellation nicht.
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: UEM-Agent (1809)

Beitrag von Hendrik_Ambrosius » 16. Nov 2018, 13:23

Dann installieren Sie den Agenten per Aufruf von UEMAGENT.BAT da ja nun auf den betroffenen Clients kein Agent mehr läuft.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

gessi0
Beiträge: 41
Registriert: 01. Sep 2016, 10:24
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von gessi0 » 08. Jan 2019, 13:37

Hey,

ich hab auch das Problem, dass der alte Agent deinstalliert wird und der neue nicht hochkommt. Push funktioniert nur ab und zu.
Die Variante per .bat datei ist auch nicht wirklich eine sinnvolle Lösung, da der Großteil unserer Clients unterwegs im Feld sind.

Die Clients, die den UEM dann mal draufhaben, können easy und ohne Fehler auf die immer aktuellste UEM Version upgegradet werden, aber solange der Change von Advanced auf UEM nicht richtig funktioniert wird das wohl nix mit UEM...

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von SchragnerD » 08. Jan 2019, 14:20

Hi,
wir haben mittlerweile herausgefunden, dass es am Virenscanner liegt.
Sobald dieser aktiviert ist, werden manche dll-Dateien mit dem Zeitstempel 01.01.1980 abgelegt.
Die Installation schlägt dann beim nächsten Zugriff auf die Datei fehl.

Eine Ausnahme hat da im Virenscanner auch nicht geholfen, das Verhalten der UEM-Agent Installation wohl sehr ungewöhnlich ist.
Der Hersteller des Virenscanners hat dieses Problem an die Entwicklung weitergegeben.
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

gessi0
Beiträge: 41
Registriert: 01. Sep 2016, 10:24
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von gessi0 » 08. Jan 2019, 15:00

Hey,

welchen Virenscanner nutzt ihr?

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von SchragnerD » 15. Jan 2019, 13:10

Habe auf den Post in einer privaten Nachricht geantwortet.

Wir haben bisher leider noch immer keine Lösung für das Problem.

Ich denke das einfachste wäre, wenn sich ein UEM-Agent Entwickler mit einem Entwickler des Virenscanner Herstellers zusammentelefonieren würde.
Leider scheint das aber nicht so einfach zu sein...
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

marc.schneider
Beiträge: 218
Registriert: 29. Mär 2010, 12:26
Wohnort: Magdeburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von marc.schneider » 15. Jan 2019, 13:27

Hallo,

ich habe mit dem UEM-Agenten auch ein bisschen rumgespielt und scheitere mit Trend Micro Office Scan auch bereits an der Installation (Update vom Adv. Agent).
Da das bei uns aber noch nicht ganz oben auf der Tagesordnung steht, habe ich noch Zeit...
Allerdings werde ich wohl besser dennoch ein Ticket bei TM aufmachen :roll: Wer weiß, wie lange die Asiaten brauchen... :lol:

Beste Grüße
Marc
Marc Schneider
Ärztekammer Sachsen-Anhalt
39120 Magdeburg
http://www.aeksa.de
--
Matrix42 Empirum v19.0.1 Adv. Agent, UEM in Vorbereitung
Datenbank: MSSQL 2017
Master-Server: Win Server 2012 R2
Web-Depot: Win Server 2012 R2 (nur via https erreichbar)
Clients: Win10 x64

SchragnerD
Beiträge: 155
Registriert: 09. Nov 2011, 20:25
Wohnort: Offenburg
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von SchragnerD » 15. Jan 2019, 13:35

Wenn das bei so vielen Virenscannern ein Problem macht, ist halt die Frage ob das wirklich an den Virenscanner Herstellern liegt oder ob Matrix42 sich da eine andere Installationsmethode überlegen sollte...

Klar gibt es noch den Advanced Agent der auch funktioniert. Wenn ich das aber richtig verstanden habe, soll dieser ja durch den UEM Agent abgelöst werden.
Daher wäre das schon klasse, wenn ein Update mit einem installierten Virenscanner auch funktionieren würde.
Viele Grüße
Dieter Schragner

Empirum v18.0.2
Service Store 9.0.4

variosity
Beiträge: 76
Registriert: 27. Nov 2008, 11:45
Wohnort: CH-7203 Trimmis
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von variosity » 25. Jan 2019, 16:20

Wir haben egal mit welchen UEM Agents Problem mit dem austauschen und wieder zurück auf Advanced. Den Virenscanner habe ich bei uns vorerst ausgeschlossen. Da wir auch Agenten Probleme beim Stagen haben, da ist noch kein McAfee drauf. Wenn er natürlich zur Laufzeit was dreht wäre das fatal.
Sobald wir mit viel gebastel (c++ reinstal/repair etc.) den Advanced wieder drauf haben läuft es eigentlich stabil.
Gruss und Dank
Heiko
WPM v19.0 last Hotfix 31.05.19


Bank on IT - inventx
IT-Partner für führende Finanz- und Versicherungsdienstleister

Benutzeravatar
Timmaeh
Beiträge: 27
Registriert: 16. Dez 2014, 16:54
Kontaktdaten:

Re: UEM-Agent (1809)

Beitrag von Timmaeh » 29. Jan 2019, 08:58

Den Advanced Agent mit dem UEM Agent direkt zu ersetzten funktioniert bei uns auch nur beui deaktiviertem TrendMicro-Virenscanner.

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast