Seite 1 von 1

Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 14:05
von Dennis1907
Hallo zusammen,

ich habe heute die neuste Version von Ghostscript in der 32 Bit Version paketiert. Diese lässt sich im Standard Template ohne Probleme mit installieren. Auch über eine Zuweisungsgruppe wird die alte Version deinstalliert und die neue installiert.

Nun habe ich den Fall, dass ich auf einem neuinstallierten System (ohne Software) die neue Ghostscript Version aus dem Depot installieren konnte. Die Deinstallation aus dem Depot funktioniert ebenso. Versucht man jedoch dann, Ghostscript erneut zu installieren, läuft das ganze in einen Fehler (siehe Anhang).

Auch nach säubern der registry lässt sich Ghostscript nicht mehr installieren.

Hat hier jemand eine Idee, woran das ganze liegen kann?

Vielen Dank und Gruß
Dennis

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 14:22
von r.wiegel
Funktioniert die Reinstallation dann, wenn IF-Abfrage(n) auskommentiert werden?
Die Setup.inf wäre hilfreich...

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 14:26
von Dennis1907
r.wiegel hat geschrieben:
28. Okt 2019, 14:22
Funktioniert die Reinstallation dann, wenn IF-Abfrage(n) auskommentiert werden?
Die Setup.inf wäre hilfreich...
Auch mit auskommentieren der IF Abfrage in der Installation funktioniert die Reinstallation nicht. Ich habe die Setup.inf einmal angehangen

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 14:41
von r.wiegel
Steht etwas (z.B. %Errorlevel%) im SetupErrorLog?
Bei einer Reinstallation ändert sich der Pfad von %src% auf %app%. Evtl. fehlt die Datei unter dem Pfad für die Reinstallation.
Klappt die Reinstallation mit der Option "Vorherige Deinstallation - Aktivieren"?

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 14:52
von Dennis1907
Das SetupErrorLog des Clients ist leer.

Was ich nicht ganz verstehe ist, dass das ja dann keine Reinstallation ist sondern eine Installation, da ich das Sprogramm vorher deinstalliiert habe und dann nochmals versucht habe, dieses dann wieder aus dem Depot zu installieren.

Habe es testweise auch über eine Softwaregruppe in der EMC versucht, per Reinstall und dann vorherige Deinstallation aktivieren. Jedoch ohne Erfolg :?:

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 28. Okt 2019, 15:17
von r.wiegel
da ich das Sprogramm vorher deinstalliiert habe...
wie deinstalliert? Über Systemsteuerung?
Wurde dabei lediglich GH deinstalliert und nicht das "Empirum-Paket + GH"?
Ich vermute, dass lediglich die Anwendung selbst deinstalliert wurde, das Paket befindet sich im Status "installiert".
Der Agent ersetzt %src% durch %app%, um auf Setup.inf zuzugreifen aber auch auf den Installer.

Re: Ghostscript schlägt bei erneuter Installation fehl

Verfasst: 30. Okt 2019, 09:24
von Dennis1907
Nein, ich habe Ghostscript über das Software Depot installiert und dann wieder über das Software Depot erfolgreich deinstalliert. Die erneute Installation über das Software Depot schlägt dann aber fehl.