PM2Client.exe - Fehler in Anwendung

Moderatoren: MVogt, moderators

Antworten
Thomas Weinberger
Beiträge: 15
Registriert: 15. Dez 2004, 13:42
Wohnort: Nürnberg
Kontaktdaten:

PM2Client.exe - Fehler in Anwendung

Beitrag von Thomas Weinberger » 28. Sep 2006, 10:47

Hallo Zusammen,

wir sind aktuell dabei unsere Windows XP SP2 PCs mit Patchmanagment V2 zu aktualisieren. Inzwischen haben sich zum Stand Service Pack 2 einige Patches angesammelt, daher rufen wir den PM2Client per Shutdown-Script auf, damit die Anwender schonmal heimgehen können.

Bei der Installation ist nun auf 2 Rechner ein Anwendungsfehler in der PM2Client.exe aufgetreten:

[font=Courier New]Die Anweisung in "0x004122207" verweist auf Speicher in "0x00000000000". Der Vorgang "read" konnte nicht auf dem Speicher durchgeführt werden.
[/font]
Beim nächsten Aufruf macht PM2 weiter und installiert die restlichen fehlenden Patches.

Nachdem die betreffenden PCs nur einige Monate alt sind, ist ein Hardwareproblem ziemlich unwahrscheinlich - es klingt eher nach einem Anwendungsproblem der PM2Client.exe. Gibts hierzu Erfahrungen und evtl. schon Lösungen?

Gruß,
Thomas Weinberger

Thomas Weinberger
Beiträge: 15
Registriert: 15. Dez 2004, 13:42
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von Thomas Weinberger » 29. Sep 2006, 11:27

Inzwischen hat sich das Problem etwas eingrenzen lassen:

die Ursache für den Programmabsturz scheint in der Abarbeitung des Shutdown-Scripts von Windows zu liegen. Die Installation läuft in diesem Fall ja unter dem Systamaccount ab (Installation für SYSTEM) und der Programmfehler tritt reproduzierbar nur in dieser Konstellation auf. Startet man den PM2Client im Logon-Script oder direkt über Softwaredepot ist alles ok.

Gibt es hierzu Erkenntnisse und evtl. Tipps, wie man den Fehler beseitigen kann bzw. warum sich PM2 im Shutdown-Script anders verhält?

ckessler
Beiträge: 83
Registriert: 15. Mär 2006, 16:29
Wohnort: Rheinhessen
Kontaktdaten:

Ähnlicher Fehler im Logon-Betrieb

Beitrag von ckessler » 29. Sep 2006, 17:03

Hier im Haus läuft der PM-Client nach der Benutzeranmeldung. Der Fehler tritt auch bei uns sporadisch und nicht reproduzierbar auf, als Urheber wird allerdings die Setup.exe genannt.
Installation der Patches wird ebenfalls nach der nächsten Anmeldung fortgesetzt.
Computer sind großartig.
Sie helfen uns die Probleme zu lösen, die wir ohne Computer gar nicht hätten.

Thomas Weinberger
Beiträge: 15
Registriert: 15. Dez 2004, 13:42
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von Thomas Weinberger » 04. Okt 2006, 11:57

bei der Ausführung von PM2Client per Logon-Skript hatten wir bisher keine Probleme ... nur die Anwender müssen eben warten, bis die Prüfung und vorallem die Installation der fehlenden Patches durchgelaufen ist :roll:

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste