Windows 7 Installation - Produktkey

Moderator: jknoth

Antworten
HHeile
Beiträge: 10
Registriert: 15. Nov 2010, 16:20
Kontaktdaten:

Windows 7 Installation - Produktkey

Beitrag von HHeile » 11. Mär 2011, 11:56

Moin,

ich habe folgendes vor:

Ich habe eine kleine Laborumgebung.
In dieser haben ich das BEtriebssystem Win7 Pro OEM importiert, was auch funktioniert hat.
Im Template habe ich folgendes angegeben:

Architektur Win7Pro x32
Installation ohne Angabe des Produktkeys
Automatisch Aktivieren habe ich deaktiviert


Mein Ziel dabei ist, die Installation komplett durchzuführen und am Ende den Key manuell einzutragen.

Was passiert:
zunächst läuft alles normal:
MEKO0012 11.03.2011 11:35:24 [Eis32] Performing reboot.
MEKO0012 11.03.2011 11:35:24 [Eis32] Total elapsed time: 8 min
MEKO0012 11.03.2011 11:35:23 [Eis32] Selected SKU: Windows 7 PROFESSIONAL
MEKO0012 11.03.2011 11:35:16 [Eis32] MachineIdNum: 224996_122202
MEKO0012 11.03.2011 11:35:12 [Eis32] Sound Adapter : No Sound Adapter detected!
MEKO0012 11.03.2011 11:35:12 [Eis32] Sound Adapter : No PCI-Sound Adapter detected!
MEKO0012 11.03.2011 11:35:12 [Eis32] Display Adapter: Index not unique! 32902-66-6058-12371
MEKO0012 11.03.2011 11:32:16 [Eis32] Storage Adapter: SATA detected with: 32902-15138-6058-12371
MEKO0012 11.03.2011 11:30:35 [Eis32] Network Adapter: Intel(R) 82578DM Gigabit Network Connection
MEKO0012 11.03.2011 11:28:52 [Eis32] Performing hardware detection...
MEKO0012 11.03.2011 11:28:51 [Eis32] Total elapsed time: 1 min
MEKO0012 11.03.2011 11:28:30 [Eis32] Transferring Empirum components [about 1 minute...]
MEKO0012 11.03.2011 11:27:58 [Eis32] Transferring WinPE 2.x patch files [about 1 minute...]
MEKO0012 11.03.2011 11:27:58 [Eis32] File copy process successful.
MEKO0012 11.03.2011 11:27:58 [Eis32] Total elapsed time: 0 min
MEKO0012 11.03.2011 11:27:58 [Eis32] Copying installation files.
MEKO0012 11.03.2011 11:27:58 [Eis32] Total elapsed time: 0 min
MEKO0012 11.03.2011 11:27:57 [Eis32] Using service partition: 2 on disk: 0 drive letter: S
MEKO0012 11.03.2011 11:27:57 [Eis32] Using system partition: 1 on disk: 0 drive letter: C
MEKO0012 11.03.2011 11:27:56 [Eis32] Assigning drive letters...
MEKO0012 11.03.2011 11:27:56 [Eis32] Disk/MB: 0/305245 parttypes/MB: 7/297241 12/8001 0/0 0/0 free/used: 0/305242
MEKO0012 11.03.2011 11:27:56 [Eis32] Hard disk formating/partitioning successful.
MEKO0012 11.03.2011 11:27:56 [Eis32] Created partition: 1 on disk: 0 with size: 297241
MEKO0012 11.03.2011 11:27:54 [Eis32] Creating partition: 1 on disk: 0 with size: 0
MEKO0012 11.03.2011 11:27:54 [Eis32] Creating all partitions...
MEKO0012 11.03.2011 11:27:54 [Eis32] Disk/MB: 0/305245 parttypes/MB: 0/0 12/8001 0/0 0/0 free/used: 297244/8001
MEKO0012 11.03.2011 11:27:54 [Eis32] Disk: 0 partition: 2 is preserved - due partition number exclusion
MEKO0012 11.03.2011 11:27:54 [Eis32] Deleting partitions...
MEKO0012 11.03.2011 11:27:54 [Eis32] Disk/MB: 0/305245 parttypes/MB: 7/297241 12/8001 0/0 0/0 free/used: 0/305242
MEKO0012 11.03.2011 11:27:53 [Eis32] Preparing hard disks.
MEKO0012 11.03.2011 11:27:53 [Eis32] Entering re-installation mode
MEKO0012 11.03.2011 11:27:53 [Eis32] Target device for OS-Installation: /dev/sda
MEKO0012 11.03.2011 11:27:53 [Eis32] TCP/IP address: DHCP
MEKO0012 11.03.2011 11:27:53 [Eis32] Domain/Workgroup: Dom: meko-s.local
MEKO0012 11.03.2011 11:27:53 [Eis32] Computer name: LAB01
MEKO0012 11.03.2011 11:27:53 [Eis32] Image name: win7 x86 PRO DE SP0
MEKO0012 11.03.2011 11:27:53 [Eis32] Total elapsed time: 0 min
MEKO0012 11.03.2011 11:27:53 [Eis32] Connected Empirumserver: sd01 IP: 10.200.1.10
MEKO0012 11.03.2011 11:27:52 [Eis32] Current client mac address: 1078D2AAE77B IP: 10.11.11.33
MEKO0012 11.03.2011 11:27:52 [Eis32] Empirum OS-Installation script Ver. 01.52
MEKO0012 11.03.2011 11:27:51 [Eis32] Empirum Eis32 Ver. 12.1.1.38
MEKO0012 11.03.2011 11:27:47 [TimeOutThread] 11.02.2011 11:28.45 - Eis32 Time Out Thread: Start!
MEKO0012 11.03.2011 11:27:47 [seldest] entering runlevel
MEKO0012 11.03.2011 11:27:42 [getimage] entering runlevel
MEKO0012 11.03.2011 11:27:39 [getconfig] entering runlevel
MEKO0012 11.03.2011 11:27:39 [raidsetup] entering runlevel
MEKO0012 11.03.2011 11:27:39 [TimeOutThread] 11.02.2011 11:28.37 - Eis32 Time Out Thread: End!
MEKO0012 11.03.2011 11:27:37 [TimeOutThread] 11.02.2011 11:28.35 - Eis32 Time Out Thread: Start!
MEKO0012 11.03.2011 11:27:34 [networking ] You can connect to observe the Client's state by browsing to http://10.11.11.33
MEKO0012 11.03.2011 11:27:34 [sshd ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [networking ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [epelog ] Empty mount point. Logs are saved local as /tmp/
MEKO0012 11.03.2011 11:27:34 [epelog ] EPE will automatically continue with the detection in 10 seconds
MEKO0012 11.03.2011 11:27:34 [modsetup ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [epelog ] Optionally insert a USB device now. SPY and log will be copied
MEKO0012 11.03.2011 11:27:34 [startx ] browser executed successfully
MEKO0012 11.03.2011 11:27:34 [httpd ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [startx ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [lo ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [syslog ] starting syslogd
MEKO0012 11.03.2011 11:27:34 [syslog ] starting klogd
MEKO0012 11.03.2011 11:27:34 [logon] entering runlevel
MEKO0012 11.03.2011 11:27:34 [boot ] msg_enter
MEKO0012 11.03.2011 11:27:34 [uncrypt ] decryption completed successfully
MEKO0012 11.03.2011 11:27:34 [uncrypt ] decrypting ...
MEKO0012 11.03.2011 11:27:34 [sshd ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [networking ] You can connect to observe the Client's state by browsing to http://10.11.11.33
MEKO0012 11.03.2011 11:27:34 [uncrypt ] reading disk.ini
MEKO0012 11.03.2011 11:27:34 [networking ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [epelog ] Empty mount point. Logs are saved local as /tmp/
MEKO0012 11.03.2011 11:27:34 [epelog ] EPE will automatically continue with the detection in 10 seconds
MEKO0012 11.03.2011 11:27:34 [epelog ] Optionally insert a USB device now. SPY and log will be copied
MEKO0012 11.03.2011 11:27:34 [modsetup ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [startx ] browser executed successfully
MEKO0012 11.03.2011 11:27:34 [startx ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [httpd ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [lo ] entering runlevel
MEKO0012 11.03.2011 11:27:34 [syslog ] starting syslogd
MEKO0012 11.03.2011 11:27:34 [syslog ] starting klogd
MEKO0012 11.03.2011 11:27:34 [boot ] msg_enter
MEKO0012 11.03.2011 11:27:34 [uncrypt ] decryption completed successfully
MEKO0012 11.03.2011 11:27:34 [uncrypt ] decrypting ...
MEKO0012 11.03.2011 11:27:34 [uncrypt ] reading disk.ini

dann startet er neu, und die Installation beginnt.
Auch normal.
Anschließend kommt folgendes Fenster:

Fenstername: Windows einrichten

Geben Sie den Produktkey ein:
<Feld zum eingeben des Produktkeys>

Windows automatisch aktivieren, wenn eine Verbindung besteht ist aktiviert.

Hier drücke ich einmal die Eingabe, und es geht weiter.



Fragen: was bedeutet die Meldung
Display Adapter: Index not unique! 32902-66-6058-12371 - im EIS Log?

Wie bekomme ich das hin, das die Installation weiter läuft, ohne das ich einmal zwischendurch die Eingabetaste drücken muss?

Gruesse

HHeile
Using:
Empirum v14
ServiceStore 5.30.840.0

ralph.hinkel
Beiträge: 21
Registriert: 14. Dez 2004, 12:09
Wohnort: Pirmasens
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von ralph.hinkel » 05. Mai 2011, 15:18

Hallo,

nur Windows 7 Enterprise unterstützt die unattended Installation ohne Eingabe eines Product Keys. Alle anderen bleiben an besagtem Fenster stehen. Vielleicht einfach den KMS-Schlüssel (http://technet.microsoft.com/en-us/libr ... 93406.aspx) eintragen und später über die Command Line mit dem richtigen Schlüssel ersetzen.

Gruß
Ralph

Phadda
Beiträge: 654
Registriert: 18. Jun 2009, 14:53
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von Phadda » 05. Mai 2011, 16:36

Win 7 Pro unterstützt unattended.xml da wir dies so mit der V14 nutzen mit dem aktuellen WAIK als Grundlage. Wobei wir via KMS die Lizenzierung tätigen, was auch für Office 2010 passt.

ralph.hinkel
Beiträge: 21
Registriert: 14. Dez 2004, 12:09
Wohnort: Pirmasens
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von ralph.hinkel » 05. Mai 2011, 16:52

Natürlich unterstützt auch die Pro-Version unattended.xml. Aber sie unterstützt nicht die

Unattended-Installation ohne Eingabe eines Product Keys !

Könnt Ihr auch in der Matrix-Knowledge Base nachlesen und meine Erfahrungen damit bestätigen dies ebenfalls.

Gruß
Ralph

Phadda
Beiträge: 654
Registriert: 18. Jun 2009, 14:53
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von Phadda » 06. Mai 2011, 07:58

In der XML steht bei uns:

Code: Alles auswählen

<ProductKey>
                    <WillShowUI>OnError</WillShowUI>
                    <Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
 </ProductKey>
In der Betriebssystemkonfiguration ist "Windows Product key: Installation ohne Angabe des Product Keys" aktiviert.
Somit installier ich ohne Probleme die Pro Version ohne einen Productkey in Empirum einzutragen. Ist das dann ein Bug?

Benutzeravatar
tgrosch
Beiträge: 602
Registriert: 14. Nov 2007, 16:34
Wohnort: Fulda
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von tgrosch » 06. Mai 2011, 09:02

Vielleicht hilft euch das hier weiter: http://blogs.technet.com/b/dmelanchthon ... 08-r2.aspx
Viele Grüße

Tobias
---
Empirum Echtsystem: v19 - 19.0.1 - Win 2012 R2 mit EPE 4.7.3 und UEM Agent 1905.1
Empirum Testsystem: v19 - 19.0.1 - Win 2012 R2 mit EPE 4.7.5 und UEM Agent 1906.1
Workplace Management Echtsystem: ServiceStore 9.1.0.2532 - Win 2012 R2
Workplace Management Testsystem: ServiceStore 9.1.0.2532 - Win 2016
MDM: Silverback 18.0.3.27
DB-Server: Win 2012 R2 mit SQL 2014

Benutzeravatar
thahn
Beiträge: 486
Registriert: 03. Jan 2007, 09:03
Wohnort: KR - NRW
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von thahn » 06. Mai 2011, 10:40

Moin,

solange es sich es sich nicht um eine OEM - Source meldet, sollten sich PRO - ENTERPRISE - ULTIMATE auch ohne Angabe eines Key installieren lassen.

Wenn die Installation stehen bleibt, dann nur in dem Auswahlfenster - welche Version installiert werden soll. Dann stimmt meist die SKU Angabe im Template nicht mit der importierten Source überein.

cYa
Thomas Hahn
Technical Account Manager

Matrix42 AG

Email: thomas.hahn[at]matrix42.com
http://www.matrix42.de
Skype: thahn42
ICQ: IO25IGO8

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of matrix42 AG.

Phadda
Beiträge: 654
Registriert: 18. Jun 2009, 14:53
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von Phadda » 06. Mai 2011, 11:22

Die Aussage passt, wir haben nur offizielle ISOs von MS und keine OEMs genutzt wie HHeile ;-)

Benutzeravatar
thahn
Beiträge: 486
Registriert: 03. Jan 2007, 09:03
Wohnort: KR - NRW
Kontaktdaten:

Re: Windows 7 Installation - Produktkey

Beitrag von thahn » 06. Mai 2011, 11:37

Hi,

jetzt habe ich gerade mal in der Knowledge Base geschaut, vermutlich der Artikel #KBA00410 ???

meine Aussage bezieht auf meine eigenen Erfahrungen, ich habe gerade mal eine Info an den Support geschickt,

und um das Thema von HHeile aufzugreifen, OEM Versionen sind etwas tricky, aber über einige kleine EIS-Anpassungen lässt sich auch dem Window 7 noch der OEM-Key unterschieben über eine Variable. Konnten wir bei XP auch schon ;-).

aber es stimmt schon in erster Linie möchten wir eben "Volumen-Lizenzen" verteilen, weil das der gängige Weg ist.
cYa
Thomas Hahn
Technical Account Manager

Matrix42 AG

Email: thomas.hahn[at]matrix42.com
http://www.matrix42.de
Skype: thahn42
ICQ: IO25IGO8

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of matrix42 AG.

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste