Hardwareprofil - Tarox Basic PC 3000 (2012)

Moderator: jknoth

Antworten
s.schneider
Beiträge: 15
Registriert: 26. Okt 2012, 11:24
Wohnort: Neuenrade
Kontaktdaten:

Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von s.schneider » 21. Mai 2013, 13:41

Hallo Zusammen!

Ich habe ein Problem bei der Treiberinstallation bzw. schon bei der Bereitstellung der Treiber für einen PC der Firma Tarox.

Das Hardware-Profil wurde durch den Hardware-Assistenten erkannt und angelegt. Computertyp Tarox > Basic PC 3000 (2012) Allerdings mit keinerlei sonstigen Geräten.

In diesem besagten Tarox PC steckt ein Asus P8H61-MX R2.0 Board, ausgestattet mit einem Intel Core i3-2120

Auf der beiliegenden Treiber-CD befinden sich Treiber für eine "VIA High Definition Audio" Soundkarte, "Intel(R) Graphics Family" Grafikkarte, "Intel(R)6 Series/C200 Series Chipset Family SMBus Controller -1C22" Chipsatz und "Intel(R) Management Engine Interface" Treiber.

Ich habe dann diese Treiber von der CD als manuelle sonstige Pakete angelegt und dem PC-Profil zugeordnet.
Den Chipsatz natürlich wie in der Anleitung beschrieben, als erstes.

Allerdings werden die Treiber nicht richtig installiert!

Auf Nachfrage bei der Firma Tarox wurde mir gesagt, dass der Grafik-Chip im Prozessor säße und man dadurch Probleme bei der Installation über eine Software-Verteilung bekommen könne. Aber auch die Soundkarte lässt sich nicht mit den bereitgestellten Treibern installieren.

Was mache ich falsch, bzw was muss ich beachten? Da dies mein erstes Installieren mit einem Hardware-Profil ist, bin ich total ratlos und für jede Hilfe dankbar!

Das verwendete Betriebssystem ist Windows 7 SP1 (32Bit)

Gruß

Sebastian

skoch
Beiträge: 7
Registriert: 28. Mai 2009, 10:05
Kontaktdaten:

Re: Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von skoch » 24. Mai 2013, 09:29

Hallo Sebastian,
was bedeutet die Treiber werden nicht richtig installiert?
Bitte überprüfe mal folgendes.
Auf dem Client sollten in der Windows Installations Partition im Verzeichnis Install\drivers die Ordner mit deinen Treibern sein.
Sind dort alle deine eingebundenen Treiber vorhanden?
Wenn nein, hast du beim Einbinden der Treiber einen Fehler gemacht.

Ich gehe bei neuen PCs immer folgendermaßen vor.
1. Erst den HW-Spy erstellen und die Netzwerk und Grafikkarte einbinden.
2. den PC mit Hand installieren, erst mal noch ohne Treiber.
3. Im Gerätemanager die Hardware-IDs der fehlenden Geräte aufschreiben.
4. Den ersten Treiber installieren und in der Treiber-Datenbank über die HW-ID nach dem Treiber suchen.
Meistens ist der passende oder ein vergleichbarer Treiber vorhanden.
Ist kein Passender Dabei, in den inf Dateien der Vergleichbaren Treiber schauen ob die HW auch unterstützt wird.
Ist auch bei den Vergleichbaren kein passender Treiber vorhanden dann, einen neuen mit entsprechender HW ID einbinden.
5. Das Spiel auch für die restlichen Treiber durchführen.
6. 2. Baugleichen PC nehmen und mit Empirum installieren. Ist kein Baugleicher vorhanden, baue ich eine neue Festplatte in den PC und lege die von Hand installierte als Referenz bei Seite.
7. Nach der Installation prüfen ob alle Treiber installiert worden sind. Wenn noch einer Fehlt kann ich anhand der Hardware ID sehen welcher es ist.
8. Bei fehlenden Treibern in der Windows Installations Partition schauen ob er runtergeladen wurde.
Nein -> wurde er im HW-Profil zugewiesen und ist er unter EMPIRUMSERVER\EMPinst$ \drv\OS-VERSION\HwMisc vorhanden?
JA -> Nimmt Windows den Treiber an, wenn ich im Gerätemanager die inf zuweise?

Über diesen Weg bekomme ich eigentlich fast immer alle Treiber zum Laufen. Wenn es dann immer noch nicht funktioniert, dann wird es kompliziert und die grauen Zellen müssen richtig arbeiten :D

Gruß Sven

s.schneider
Beiträge: 15
Registriert: 26. Okt 2012, 11:24
Wohnort: Neuenrade
Kontaktdaten:

Re: Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von s.schneider » 27. Mai 2013, 08:05

Guten Morgen Sven,

Erst einmal einen riesen Dank, dass du dir die Mühe gemacht hast und mir eine so detailierte Antwort gegeben hast.

Ich werde die einzelnen Schritte heute mal nachverfolgen und das ausprobieren.

Am Anfang bin ich natürlich auch hingegangen und habe die mit dem Spy erkannten Geräte (Netzwerk & GraKa) eingebunden. ABER, da fängt der Spaß bei mir schon an... Ich habe laut Hersteller eine Grafikkarte die auf dem Prozessor-Chip sitzt. In den Eis32-Logs steht, dass ich als Display Adapter eine Intel(R) HD Graphics habe, was auch stimmt, aber er wird nicht installiert. (Zu der Zeit hatte ich noch keine Misc-Gruppe für den PC angelegt)

Wie durchsuche ich denn die Treiber-Datenbank nach der HW-ID? Alles einzeln durchklicken, oder gibts da ne andere Chance?

Und was tue ich, wenn der hwmisc Ordner komplett leer ist, obwohl ich 4 Treiberpakete dem zugeordnet habe? :)

Gruß

Sebastian

skoch
Beiträge: 7
Registriert: 28. Mai 2009, 10:05
Kontaktdaten:

Re: Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von skoch » 27. Mai 2013, 09:25

Guten Morgen Sebastian,

hast du dir das Handbuch zur Treiberintegration schon mal durchgelesen?
http://helpfiles.matrix42-web.de/2013_D ... ion|_____0

Wie hast du den Treiber für die Graka eingebunden? Hast du einen Treiber bei Matrix heruntergeladen oder einen eigenen eingebunden?
Der Garka Treiber sollte in einem Unterverzeichnis unter EMPIRUMSERVER\EMPinst$ \drv\OS-VERSION\Display liegen. Wie der Ordner heißt siehst du in den Treibereigenschaften. Mir ist es schon zwei Mal passiert, dass bei einem Treiber von Matrix der Ordner zwar angelegt wurde aber leer war. Dann muss man den Treiber halt von Hand in den Ordner kopieren.
Wie durchsuche ich denn die Treiber-Datenbank nach der HW-ID?
Richtig durchsuchen kann man die Treiberdatenbank leider nicht. Aber in der Listenansicht der Treiber sind die letzten vier Spalten VendorID, DeviceID, SubvendorID und SubdeviceID.
Ich sortiere dann immer nach DeviceID und scrolle mich durch, nach einem Treiber mit der Gleichen ID. Dann schaue ich mir im Treiberverzeichnis die inf-Dateien an, ob mein Gerät auch davon unterstützt wird. Denn die meisten Hersteller geben gerade für Chip-Sätze Family-Treiber raus, die mehrere Geräte unterstützten.
Sollte ein passender Treiber dabei sein, erstelle ich einen neuen Treiber und verlinke auf den alten.
Wie das genau geht, steht im Handbuch Treiberintegration.

Wenn der HWmisc Ordner leer ist, hast du wirklich im richtigen OS Ordner geschaut?
Wenn ja hast du bei der Treiberintegration einen Fehler gemacht und den Treiber vielleicht einem falschen OS zugeordnet. Du siehst ja in den Treibereigenschaften wie die Ordner heißen sollten und kannst mal auf dem Server nach dem Ordner suchen.

Gruß Sven

s.schneider
Beiträge: 15
Registriert: 26. Okt 2012, 11:24
Wohnort: Neuenrade
Kontaktdaten:

Re: Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von s.schneider » 27. Mai 2013, 09:46

Die Anleitung hab ich mir schon durchgelesen, sonst wüsst ich ja nicht wie ich nen HWprofil anlege und mit Treibern versorge! :)

in hwmisc wird der Ordner des PCs korrekt angelegt, aber da drin ist nix, habe aber vier sonstige Treiber zugeordnet.

Den Treiber der GraKa hab ich mit eigenen Treibern integriert, weil von Matrix wurden keine gefunden.

skoch
Beiträge: 7
Registriert: 28. Mai 2009, 10:05
Kontaktdaten:

Re: Hardwareprofil - Tarox Basic PC 3000 (2012)

Beitrag von skoch » 27. Mai 2013, 10:15

Im PC Ordner unter HwMisc sollten auch nur die 2 Dateien Eis_DFL_.tbl und Eis_LFN_.tbl sein.
Die Ordner der Sonstigen Treiber sollten direkt unter HwMisc liegen.

Ist der GraKa Treiber im Unterordner von Display und sind die Treiberdateien auch im Ordner?
Wird der Treiber auch auf die Installpartition des PC kopiert?

Gruß Sven

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: Majestic-12 [Bot] und 15 Gäste