Bild

WinPE - PreOS-Package PXEOffAndReboot funktioniert mit Dell-Hardware nicht?

Moderator: jknoth

Antworten
CLuk
Beiträge: 2
Registriert: 12. Apr 2018, 13:39
Kontaktdaten:

WinPE - PreOS-Package PXEOffAndReboot funktioniert mit Dell-Hardware nicht?

Beitrag von CLuk » 18. Apr 2019, 09:27

Liebe Empirum-Gemeinde,

Wir haben bei uns gerade WinPE eingeführt und sind an den ersten Tests mit unseren Dell-Rechnern. Das Setup klappt eigentlich wunderbar, auch ein eigenes PreOS-Package für die Anpassung des Win10-Startmenü-Layouts, bzw. der vorinstallierten Apps hat ganz gut geklappt.

Eine kleineres Problem, dessen Lösung aber fürs Aufsetzen mehrerer hunderter PCs viel Zeit sparen würde, wäre:

Mit unseren Dell-Geräten funktioniert das PreOS-Package PXEOffAndReboot nicht richtig. Die Rechner fahren trotz erfolgreicher Paketausführung immer noch bei jedem Reboot mit PXE an, obwohl dieses PreOS-Package ja genau das verhindern sollte, oder habe ich da etwas falsch verstanden? Reihenfolge der OS-Packages ist richtig gesetzt, die Rechner werden ansonst sauber mit dem OS aufgesetzt. Muß dafür im UEFI/BIOS eine Einstellung gesetzt werden, um die Kontrolle über das PXE dem (Pre-)OS zu überlassen?

Betroffene Hardware bei uns momentan:
Dell XPS 13 (in verschiedenen Varianten)
Dell OptiPlex 5030

Gibts da etwas, das ich evtl. übersehe?

[Edit]:
Noch vergessen, zu erwähnen:
Wir setzen Empirum in der Version 18.0.3 mit aktuellem Hotfix ein, das PXEOffAndReboot-PreOS-Package in der Version 1.0

-----------
Lösung:
Ich hatte etwas falsch verstanden, das PXEOffAndReboot-PreOS-Package dient nicht dazu, die Bootreihenfolge zu ändern, sondern lediglich dem Empirum bekannt zu machen, dass der Rechner nicht mehr PXE-aktiviert sein soll.

Über den tap-Servicedesk habe ich folgende Lösung erhalten:

In der Install.ps1 des WindowsInstall-PreOS-Packages:
unter

Code: Alles auswählen

\Empirum\Configurator\Packages\matrix42\OsPackages\WindowsInstallation\VERSIONSNUMMER\Install
gibt es eine Zeile (Zeilennummer kann je nach WindowsInstallation-Version variieren)

Code: Alles auswählen

$argumentString = '/unattend:X:\UAF\unattend.xml /NoReboot /AddBootMgrLast'; 
Bitte tauschen Sie diese Zeile mit der folgenden aus (bzw. löschen einfach den Parameter "/AddBootMgrLast":

Code: Alles auswählen

$argumentString = '/unattend:X:\UAF\unattend.xml /NoReboot'; 
Nach dieser Änderung hat's wunderbar geklappt mit der richtigen Bootreihenfolge

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste