[Solved] Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Moderator: jknoth

Antworten
AKießling
Beiträge: 22
Registriert: 13. Feb 2018, 12:20
Kontaktdaten:

[Solved] Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von AKießling » 29. Mai 2019, 10:49

Moin zusammen,

nachdem die letzten Wochen unser OS Deployment - Windows 10 1803 - mit WinPE via PXE in den USA über deren Subdepot soweit problemlos funktioniert hat, hat mir unser US-Kollege gestern ein kleines Problem, welches beim Windows-Setup auftritt, gemeldet.

Hierbei erscheint folgende Fehlermeldung:
https://abload.de/img/windows-setupzxk2z.jpg

„Windows could not apply the unattend answer file’s <DiskConfiguration> setting.

Man muss dazu sagen hierbei handelt es sich um neue Dell Optiplex 7060 Geräte. Das Matrix42 OS-Deployment für dieses Modell haben wir letzte Woche bei uns ebenfalls getestet und hatten hierbei keinerlei Fehler.

Ich habe heute Morgen den ganzen Prozess für einen US-Client mit Hilfe einer virtuellen Testmaschine auf unserer HyperV-Umgebung nachgestellt und hierbei lief das OS-Deployment ohne Fehler durch.

Könnt ihr mir sagen was hierbei das Problem ist oder einen Tipp geben?

Vielen Dank im Voraus!

Mit freundliche Grüßen

André Kießling
Zuletzt geändert von AKießling am 18. Jun 2019, 16:47, insgesamt 1-mal geändert.

Benutzeravatar
Rumpelstilzchen
Beiträge: 36
Registriert: 25. Jan 2018, 16:15
Kontaktdaten:

Re: Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von Rumpelstilzchen » 29. Mai 2019, 11:11

Hi André,

auf den Server wird die Unattend-Datei als "debug_unattend.xml" übertragen. Dort könnte man nachschauen ob der Eintrag auf den ersten Blick korrekt ist:

Code: Alles auswählen

<DiskConfiguration>
        <WillShowUI>OnError</WillShowUI>
        <Disk>
          <DiskID>0</DiskID>
          <WillWipeDisk>false</WillWipeDisk>
          <ModifyPartitions>
            <ModifyPartition>
              <Order>1</Order>
              <PartitionID>4</PartitionID>
              <Letter>C</Letter>
            </ModifyPartition>
          </ModifyPartitions>
        </Disk>
</DiskConfiguration>
Auf dem Client kann man mit DISKPART schauen ob nicht eventuell bereits Parititonen angelegt wurden und DOCH schon einmal Deployment statt fand. (Mehrere Festplatten eventuell?)

In den DiskPartitioning-Variablen kann man ein verstecktes Feature benutzen: die Variable "ClearAllDisks" anlegen und auf "1" setzen. Das wird alle Platten zurücksetzen (Clear-Disk). Das hilft eventuell, wenn ein Deployment eventuell auf einer anderen Platte bereits durchgeführt worden ist.

Ansonsten vielleicht die Variablen überprüfen
Heute backe ich morgen braue ich: Fehler könnten sich einschleichen und die Aussagen sind zu überprüfen - ich übernehme keine Verantwortung für das geschriebene Wort

AKießling
Beiträge: 22
Registriert: 13. Feb 2018, 12:20
Kontaktdaten:

Re: Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von AKießling » 29. Mai 2019, 12:06

Hallo Rumpelstilzchen,

der Hinweis mit der debug_unattend.xml war schon gut. (Hab vor dem Schreiben des Beitrags auf dem kompletten Depot-Srv sowieso mal ne Suche nach allen *unattend.xml gestartet. :lol: )

Die debug_unattend.xml sieht schon mal korrekt aus, aber die debug_Matrix42.Platform.Service.Host, welche im gleichen Ordner für den Client liegt, der auf Fehler gelaufen ist, hat etwas auffälliges, was die Initialisierung von disk 0 angeht.

Code: Alles auswählen

2019-05-24 10:21:29.494 [Information] [Process.OutputReadNotifyUser] Start partitioning...
2019-05-24 10:21:36.413 [Information] [Process.OutputReadNotifyUser] Clearing disk 0 ...
2019-05-24 10:21:36.921 [Information] [Process.OutputReadNotifyUser] Initialising disk 0 with standard GPT layout ...
2019-05-24 10:21:36.923 [Error] [Process.ErrorReadNotifyUser] Clear-Disk : No MSFT_Disk objects found with property 'Number' equal to '0'.  Verify the value of the property and 
2019-05-24 10:21:37.115 [Error] [Process.ErrorReadNotifyUser] retry.
2019-05-24 10:21:37.125 [Error] [Process.ErrorReadNotifyUser] At \\US-Subdepot\Configurator$\Packages\Matrix42\OsPackages\DiskPartitioning\3.3\install\install.ps1:49 char:2
2019-05-24 10:21:37.135 [Error] [Process.ErrorReadNotifyUser] +     Clear-Disk $disknum -RemoveData -RemoveOEM  -Confirm:$false
2019-05-24 10:21:37.145 [Error] [Process.ErrorReadNotifyUser] +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2019-05-24 10:21:37.156 [Error] [Process.ErrorReadNotifyUser]     + CategoryInfo          : ObjectNotFound: (0:UInt32) [Clear-Disk], CimJobException
2019-05-24 10:21:37.167 [Error] [Process.ErrorReadNotifyUser]     + FullyQualifiedErrorId : CmdletizationQuery_NotFound_Number,Clear-Disk
2019-05-24 10:21:37.177 [Error] [Process.ErrorReadNotifyUser]  
2019-05-24 10:21:37.188 [Error] [Process.ErrorReadNotifyUser] Initialize-Disk : No MSFT_Disk objects found with property 'Number' equal to '0'.  Verify the value of the property 
2019-05-24 10:21:37.199 [Error] [Process.ErrorReadNotifyUser] and retry.
2019-05-24 10:21:37.209 [Error] [Process.ErrorReadNotifyUser] At \\US-Subdepot\Configurator$\Packages\Matrix42\OsPackages\DiskPartitioning\3.3\install\install.ps1:51 char:5
2019-05-24 10:21:37.219 [Error] [Process.ErrorReadNotifyUser] +     Initialize-Disk $disknum -PartitionStyle GPT  -Confirm:$false
2019-05-24 10:21:37.229 [Error] [Process.ErrorReadNotifyUser] +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2019-05-24 10:21:37.240 [Error] [Process.ErrorReadNotifyUser]     + CategoryInfo          : ObjectNotFound: (0:UInt32) [Initialize-Disk], CimJobException
2019-05-24 10:21:37.250 [Error] [Process.ErrorReadNotifyUser]     + FullyQualifiedErrorId : CmdletizationQuery_NotFound_Number,Initialize-Disk
2019-05-24 10:21:37.260 [Error] [Process.ErrorReadNotifyUser]  
2019-05-24 10:21:37.270 [Error] [Process.ErrorReadNotifyUser] New-Partition : No MSFT_Disk objects found with property 'Number' equal to '0'.  Verify the value of the property and 
2019-05-24 10:21:37.279 [Error] [Process.ErrorReadNotifyUser] retry.
2019-05-24 10:21:37.289 [Error] [Process.ErrorReadNotifyUser] At \\US-Subdepot\Configurator$\Packages\Matrix42\OsPackages\DiskPartitioning\3.3\install\install.ps1:54 char:5
2019-05-24 10:21:37.298 [Error] [Process.ErrorReadNotifyUser] +     New-Partition -DiskNumber $disknum -GptType '{de94bba4-06d1-4d40- ...
2019-05-24 10:21:37.312 [Error] [Process.ErrorReadNotifyUser] +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2019-05-24 10:21:37.321 [Error] [Process.ErrorReadNotifyUser]     + CategoryInfo          : ObjectNotFound: (0:UInt32) [New-Partition], CimJobException
2019-05-24 10:21:37.332 [Error] [Process.ErrorReadNotifyUser]     + FullyQualifiedErrorId : CmdletizationQuery_NotFound_Number,New-Partition
2019-05-24 10:21:37.342 [Error] [Process.ErrorReadNotifyUser]  
2019-05-24 10:21:37.352 [Error] [Process.ErrorReadNotifyUser] New-Partition : No MSFT_Disk objects found with property 'Number' equal to '0'.  Verify the value of the property and 
2019-05-24 10:21:37.362 [Error] [Process.ErrorReadNotifyUser] retry.
So muss das Ganze aber aussehen (Log ist von meinem Testclient heute morgen):

Code: Alles auswählen

2019-05-29 02:05:38.469 [Information] [Process.OutputReadNotifyUser] Start partitioning...
2019-05-29 02:05:41.323 [Information] [ConnectionManager.RunExtension] I am running ...
2019-05-29 02:05:42.879 [Information] [Process.OutputReadNotifyUser] Clearing disk 0 ...
2019-05-29 02:05:45.546 [Information] [Process.OutputReadNotifyUser] Initialising disk 0 with standard GPT layout ...
2019-05-29 02:05:49.358 [Information] [Process.OutputReadNotifyUser] 
2019-05-29 02:05:52.278 [Information] [Process.OutputReadNotifyUser] DriveLetter FriendlyName FileSystemType DriveType HealthStatus OperationalStatus SizeRemaining   Size
2019-05-29 02:05:52.283 [Information] [Process.OutputReadNotifyUser] ----------- ------------ -------------- --------- ------------ ----------------- -------------   ----
2019-05-29 02:05:52.286 [Information] [Process.OutputReadNotifyUser] T           WindowsRE    NTFS           Fixed     Healthy      OK                    284.95 MB 300 MB
2019-05-29 02:05:52.289 [Information] [Process.OutputReadNotifyUser] S           SYSTEM       FAT32          Fixed     Healthy      OK                        96 MB  96 MB
2019-05-29 02:05:52.568 [Information] [Process.OutputReadNotifyUser] Initialising disk 0 with standard GPT layout - done
2019-05-29 02:05:52.649 [Information] [Process.OutputReadNotifyUser] Read the following variable values for Disk 0 from the Computer.ini: 
2019-05-29 02:05:52.652 [Information] [Process.OutputReadNotifyUser] SizeSystemPartition: 100 
2019-05-29 02:05:52.654 [Information] [Process.OutputReadNotifyUser] SizeDataPartition: 0 
2019-05-29 02:05:52.656 [Information] [Process.OutputReadNotifyUser] InterpretSizeInputAsProcentage: 1 
2019-05-29 02:05:52.659 [Information] [Process.OutputReadNotifyUser] MinimumSystemPartitionSize: 0 
2019-05-29 02:05:52.778 [Information] [Process.OutputReadNotifyUser] Available space on disk 0: 79.484375 
2019-05-29 02:05:52.811 [Information] [Process.OutputReadNotifyUser] UseAllAvailableDiskSpace is set to: True
2019-05-29 02:05:52.814 [Information] [Process.OutputReadNotifyUser] Create system partition using all available disk space...
2019-05-29 02:05:58.170 [Information] [Process.OutputReadNotifyUser] C           Windows      NTFS           Fixed     Healthy      OK                     79.38 GB ... GB
2019-05-29 02:05:58.176 [Information] [Process.OutputReadNotifyUser] Done.
Er findet also keine Festplatte (disk 0), die er zur Partitionierung hernehmen kann.

Hierbei werde ich heute mal den Ansatz mit der DiskPartitioning-Variable und dem verstecktes Feature testen: die Variable "ClearAllDisks" anzulegen und auf "1" zu setzen, sofern möglich nur für unsere US-Clients, weil wir eben dieses Problem bei unseren Optiplex 7060 nicht haben.

Wobei ich eher auf einen anderen Fehler tippe, was die UEFI-Settings der Optiplex7060-Geräte angeht, die unser US-Kollege nicht ordnungsgemäß durchgeführt hat.

Danke nochmal für den Hinweise. Ich werde berichten.
Zuletzt geändert von AKießling am 29. Mai 2019, 12:16, insgesamt 1-mal geändert.

Benutzeravatar
Rumpelstilzchen
Beiträge: 36
Registriert: 25. Jan 2018, 16:15
Kontaktdaten:

Re: Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von Rumpelstilzchen » 29. Mai 2019, 12:13

Super :D,

vielleicht fehlen auch noch Treiber für die Storage/Festplatte in der WinPE-Bootkonfiguration?
Heute backe ich morgen braue ich: Fehler könnten sich einschleichen und die Aussagen sind zu überprüfen - ich übernehme keine Verantwortung für das geschriebene Wort

AKießling
Beiträge: 22
Registriert: 13. Feb 2018, 12:20
Kontaktdaten:

Re: Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von AKießling » 29. Mai 2019, 12:18

Das mit den Storage/Festplatten-Treibern in der WinPE-Bootkonfiguration habe ich bereits vorletzte Woche durchgeführt, da unsere Optiplex7060 anfangs über WinPE auch nicht ordnungsgemäß durchgelaufen sind, weil eben diese Treiber nicht aktuell waren.

Ich tippe eher auf einen anderen Fehler, was die UEFI-Settings der Optiplex7060-Geräte angeht, die unser US-Kollege nicht ordnungsgemäß durchgeführt hat.

Update / Lösung :

Das Problem bei uns konnte behoben werden, nachdem unser US-Kollegen diverse UEFI / BIOS-Einstellungen angepasst hat.
Jetzt werden die Optiplex7060-Geräte fehlerfrei installiert.

André Schüttel
Beiträge: 211
Registriert: 08. Jul 2009, 13:37
Wohnort: Leipzig
Kontaktdaten:

Re: [Solved] Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von André Schüttel » 09. Sep 2019, 14:44

Guten Tag,

ich muss mich mal ranhängen.

Wie ist es möglich mit WinPE zwei Festplatten, so wie mit EPE, umzugehen?

Ich möchte Platte 1 als System und Platte 2 als Daten und Profil erstellen.
EMPIRUM v18.0.2; WSM 8.1.1; SQL Server Std 2014

MaMa82
Beiträge: 297
Registriert: 10. Jun 2011, 13:56
Kontaktdaten:

Re: [Solved] Windows 10 (1803) OS-Deployment (WinPE) - Windows could not apply the unattend answer file‘s...

Beitrag von MaMa82 » 09. Sep 2019, 14:55

Hallo André,

aktuell im Produkt so noch nicht implementiert.
Sollte ggfs. über eine eigens dafür angepasste XML funktionieren.
Habe ich aber ehrlich gesagt selber noch nicht getestet.

Ggfs. Feature-Request im ideas Portal voten, sofern vorhanden, oder erstellen.
Grüße MaMa82


PS: EDV steht nicht für "Elektronische Datenverarbeitung", sondern vielmehr für "ENDE DER VERNUNFT"! :roll:

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste