Seite 1 von 1

WinPE setzt Boot Reihenfolge nicht richtig

Verfasst: 04. Sep 2019, 09:44
von DotzlerJ
Hallo,

seitdem wir unsere PCs über das neue WinPE installieren, ist nach der Installation die UEFI Boot Reihenfolge wie folgt:
1. Onboard NIC (IPv4) 2. Onboard NIC (IPv6) 3. Windows Boot Manager

Die Installation über EPE hat die Boot Reihenfolge immer richtig gestellt, sodass der Boot Manager auf Position 1 steht.

Mir ist nun aufgefallen das im Matrix42 PreOS Package WindowsInstallation 4.13 Powershell Skript ganz bewusst der Boot Manager auf letzte Position gestellt wird (/addlast). Hat das einen besonderen Grund? Wir möchten diesen natürlich gerne an erster Stelle haben da die User sonst jeden Tag erst die beiden NIC boots abwarten müssen....

Hier der Ausschnitt aus der Powershell von M42:

Code: Alles auswählen

function StartBCDEdit()
{
    Write-Host "Starting StartBCDEdit";
    
    $argumentString = '/set {fwbootmgr} displayorder {bootmgr} /addlast';
    Write-Host "Using bcdedit $argumentString";

    $SetupProcess = Start-Process "bcdedit" -Argumentlist $argumentString -PassThru
    try
    {
        $SetupProcess | Wait-Process -Timeout 3600 -ErrorAction Stop
        Write-Host -Message 'BCDedit successfully completed within timeout.'
    }
    catch
    {
        $SetupProcess | Stop-Process -Force
        ExitWithCodeMessage 533 'BCDedit exceeded timeout.';
    }

    Write-Host "Finished BCDEdit";
}

Re: WinPE setzt Boot Reihenfolge nicht richtig

Verfasst: 04. Sep 2019, 13:46
von DotzlerJ
Anmerkung:
Eine Anpassung der Zeile zu "addfirst" bewirkt leider auch nichts. Der Windows Boot Manager steht weiterhin an letzter Stelle.

alt:
$argumentString = '/set {fwbootmgr} displayorder {bootmgr} /addlast';

neu:
$argumentString = '/set {fwbootmgr} displayorder {bootmgr} /addfirst';

Hat hier jemand schon die gleiche Erfahrung gemacht? Gerade eben nochmal mit EPE und den gleichen BIOS Settings neuinstalliert --> Boot Reihenfolge nach erfolgreichen OS Deployment ist richtig.

Re: WinPE setzt Boot Reihenfolge nicht richtig

Verfasst: 06. Sep 2019, 08:48
von DotzlerJ
Hallo,

habe nun eine Lösung von unseren Partner erhalten.

Falls jemand das selbe Problem bzw. die selbe Anpassung Wünscht muss wie folgt vorgegangen werden:

Anpassen der install.ps1 (\Empirum\Configurator\Packages\matrix42\OsPackages\WindowsInstallation\4.13\install.ps1)
im Abschnitt function StartBCDEdit()
wie folgt:
Ersetzen von
$argumentString = '/set {fwbootmgr} displayorder {bootmgr} /addlast';
mit
$argumentString = '/set {fwbootmgr} displayorder {bootmgr}';

Das gleiche dann auch in der EmpirumPEAgent.bat im WindowsInstallation-Ordner anpassen.

Re: WinPE setzt Boot Reihenfolge nicht richtig

Verfasst: 17. Okt 2019, 16:24
von clippa
Danke für den Hinweis auf die EmpirumPEAgent.bat

Bisher haben wir nur die .ps1 angepasst aber in der WindowsInstallation 4.14 war das /addlast in der .ps1 nicht mehr vorhanden und dafür in der .bat