Probleme mit Software-Installation während OS-Installation

Moderator: jknoth

Antworten
Benutzeravatar
lennu
Beiträge: 581
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Probleme mit Software-Installation während OS-Installation

Beitrag von lennu » 16. Jul 2007, 15:07

Hallo,

ich möchte eine aktuellere Version des Windows Installers bei der Installation von Windows 2000 Professional installieren (mittels EPE). Ich habe einen KHC-Eintrag zu Windows 98 gefunden und mich mehr oder minder daran gehalten:

Ich habe unter "Empinst\Wizard\Scripts2\Custom" die Datei Copy_Win2000.eis erstellt:

Code: Alles auswählen

;§§§ This Script is merged at the end of Win2000.eis.
;§§§ It is processed after removing the floppy disk.
;§§§ Example: (see also at the beginning of the example in... \Scripts\Custom\Begin_Win2000.eis)

;IF "%HWDIR%"<>"" THEN
;	COPY Z:\drv\%OS%\otherHW c:\install\system\$OEM$\$1\%HWDIR%\
;	WAIT 1
;ENDIF

;§§§ Please do not remove this line! Modifications only below this line!

; Modifies AUTOLOG.INF script -> MSI-installation
; MSI_31.EXE must be copied to EmpInst/DRV/WIN2000/$OEM$
	WRITEINI %O%autolog.inf Options MSIINST "MSIINST, COPYALWAYS"
	TEXTOUT  %O%autolog.inf [MSIINST]
	TEXTOUT  %O%autolog.inf #SET:MSI
	TEXTOUT  %O%autolog.inf [SET:MSI]
	TEXTOUT  %O%autolog.inf call start /wait c:\Install\i386\$oem$\MSI_31.exe /passive /norestart

Dazu habe ich die Datei MSI_31.exe unter Empinst\DRV\Win2000\$oem$ abgelegt.

Während der Installation des OS bekomme ich nun die Meldung, dass der Befehl "call start /wait c:\Install\i386\$oem$\MSI_31.exe /passive /norestart" nicht ausgeführt werden kann (Fehler 2).

Wenn ich mich richtig erinnere, heisst Fehler 2, dass die Datei nicht existiert - wenn ich den Rechner aber mit einem anderen OS boote, finde ich die Datei aber in dem angegebenen Pfad.

Was mache ich falsch???

Danke für jeden Hinweis,
Lennart

(Umgebung: 2005 PFP R2 inkl. aller Hotfixes)
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

Benutzeravatar
tlangner
Beiträge: 126
Registriert: 10. Jan 2005, 19:59
Wohnort: Lich, Hessen
Kontaktdaten:

Beitrag von tlangner » 16. Jul 2007, 15:36

Hallo,

warum so umständlich über die Eis-Customs?
Es gibt einen sehr guten KHC Eintrag wie bei dem OS-Setup die verschiedensten Patche integriert werden können, sogenanntes Slipstream aber auf Microsoft weise, kein nLite. Nach der Installation sind die eingespielten Patche auch aufgeführt und somit immer nachvollziehbar. Habe ich in unserer Umgebung integriert und läuft prima.

Wenn der KHC Artikel nicht gefunden wird einfach nochmal melden.

Gruß
Thomas Langner

ovd
Beiträge: 9
Registriert: 21. Jul 2008, 09:49
Kontaktdaten:

Beitrag von ovd » 21. Jul 2008, 11:12

Für diesen KHC Eintrag würde ich mich auch interessieren.

Grüsse
RK

philipp.kiessler
Beiträge: 248
Registriert: 05. Feb 2007, 11:42
Kontaktdaten:

Beitrag von philipp.kiessler » 20. Aug 2008, 14:45

Mich würde, auch wenn es schon etwas her ist, auch interessieren, wie man den Fehler beheben kann!

Wie in "Service Pack 3 als $OEM$-Installation" beschrieben, würde ich das benötigen, um das SP3 als Nicht-Slipstream (Patchproblemen wegen) während der OS-Installation auf die Kiste zu bringen. Ich weiß, kuriose Ideen, die ich da habe!

Ein kleines Update:
Sobald ich den Aufruf ohne "start \wait" rein schreibe, klappt es ohne Probleme.
Philipp Kießler

Antworten

Zurück zu „OS Installer“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 14 Gäste