Seite 1 von 1

Inventory ReadXML failed V 16.0.1

Verfasst: 05. Sep 2016, 13:46
von vkleppa
Server: W2008 R2 (x64)
Empirum 16.0.2.3955
DB-Version 7.02

Seit dem Automatischen Serverneustart wegen Windows-Update am 10.08.2016 landen alle Inventory-Daten
im \EmpInv\Error-Verzeichnis.

Das habe ich Urlaubsbedingt leider erst jetzt bemerkt.

DebugViev meldet folgendes:

[5456] Reading XML file '\\UKSPA-S7\EmpInv$\UK-SPA.UKSPA-031269_2016-09-05 12-35-41.XML.GZ'
[5456] \\UKSPA-S7\EmpInv$\UK-SPA.UKSPA-031269_2016-09-05 12-35-41.XML.GZ: Start tag expected, '<' not found
[5456] ReadXML failed!
[5456] MATRIXINVENTORY File moved to error directory: UK-SPA.UKSPA-031269_2016-09-05 12-35-41.XML.GZ


Die XML-Dateien beginnen wie folgt

<?xml version="1.0" encoding="ISO-8859-1"?>
<InventoryData Version="16.0" DBVersion="7.02" OSType="1" DLLVersion="16.0.2.3955" FileType="FULL" DetectionType="InventoryAgent" CodePage="1252">

Ich vermute, die Inventory-Files sind OK, weil der Fehler auch bei offline erstellten Inventory-Dateien, die schon mal erfolgreich verarbeitet wurden, jetzt permanent auftritt.

Da am 10.08. der Activation- und der WakeOnLan-Dienst wegen fehlender Dateien in \windows\syswow64\ nicht starteten,
vermute ich, dass für das Inventory nötige Programmdateien ebenfalls fehlen.
Vermutung: Als Folge werden die .gz-Dateien nicht geöffnet oder die enthaltenen .xml-Dateien nicht gelesen werden können.

Hat jemand eine Idee, welche Dateien fehlen könnten?
Oder liegt das Problem doch woanders?

Danke für jeden Tip!

Volkmar Kleppa