Seite 1 von 1

Device Discovery per SNMP erkennt eigene Gerätetypen nicht

Verfasst: 02. Jan 2019, 11:55
von fatlouis
Hallo zusammen und frohes neues.

Unser Device Discovery entdeckt munter alle Geräte in den eingestellten Netzwerken.
Darunter sind auch Drucker die mit den von Matrix voreingestellten OIDs zu Printern nicht oder nicht vollständig übereinstimmen.
Dafür haben wir dann eigene Gerätetypen definiert.

Leider glaube ich, dass der Device Discovery Dienst diese Typen samt definierten Mappings einfach ignoriert?

Mappings die beiden 4 voreingestellten Typen angelegt werden greifen alle.
Kann es sein das Empirum hier die von uns erstellten Gerätetypen beim Discovery nicht einordnen kann und deswegen immer auf UNKNOWN springt?

Anbei mal die Regel für eine unserer eigenen Gerätetypen
Beispiel.png
Beispiel SNMP Regel zu eigenem Gerätetyp
(26.15 KiB) 81-mal heruntergeladen
In den dd.*.xml Dateien ist für die entsprechenden Typen immer diese Zeile zu finden: <Column Name="DType">Unknown</Column>

Muss ich da noch irgendwo was neustarten oder umkonfigurieren? Ich weiß leider nicht mehr weiter....



Vielen Dank schon mal im Voraus

Re: Device Discovery per SNMP erkennt eigene Gerätetypen nicht

Verfasst: 02. Jan 2019, 15:09
von MaMa82
Hallo und frohes Neues! :mrgreen:

Da geht das Neue Jahr ja gleich gut los.

Bist Du Dir sicher, dass das Custom SNMP-mapping bzw. Filterkriterium so passt?
Ich würde zum einen den ODER Operator entfernen und zum anderen wäre nach den Konfigurationsänderungen der DD-Dienst zu reinstallieren, damit das Mapping greift.´

Zudem solltest Du bei den Unknown devices kontrollieren, ob die gewünschten OIDs überhaupt durch den DD ausgelesen werden. Ich musste hier bereits feststellen, dass diese nicht vollumfänglich ausgelesen werden können. (vor allem wenn die OID-Struktur sehr tief verschachtelt bzw. geräte-/herstellerspezifisch ist)

Re: Device Discovery per SNMP erkennt eigene Gerätetypen nicht

Verfasst: 03. Jan 2019, 08:18
von fatlouis
Moin MaMa82,

erstmal danke für die Ausführliche Antwort.

Bei den Custom Filtern bin ich mir ziemlich sicher, dass die so in Ordnung sind.
Zumal ich testweise schon 2 Varianten als Gerätetypen getestet hatte wenn ich mir mal unsicher war :roll:

Den ODER Operator kann ich nur durch den UND Operator ersetzen, ist es das was du meinst?
DD-Dienst reinstallieren! Das wirds sein. Das hab ich bisher nicht gemacht...

Extra mibs für den DD hab ich eingelesen. Und 08/15 Geräte mit OIDs vom Mars haben wir Gott sei Dank nicht ;)

Ich teste das mit dem reinstallieren gleich mal aus und melde mich wieder.

Danke noch mal
MFG

fatlouis

Re: Device Discovery per SNMP erkennt eigene Gerätetypen nicht

Verfasst: 03. Jan 2019, 12:57
von fatlouis
wie immer... leute krank, keiner da... Meine Rückmeldung zu dem Thema wird sich leider noch ein paar Tage hinziehen.

Trotzdem nochmals danke für den Hinweis

Re: Device Discovery per SNMP erkennt eigene Gerätetypen nicht

Verfasst: 08. Jan 2019, 13:38
von fatlouis
Leider greift das bei mir immer noch nicht.
Anbei mal das Mapping und ein Beispiel Gerät.

Beim Mapping habe ich die Einträge auch schon alle einzeln durchgetestet...
Der Übersicht halber habe ich sie gerade alle 4 als ODER Werte drin.

Bei jeder einzelnen Konfig hab ich den DD Dienst reinstalliert.

Für Ideen, Vorschläge oder Kritik bin ich sehr dankbar :)

MFG

fatlouis

EDIT: Typo beim zusammenführen der 4 möglichen OIDs korrigiert (.1.3.6.1.4.1.6666 changed to 1.3.6.1.4.1.6666)