Dienste im DBUtil sind nicht da?!

Antworten
John Carmack
Beiträge: 53
Registriert: 11. Nov 2011, 15:12
Kontaktdaten:

Dienste im DBUtil sind nicht da?!

Beitrag von John Carmack » 25. Jun 2012, 14:06

Hallo Leute,

ich hab mal zum testen Empirum v14.2 + Patch 1 auf einen Computer installiert.
Leider kann ich nachdem die DB Verbindung steht keine Dienste installieren... Warum?

http://s14.directupload.net/file/d/2932 ... 9x_jpg.htm

Auf der linken Seite auf der man die Dienste aussuchen und installieren kann erscheint keine Auswahl.

Danke für eure Hilfe! :-)

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 25. Jun 2012, 15:07

Das ist ein Bug. Lassen Sie folgendes SQL-Script gegen die EmpLocations-DB laufen:

-- Sets Service module amount

BEGIN
DECLARE @Option VARCHAR(40) = 'EMP_MODULES', @NewValue VARCHAR(1) = '7', @OldValue VARCHAR(255)
SELECT @OldValue = EmpValue FROM Options WHERE EmpOption = @Option
IF @OldValue IS NULL
INSERT INTO Options(EmpOption, EmpValue, UserID) VALUES (@Option, @NewValue, 0)
ELSE
UPDATE Options SET EmpValue = @NewValue, UserID = 0 WHERE EmpOption = @Option
END;
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

John Carmack
Beiträge: 53
Registriert: 11. Nov 2011, 15:12
Kontaktdaten:

Re: Dienste im DBUtil sind nicht da?!

Beitrag von John Carmack » 25. Jun 2012, 17:08

hmmm... irgendwie will das noch nicht so richtig...
Bin leider kein SQL Experte...

http://s1.directupload.net/file/d/2932/cgt5ptoq_jpg.htm

Als fehler kommt raus:

Msg 139, Level 15, State 1, Line 0
Cannot assign a default value to a local variable.
Msg 137, Level 15, State 1, Line 3
Must declare the scalar variable "@OldValue".
Msg 137, Level 15, State 2, Line 4
Must declare the scalar variable "@OldValue".
Msg 137, Level 15, State 2, Line 5
Must declare the scalar variable "@Option".
Msg 137, Level 15, State 2, Line 7
Must declare the scalar variable "@NewValue".

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 25. Jun 2012, 18:10

Laden Sie die SQL-Datei mal hier runter:
https://matrix42.box.com/s/83ff4c946fb0015e76da
Dann via DBUtil auf EmpLocations ausführen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

John Carmack
Beiträge: 53
Registriert: 11. Nov 2011, 15:12
Kontaktdaten:

Re: Dienste im DBUtil sind nicht da?!

Beitrag von John Carmack » 26. Jun 2012, 10:02

geht leider immer noch nicht... :(

DBUtil -> Actions -> Execute SQL Scripts... -> EmpLocations -> ResetServiceModules.sql

Mache ich etwas falsch?

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 26. Jun 2012, 10:13

Nein, das ist richtig so.
Dann sollten Sie eine Störung bei unserem Support eröffnen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

John Carmack
Beiträge: 53
Registriert: 11. Nov 2011, 15:12
Kontaktdaten:

Re: Dienste im DBUtil sind nicht da?!

Beitrag von John Carmack » 26. Jun 2012, 10:38

ich installiere erst einmal alles neu...

Kann es sein das man eine neue SQL Instanz auf dem SQL Server installieren muss?

Hatte eine "alte" Instanz benutzt auf der die Empirum v14.1 DB installiert war.

Da ich etwas ausprobieren wollte habe ich kein Update auf 14.2 gemacht sondern v14.1 deinstalliert und 14.2 neu installiert.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 26. Jun 2012, 10:49

Nein, das ist egal.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 28. Jun 2012, 15:43

Habe gerade vom Support eine aktualisierte Version des SQL Scripts erhalten.
Die ursprüngliche Version machte Probleme mit SQL 2005.
Unter dem selben Link (s.u.) ist nun die neue Version verfügbar für SQL 2005 und 2008.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

madmaki
Beiträge: 34
Registriert: 24. Aug 2008, 07:50
Wohnort: Berlin
Kontaktdaten:

Re: Dienste im DBUtil sind nicht da?!

Beitrag von madmaki » 26. Apr 2013, 20:34

Dieser Fehler tritt immernoch auf, wenn man einen Empirumserver v14.2 komplett neu auflegt und anschließend alle Patches (1 bis 5) einspielt !!
Das hat mich heute fast in den Wahnsinn getrieben
:evil:

Irgendwann habe ich dann nach der gefühlten 100sten Neuinstallation erst DBUTIL gestartet, die Datenbank erstellt etc. und danach die Patches eingespielt.

Der Thread hier ist von JUNI 2012, ABER der Fehler hat sich bis Patch 5 von 04/2013 gehalten !!

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 27. Apr 2013, 10:07

Wahrscheinlich gehen wir davon aus dass eh kaum noch Neuinstallationen von Empirum 14.x gemacht werden weil es ja schon seit fast einem halben Jahr PVWM 2013 aka Empirum 15.0 gibt ;-)
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

madmaki
Beiträge: 34
Registriert: 24. Aug 2008, 07:50
Wohnort: Berlin
Kontaktdaten:

Re: Dienste im DBUtil sind nicht da?!

Beitrag von madmaki » 27. Apr 2013, 13:27

Sorry, aber das finde ich ziemlich schwach !!
Den Fehler hätte man leicht mit dem Patch 5 beheben können, der ja vom 17.04.2013 ist !!

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Dienste im DBUtil sind nicht da?!

Beitrag von Hendrik_Ambrosius » 28. Apr 2013, 00:06

Klar, hätte man vielleicht machen können.

Aber das hat bestimmt seinen Grund wieso das nicht gemacht wurde - vielleicht weil es dringendere Sachen gab als die Handvoll Neuinstallationen die mit v14 noch gemacht werden eleganter zu machen... aber das ist nur eine Vermutung, habe in diesen Bereich keinen Einblick und keinen Einfluß.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Antworten

Zurück zu „DBUtil“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast