Sync-Job gelöscht, Verzeichnisse werden weiterhin neu angele

Antworten
marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Sync-Job gelöscht, Verzeichnisse werden weiterhin neu angele

Beitrag von marKo » 21. Mär 2011, 13:56

Hallo,
ich habe in unserer Empirum V12R2P3 Umgebung einen neuen Sync-Job zu einem SubDepot-Server angelegt. Ich habe mich dort aber im Pfad verschrieben und habe den Pfad im nach hinein geändert aber die falsche Ordnerstruktur wird auf dem Master-Server und auf dem SubDepot immer wieder neu angelegt. Zum Schluss habe ich den Sync-Job dann gelöscht aber die falsche Ordnerstruktur wir weiterhin immer wieder neu angelegt… Kann mir jemand sagen, wie ich das abgestellt kriege?

Vielen Dank

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von Hendrik_Ambrosius » 21. Mär 2011, 21:48

Verweist die EmpirumServer-Variable des Depotserver auf sich selbst oder auf das übergeordnete Depot?
Wenn er auch sich selbst verweist bekommt er wohlmöglich nicht die neuen Variablenwerte mit.
Entweder die Variable umsetzen oder die Dateien per Filecopy aktualisieren um diese deadlock-Situation zu lösen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von marKo » 28. Mär 2011, 11:14

Sorry, dass ich jetzt erst antworte. Ich war die letzte Woche krank.
Vielen Dank erstmal aber für die Antwort.
Die %EmpirumServer% Variable des Depotservers verweist auf den übergeordneten Masterserver, nicht auf sich selbst.
Was mich an der ganzen Sache wundert ist, ich habe den Sync-Job gelöscht und trotzdem scheint der immer noch aktiv zu sein. Die Falsche Verzeichnisstuktur wird immer wieder neu angelegt, ob wohl ich sie von beiden Servern lösche und außerdem kann ich keinen neuen Sync-Job anlegen, der den gleichen Namen hat, wie der, den ich gelöscht habe. Da sagt er mit immer, diesen Sync-Job gibt es schon.... Was hab ich falsch gemacht?

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von Hendrik_Ambrosius » 28. Mär 2011, 19:22

Gelöscht oder deinstalliert? Das macht einen Unterschied!
Dann legen Sie doch einfach einen neuen Sync-Job mit neuem Namen an.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von marKo » 29. Mär 2011, 08:43

Gelöscht. Und wahrscheinlich ist genau das das Problem.
Ich habe einen neuen Sync-Job angelegt, der die richtige Verzeichnisstruktur enthält und der funktioniert auch.
Aber die "falschen" Verzeichnisse aus dem gelöschten Sync-Job werden immer wieder auf beiden Servern neu angelegt. Kann es sein, dass dort noch in der SQL-Datenbank irgendwas drin steht, was Empirum immer wieder ausführt und die Verzeichnisse neu anlegt? Ich habe auch schon versucht, einen neuen Sync-Job anzulegen, der den gleichen Namen hat, wie der gelöschte Sync-Job. Aber da kriege ich von Empirum immer die Meldung, dass es schon einen Sync-Job gibt mit diesem Namen...

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von Hendrik_Ambrosius » 29. Mär 2011, 20:37

Tja, dann ist da wohl wirklich noch etwas in den DB drin.
Wenn ich mich recht erinnere werden die Sync Templates auch wie Pakete abgelegt.
Also ggf. dort direkt via SQL-Editor löschen um das mal glattzuziehen.
Eventuell ist es aber auch nur in der Registry des jeweiligen Depotservers drin.
Durchsuchen Sie mal die gesamte Registry nach dem Namen des Syncjobs, löschen Sie dann den Zweig und gucken sie ob er wiederkommt.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von marKo » 30. Mär 2011, 11:12

Ich habe das mal geprüft und die Sync-Jobs werden auch wie Pakete abgelegt. Auf dem Depotserver war auch dieser Job noch in der Registry vorhanden aber es gab keine Setup.inf mehr unter dem Empirum-Agenten-Verzeichnis unter C:\WINDOWS\EmpirumAgent\Packages\matrix42\SyncJobs. Den Eintrag in der Registry habe ich dann gelöscht, die falschen Verzeichnisse auf beiden Servern dann auch gelöscht und es dauerte nicht lange und die Verzeichnisse waren wieder da :-(
In der SQL-DB haben wir auch geguckt und in der Tabelle dbo.SyncStatus steht dieser Job noch drin. Allerdings steht da nur die falsche Verzeichnisstruktur drin mit einer ID. am Anfang Jetzt weiß ich nicht, wohin diese ID zeigt bzw. was ich aus der SQL-DB löschen muss, damit das nicht mehr auftaucht. Können Sie mir sagen, was genau ich da aus der SQL-DB löschen muss oder vielleicht gibt es ja von Empirum eine SQL-Abfrage die mir da weiter helfen kann... Ich will nicht einfach in der SQL-DB irgendwas löschen und habe dann hinterher eine korrupte Datenbank...
Gibt es von Matrix42 eine Beschreibung, wie genau die Arbeitsweise dieser Sync-Jobs ist? Wenn ich genau verstehe, wie das mit diesen Sync-Jobs funktioniert, wer das von wo aus antriggert, dann kann ich da vielleicht auch genauer nach schaun.
Vielen Dank auf jeden Fall erstmal für Ihre Hilfe

marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von marKo » 30. Mär 2011, 11:53

NACHTRAG: Der Registry-Eintrag für den Sync-Job ist auf dem Depot-Server wieder da. Im Rollout-Koordinator steht dieser Sync-Job auf "Reinstall"... Irgendwo ist dieser Sync-Job dem Depot-Server noch zugewiesen. Der Fehler war ganz klar, ich hätte den Sync-Job nicht einfach löschen dürfen, sondern Deinstallieren müssen. Aber das ist nun zu spät... :-(

marKo
Beiträge: 58
Registriert: 06. Mai 2009, 12:11
Kontaktdaten:

Re: Sync-Job gelöscht, Verzeichnisse werden weiterhin neu an

Beitrag von marKo » 30. Mär 2011, 13:28

Ich habs gefunden.
Die Sync-Jobs liegen auf dem Depot-Server unter
C:\Program Files\Empirum\Empsync\...
dort liegt auch der Sync-Monitor und über diesen kann man den fehlerhaften Sync-Job deaktivieren :-)

Antworten

Zurück zu „Sync“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste