Synch zu Subdepots

Antworten
Tigris
Beiträge: 25
Registriert: 20. Apr 2009, 16:36
Kontaktdaten:

Synch zu Subdepots

Beitrag von Tigris » 27. Mai 2009, 18:13

Hi Leute,

wir stehen noch ziemlich am Anfang mit unserem Empirum System und unserem Wissen^^

Frage: Wie kann ich die Synchronisierung zwischen Empirum Master Server und den Subdepots zeitlich einschränken?
z.Z läuft die Synchronisierung alle 15 Minuten glaub ich. Das belastet die sowieso schon langsamen Leitungen zu den Depots unnötig.
Das lässt dich doch sicherlich in den Griff bekommen.

Danke schonmal ;)

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 27. Mai 2009, 18:36

Das kann man in den dem Depotserver zugewiesenen SyncTemplates einstellen. Einfach doppelt drauf klicken und bis zum Zeitplan weiter.
Dann noch mal neu das SyncTemplate via Reinstallation verteilen.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Tigris
Beiträge: 25
Registriert: 20. Apr 2009, 16:36
Kontaktdaten:

Beitrag von Tigris » 27. Mai 2009, 18:40

Hendrik_Ambrosius hat geschrieben:Das kann man in den dem Depotserver zugewiesenen SyncTemplates einstellen. Einfach doppelt drauf klicken und bis zum Zeitplan weiter.
Dann noch mal neu das SyncTemplate via Reinstallation verteilen.
Danke schonmal für die schnelle Antwort. Werde das testen.

Benutzeravatar
Trickser
Beiträge: 560
Registriert: 11. Okt 2006, 10:51
Wohnort: Jülich
Kontaktdaten:

Beitrag von Trickser » 27. Mai 2009, 21:31

Hi,

je nachdem wie Eure Leitungen managebar sind, macht es auch Sinn die "fetten" Jobs für die Pakete und EmpInst über die RSync Jobs laufen zu lassen. Hier kann man relativ leicht mit Port-Priorisierung arbeiten und dem RSync Port eine niedrige Prio zu geben, bei SMB würde man auch den 'normalen' Traffic beschneiden. Ausserdem kann man bei RSync in den Sync-Jobs auch eine maximale prozentuale Auslastung bzw. Mindestbandbreite vorgeben.

EmpInst muss eigentlich nur laufen, wenn es Änderungen an der Hardware oder am OS gibt. Nach der Integrationsphase dürfte 1* die Woche am Wochenende reichen.

Pakete würde ich schon mind. 1* täglich, besser 2* laufen lassen, da man doch öfter mal was ändert. Muss ja nicht in der Rush hour sein.

Die dünnen jobs wie Values, OS.ini und EmpInv würde ich aber möglichst spontan einstellen, zumindest über Tag, da ansonsten das System zu träge wahrgenommen wird. Möglichst alle 5 min. sofern die Leitung das hergibt, Inventory vieleicht alle 15 min. oder halbe Stunde.


Gruß,

Micha.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7414
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 27. Mai 2009, 22:21

...und wo wir schon mal am Optimieren sind: Die QuickSync-Jobs nicht vergessen! Damit tendiert der traffic für os.ini, ddc, usw. gegen null.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

markus_keup
Beiträge: 92
Registriert: 30. Nov 2006, 13:29
Kontaktdaten:

Rsync funktioniert nicht richtig

Beitrag von markus_keup » 22. Jun 2009, 16:16

Hallo Hallo,

beim ausprobieren des RSYNC-Synctemplates zur Synchranisastion meines Master-Servers mit dem Depot, bekommt ich im Sync_monitor folgenden Fehler:

(Dazu zu sagen ist, daß ich die Variablen SYNC-SERVER usw. nach Anleitung angepasst und eingestellt habe)


RSubdepot_Empinst:22/06/2009 15:42:28 Fehler: Ziel-Zugriff nicht möglich! FEHLER
RSubdepot_Empinst:22/06/2009 15:42:28 rsync.exe rsync://EmpAgent@emp002k8/empinst cygdrive/e/empirum/empinst --recursive --delete --compress --stats --progress --times --partial-dir=PARTIALDIR --send-buffer=960 --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Pp][Xx][Ee][Ss][Pp][Yy]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Ii][Mm][Aa][Gg][Ee]/[Pp][Xx][Ee][Ii][Mm][Aa][Gg][Ee][Ss]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Oo][Ss]/ --exclude=[Cc][Oo][Nn][Vv][Ee][Rr][Tt].[Ii][Nn][Ii] The filename, directory name, or volume label syntax is incorrect. FEHLER
RSubdepot_Empinst:22/06/2009 15:42:25 rsync error: error in file IO (code 11) at main.c(558) [receiver=2.6.9] EXTERN
RSubdepot_Empinst:22/06/2009 15:42:25 rsync: mkdir "/cygdrive/c/WINDOWS/system32/cygdrive/e/empirum/empinst" failed: No such file or directory (2) EXTERN
RSubdepot_Empinst:22/06/2009 15:42:25 927 files to consider EXTERN
RSubdepot_Empinst:22/06/2009 15:42:25 900 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:24 800 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:22 700 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:21 600 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:20 500 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:19 400 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:19 300 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:17 200 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:15 100 files... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:14 transfer options: send-buffer=960, client send-window=0, recv-window=0, server send-window=0, recv-window=0, iotimeout=0, deny-dup-client=0, md5=0 EXTERN
RSubdepot_Empinst:22/06/2009 15:42:14 transfer options: ack=0, ackkb=0, eta=0, throttle=0, invert=0, bwlimit=0, byte-bwlimit=0, bwlower=0, bwdelta=0 EXTERN
RSubdepot_Empinst:22/06/2009 15:42:14 cmdline: rsync .exe --config=/etc/rsyncd.conf --daemon --no-detach EXTERN
RSubdepot_Empinst:22/06/2009 15:42:14 receiving file list ... EXTERN
RSubdepot_Empinst:22/06/2009 15:42:14 cmdline : rsync rsync://EmpAgent@emp002k8/empinst cygdrive/e/empirum/empinst --recursive --delete --compress --stats --progress --times --partial-dir=PARTIALDIR --send-buffer=960 --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Pp][Xx][Ee][Ss][Pp][Yy]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Ii][Mm][Aa][Gg][Ee]/[Pp][Xx][Ee][Ii][Mm][Aa][Gg][Ee][Ss]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Oo][Ss]/ --exclude=[Cc][Oo][Nn][Vv][Ee][Rr][Tt].[Ii][Nn][Ii] EXTERN
RSubdepot_Empinst:22/06/2009 15:42:12 EXTERN
RSubdepot_Empinst:22/06/2009 15:42:11 Password: *************** EXTERN
RSubdepot_Empinst:22/06/2009 15:42:08 rsync.exe rsync://EmpAgent@emp002k8/empinst cygdrive/e/empirum/empinst --recursive --delete --compress --stats --progress --times --partial-dir=PARTIALDIR --send-buffer=960 --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Pp][Xx][Ee][Ss][Pp][Yy]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Ii][Mm][Aa][Gg][Ee]/[Pp][Xx][Ee][Ii][Mm][Aa][Gg][Ee][Ss]/ --exclude=/[Ww][Ii][Zz][Aa][Rr][Dd]/[Oo][Ss]/ --exclude=[Cc][Oo][Nn][Vv][Ee][Rr][Tt].[Ii][Nn][Ii] GESTARTET
RSubdepot_Empinst:22/06/2009 15:42:08 Ziel verbunden. MELDUNG
RSubdepot_Empinst:22/06/2009 15:42:08 Quelle verbunden. MELDUNG
RSubdepot_Empinst:22/06/2009 15:42:08 Aufgabe gestartet. MELDUNG


Hat jemand einen Tip warum er folgendes Versucht:

RSubdepot_Empinst:22/06/2009 15:42:25 rsync: mkdir "/cygdrive/c/WINDOWS/system32/cygdrive/e/empirum/empinst" failed: No such file or directory (2) EXTERN

ich meine... der Pfad sollte doch eigentlich /cygdrive/e/empirum/empinst sein, denn der ist angegeben und besteht sogar...

Wo das zusätzliche: /cygdrive/c/WINDOWS/system32/ herkommt weiß ich nicht...


Viele Grüße,

Markus

Antworten

Zurück zu „Sync“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast