cmd-Aufruf in Paket funktioniert nicht korrekt

Antworten
StadtBacknang
Beiträge: 6
Registriert: 28. Okt 2008, 15:40
Wohnort: Backnang
Kontaktdaten:

cmd-Aufruf in Paket funktioniert nicht korrekt

Beitrag von StadtBacknang » 16. Apr 2021, 12:39

Hallo,
wir müssen für Microsoft Surface Geräte manuelle Treiber- und Biosupdates durchführen. Der WSUS verteilt hier teilweise falsche Treiber. Wir hatten hier schon mehrfach Probleme mit Audiotreibern und der Kamera.

Damit auch die Bios-Updates durchgeführt werden können muss Bitlocker angehalten werden.

Hierfür gibt es den Befehl „Manage-bde –Protectors –Disable C: -RebootCount 0“, der in einer administrativen cmd ausgeführt werden muss. Manuell funktioniert es.

Die Surface-Updates gibt es als MSI-Paket und den cmd-Befehl habe ich entsprechend vorangestellt. Das ganze sieht dann so aus:

[InstallMSI]
AddMeter -1
Call cmd /c Manage-bde –Protectors –Disable C: -RebootCount 0
Call MsiExec /I "%SRC%\SurfacePro7_Win10_18362_20.122.27379.0.msi" REBOOT=REALLYSUPPRESS ARPSYSTEMCOMPONENT=1 /qr /Li "%MSILogFile%"

Leider funktioniert der Aufruf nicht. Wenn man /c durch /k ersetzt erhält man diese Information:
bde-Fehlermeldung.PNG
(54.51 KiB) 6-mal heruntergeladen
Ich habe diesen Aufruf nicht zum laufen bekommen.

Eine weitere Idee war dann, den Befehl über ein batch-file laufen zu lassen. Hier tritt derselbe Fehler auf, wenn man das File im Admin-Kontext laufen lässt.
Kennt jemand dieses Verhalten? Ist überhaupt die Syntax für empirum korrekt, bzw. die Position des Aufrufs im Paket?

Vielen Dank schon im Vorraus und ein schönes Wochenende.
T. Kieninger

Benutzeravatar
Frank Dethlefsen
Beiträge: 457
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Re: cmd-Aufruf in Paket funktioniert nicht korrekt

Beitrag von Frank Dethlefsen » 19. Apr 2021, 08:38

Moin!

Die Manage-bde.exe gibt es nur unter C:\Windows\System32 und nicht unter C:\Windows\Syswow64.
Insofern muss die Platform-Option in der Setup.inf Platform=x64 bzw. Platform=* sein.
Wenn unter Windows x64 Platform=x86 oder garnichts steht, wird die Manage-bde.exe unter C:\Windows\Syswow64 gesucht und dann nicht gefunden. Den Befehl würde ich so in die Setup.inf eintragen:

Code: Alles auswählen

Callhidden %System%\Manage-bde.exe –Protectors –Disable C: -RebootCount 0
:roll:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 11 Gäste