Package Robot // McAfee

Antworten
nureinagent
Beiträge: 2
Registriert: 03. Mai 2019, 11:39
Kontaktdaten:

Package Robot // McAfee

Beitrag von nureinagent » 04. Mär 2020, 11:47

Hallo Zusammen,

eins vorweg ... ich bin ziemlicher Anfänger auf dem Gebiet des Paketierens, daher auch mein Versuch ein Paket mit hilfe des Package Robots zu erstellen.

Das Produkt was paketiert werden sollte war der McAfee Agent (5.6.2).
Das Softwarepaket habe ich mit dem Package Robot erstellt. Die Installation sowie die Deinstallation habe ich getestet und das funktionierte auch.

Code: Alles auswählen

[SetupInfo]
Author                  =XXX
CreationDate            =XX.XX.XXXX 
InventoryID             =
Description             = 
Method                  = Package Robot
Tested on               =
Dependencies            =
Command line options    =/S2
Last Change             =
Build                   =

[VarDefInfo]
; <Variable>, <Type: 0=Computer 1=User>, <Allow NULL values: 0=No 1=Yes>

[Setup]
Version=14.2
ShowCaption=1
BlockInput=0
Platform=x64

[Requirements]

[Application]
ProductName=Agent
DeveloperName=McAfee
Version=5.6.2
Revision=1
SetupName=%ProductName% %Version% %SetupWizard%
Text1="%ProductName% %Version%",         Arial,           30, , 2170F3, 4,    , LEFT BOLD ITALIC
Text2="%DeveloperName%",                 Arial,           24, , 2170F3, 4,    , LEFT BOLD ITALIC
Text8="%Company%",                       Arial,           18, , 2170F3, 4,  10, RIGHT BOLD ITALIC
Text9="%InstallationFor% %WindowsUser%", Arial,           16, , 2170F3, 4, -18, BOTTOM ITALIC LEFT
BackgroundColor=EFEFEF,000000
CopyDialogRect=0%, 0%, 100%, 100%, HCENTER VCENTER

; Register all installations in common registry key
UserKeyName=$Matrix42Packages$\%DeveloperName%\%ProductName%
MachineKeyName=$Matrix42Packages$\%DeveloperName%\%ProductName%\%Version%
UninstallKeyName=Matrix42 - %DeveloperName% %ProductName% %Version%
UninstallDisplayName=Matrix42 - %DeveloperName% %ProductName% %Version%
UninstallString=%ReinstallString% /U
ReinstallString="%CommonSetupDir%\Setup.exe" "%App%\%SetupInfDir%\Setup.inf"
;UninstallDisplayIcon="%ApplicationDir%\%SetupInfDir%\Setup.ico",0
UninstallOptions=NOREMOVE NOREPAIR NOMODIFY
ReinstallMode=1
SrcDir=..

; Matrix42 Scripts are copied in a common scripts directory
ApplicationDir=%CommonAppData%\$Matrix42Scripts$\%DeveloperName%\%ProductName%\%Version%

SetupInfDir=Install
DataDir=%Personal%
AskUninstallOld=1
ShellLinks=1
CommonShellLinks=1
CreateUnresolvableShellLinks=1
UseStringSection=Strings:09
UseSysStringSection=SysStrings:09
DateWarning=1
SizeWarning=0
Reboot=0
PreventExternalReboot=1
StartServicesOnReboot=0
CallTimeOut=3600
AbortAfterCallTimeOut=1
DisableCancelButton=1
ShowEndMessage=1
EndMessage=%EndMessageDesc%

[Strings:07]
Disk1=Installationsmedium 1
EndMessageDesc=Die Installation wurde erfolgreich abgeschlossen!
ErrorLogMessage=Die Installation/Deinstallation wurde mit einer Fehlermeldung abgebrochen!
InstallationFor=Installation für:
InstallerDesc=Dienstprogramm zum Installieren einzelner Komponenten.
InstallerName=Installationsprogramm
SetupWizard=Installations-Assistent
Uninstallation=deinstallieren
ErrorText=Package Robot Fehler
CallingText=beim Aufruf von

[Strings:09]
Disk1=Installation media 1
EndMessageDesc=Installation was completed successfully!
ErrorLogMessage=The installation/uninstallation aborted with an error message!
InstallationFor=Installation for:
InstallerDesc=Service program to install single components.
InstallerName=Setup program
SetupWizard=Installation Wizard
Uninstallation=Uninstallation
ErrorText=Package Robot Error
CallingText=launching

[SysStrings:07]
Users=Benutzer

[SysStrings:09]
Users=Users

[Environment]
CommonSetupDir=%CommonFilesDir%\Setup%SetupBits%
V_MachineValuesPath=\\%EmpirumServer%\Values$\MachineValues\%DomainName%
V_UserValuesPath=%HKLM,"Software\matrix42\Software Depot","HomeServer"%\Values$\UserValues\%UserDomain%

; Maschinenabhängige Variablen
; machine dependent variables
;VM_<Variable>=%%%V_MachineValuesPath%\%ComputerName%.ini,%ComputerName%,<Variable>%%

; Userabhängige Variablen
; user dependent variables
;VU_<Variable>=%%%V_UserValuesPath%\%WindowsUser%.ini,%WindowsUser%,<Variable>%%

; !!! Setzen der entsprechenden ReplaceEnv Befehle für die Variablen im Abschnitt [Product] nicht vergessen!!!
; !!! Don't forget to set the appropriate ReplaceEnv instructions for the variables in the section [Product]!!!

[Encryption]

[Disks]
1=%Disk1%

[Options]
Installer = %InstallerName%, COPYALWAYS, Installer, "%InstallerDesc%"
Product   = %ProductName%,   COPYALWAYS, Product,   "%ProductDesc%"

[Installer]
1:..\..\..\..\User\Setup.exe,          %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupDeu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupEnu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:%Temp%\Setup64.exe,                  %CommonSetupDir%\Setup.exe, OPTIONAL ALWAYS NOSIZEWARNING SETUP WINDOWS64,     0
1:..\..\..\..\User\Setup64.exe,        %CommonSetupDir%\Setup.exe, OPTIONAL ALWAYS NOSIZEWARNING SETUP WINDOWS64,     0
1:%SetupInfDir%\Setup.inf,                             , ALWAYS,                                             0
; 1:%SetupInfDir%\Setup.ico,                             , NORMAL,                                           0
; 1:%SetupInfDir%\Logo.bmp,                              , NORMAL,                                           0

[Product]
;ReplaceEnv <Variable>

#Set:Product, DONTDELETE
#Set:Deinstallation, DELETE
#Reg:OnUninstallProduct, DELETE
#Reg:Product
#Ini:Product
#Security:Product

[Set:Product]
AddMeter -1
If DoesRegKeyExist ("HKLM,SOFTWARE\%DeveloperName%\%ProductName%\%Version%\Setup,Date") == "1" | DoesRegKeyExist ("HKLM,SOFTWARE\WOW6432Node\HKLM,SOFTWARE\%DeveloperName%\%ProductName%\%Version%\Setup,Date") == "1" Then "Set:Repair" Else "Set:Installation" EndIf

[Set:Installation]
Call "%Src%\Source\FramePkg.exe" 
If %ErrorLevel% <> "0" Then "SET:InstallationError" EndIf

[Set:Repair]
If DoesFileExist ("%Src%\") == "0" Then "Set:Installation" EndIf
Call "%Src%\" 
If %ErrorLevel% <> "0" Then "Set:RepairError" EndIf

[Set:Deinstallation]
If "%Src%\Source\FramePkg.exe" <> "" Then "SET:Deinstallation2" EndIf

[Set:Deinstallation2]
If %ErrorLevel% <> "0" Then "SET:DeInstallationError" EndIf
-Call "%Src%\Source\FramePkg.exe" /forceuninstall
-AddMeter -1

[Reg:OnUninstallProduct]

[Reg:Product]

[Ini:Product]

[Security:Product]

[Shell:Product]

[Set:InstallationError]
ErrorLogMsg %ErrorText% %ErrorLevel% %CallingText% Source\FramePkg.exe
Abort

[Set:RepairError]
ErrorLogMsg %ErrorText% %ErrorLevel% %CallingText% 
Abort

[Set:DeInstallationError]
-Abort
-ErrorLogMsg %ErrorText% %ErrorLevel% %CallingText% Source\FramePkg.exe
Nun habe ich das Paket auf einen Bereich ausgerollt.
Anfänglich sah die Verteilung sehr gut aus. Die Zahl der Erfolgreichen Installation stieg an (Status grün).

Nach einem Tag war aber wieder alles dahin. Auf vielen Clients steht der Status plötzlich auf gelb (nicht installiert).
Der MachineKeyName ist auf den Clients, welche auf "nicht installiert" gesprungen sind, vorhanden.

Was kann ich wie prüfen um dem Problem auf die Spur zu kommen. Oder ist vllt. schon eine fehler in der Setup.inf ersichtlich?
Braucht ihr weitere Information um mir ggf. helfen zu können?

Vielen Dank im voraus.

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 9 Gäste