MS Project 2003 Icon wird nicht installiert

Antworten
3kom
Beiträge: 10
Registriert: 26. Apr 2005, 12:03
Kontaktdaten:

MS Project 2003 Icon wird nicht installiert

Beitrag von 3kom » 17. Jan 2006, 16:08

Hallo Leute,
ich habe folgendes Problem: MS Project 2003 MSI Packetiert eine MST Datei erzeugt mit ORK soweit so gut. Das Icon wird unter All User abgelegt.
Aus der Setup.inf wollen wir das Icon an eine andere Stelle kopieren was aber nicht funktioniert. Unter Shell:Product haben wir den entsprechenden Befehl plaziert dieser wird aber nicht ausgeführt so scheint es.
Auf unseren Empirum haben wir just PFP installiert kann es damit im zusammenhang stehen? Bis dahin funktionierte diese vorgehensweise bei anderen Packeten.

HeikoLeupolz
Beiträge: 128
Registriert: 14. Dez 2004, 13:37
Wohnort: Pfronten
Kontaktdaten:

Beitrag von HeikoLeupolz » 17. Jan 2006, 18:02

wie ist denn die Vorgehensweise? Unter Shell:Product wird ein neues Icon erstellt aber nicht kopiert!

Ich würde bei Project allerdings das Icon direkt mit dem ORK so erstellen lassen wie es benötigt wird.
Viele Grüße

Heiko Leupolz

3kom
Beiträge: 10
Registriert: 26. Apr 2005, 12:03
Kontaktdaten:

Beitrag von 3kom » 18. Jan 2006, 07:50

Ja ist korrekt unter Shell:Produckt wird ein neues Icon erstellt.
Hier ein Auszug aus unserem Office Packet:
[Shell:Product]
Microsoft Office\Microsoft Office Word 2003, %ProgramFilesDir%\microsoft office\office11\winword.exe, , , , , , ,

Hier werden die Icons korrekt erstellt, das gleiche habe ich im Project Packet versucht läuft aber nicht.

Der Unterschied zwischen den Packeten ist Office = Diff mit MST File; Project = MSI mit MST File.

Benutzeravatar
mniemann
Administrator
Administrator
Beiträge: 574
Registriert: 25. Nov 2005, 17:03
Wohnort: Mainz
Kontaktdaten:

Beitrag von mniemann » 18. Jan 2006, 10:18

Was verstehen Sie denn unter "Office = DIFF mit MST" ? Office wurde sicherlich nicht gedifft, oder?
Visit my Blog: "DiEW - Das inoffizielle Empirum Weblog" (http://www.diew.eu)

Martin Niemann
Manager Support (Service Management)

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of matrix42 AG or of the support team.

jbeimel
Moderator
Moderator
Beiträge: 642
Registriert: 15. Dez 2004, 09:16
Kontaktdaten:

Beitrag von jbeimel » 18. Jan 2006, 11:52

Wenn's als MSI Paket installiert wird, dann wird das Icon doch nicht von der Setup.exe sondern vom MSI selbst angelegt :?:
Wenn es aber aus der Setup.inf heraus kommt, dann mal unter [Application] den Wert bei CommonShellLinks=0 oder 1 überprüfen. Unter Umständen kann man unabhängig von diesem Wert unter [Shell:Products] das Ziel definieren:
%UserPrograms%\Microsoft Office\Microsoft Office Word 2003, %ProgramFilesDir%\microsoft office\office11\winword.exe, , , , , , ,
oder
%CommonPrograms%\Microsoft Office\Microsoft Office Word 2003, %ProgramFilesDir%\microsoft office\office11\winword.exe, , , , , , ,
Jens Beimel
Principal Consultant


Matrix42 AG
info@matrix42.de
http://www.matrix42.de

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG.

3kom
Beiträge: 10
Registriert: 26. Apr 2005, 12:03
Kontaktdaten:

Beitrag von 3kom » 18. Jan 2006, 11:55

Nein nicht dedifft sondern mit einer leeren Setup.inf Hülse per Hand das Packet erstellt. Also die MST eingefügt.

jbeimel
Moderator
Moderator
Beiträge: 642
Registriert: 15. Dez 2004, 09:16
Kontaktdaten:

Beitrag von jbeimel » 19. Jan 2006, 11:26

Also wird das Icon vom MSI-Setup selbst angelegt. Bin mir jetzt nicht sicher ob mit dem ORK das Ziel geändert werden kann.
Aber mit [Shell:Product] ist hier nix zu machen.
Jens Beimel
Principal Consultant


Matrix42 AG
info@matrix42.de
http://www.matrix42.de

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG.

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 5 Gäste