NERO 7 MSI

ahaidbauer
Beiträge: 8
Registriert: 22. Nov 2005, 06:18
Wohnort: Wiesbaden
Kontaktdaten:

Beitrag von ahaidbauer » 18. Mai 2006, 14:13

Oder so:

[Reg:License]
HKLM,"Software\Ahead\Installation\Families\Nero 7\Info","Company",0x00000000,"Fxxxxnius"
HKLM,"Software\Ahead\Installation\Families\Nero 7\Info","User",0x00000000,"Fxxxxnius"
HKLM,"Software\Ahead\Installation\Families\Nero 7\Info","Serial7_1145604319",0x00000000,"... LIZENZNUMMER ..."

[Set:Product]
IF DoesRegKeyExist ("HKLM,Software\Ahead\Installation\Families\Nero 7\Info\Serial7_1145604319") == "1" Then "RepairMSI" Else "InstallMSI" EndIf

[RepairMSI]
AddMeter 50
Call MsiExec /F "%SRC%\Files\nero.msi" /qb-! /L "%Temp%\MSI_%ProductName%.%Version%.%Revision%.log"

[InstallMSI]
AddMeter 10
Call MsiExec /i "%SRC%\Files\nero.msi" TRANSFORMS=Nero.mst /quiet /passive /norestart

[Set:Uninstall]
-Call MsiExec.exe /X{... PRODUCTKEY ...}

ahaidbauer
Beiträge: 8
Registriert: 22. Nov 2005, 06:18
Wohnort: Wiesbaden
Kontaktdaten:

Beitrag von ahaidbauer » 18. Mai 2006, 14:16

ach ja, und die nero.mst habe ich per installshieldtuner angefertigt, da hier beim kunden nicht alle optionen installiert werden sollen.

grüße,

alex haidbauer

Sembe
Beiträge: 56
Registriert: 21. Feb 2006, 12:09
Kontaktdaten:

Sauberes Setup.inf ohne Nero Scout?

Beitrag von Sembe » 01. Jun 2006, 16:46

Hallo,

mich würde einmal interessieren, ob es jemand geschafft hat, Nero 7 ohne den Nero Scout zu installieren?
Es gibt dort zwar einen Parameter NERO_SCOUT="FALSE", aber der bewirkt nichts. sobald man eine neue CD brennen will erscheint das Ding und hängt sich in die Taskleiste und den Explorer. :?
Da hilft noch nicht einmal das Deregistrieren einer DLL, wie es in vielen Foren steht.

Bin für jede Antwort dankbar!

Gruß
Sembe

sk
Beiträge: 147
Registriert: 14. Dez 2004, 10:09
Kontaktdaten:

Beitrag von sk » 23. Aug 2006, 12:16

Hallo,

ich habe es nach der "Kalle" Methode gemacht, die installation dauert zwar ewig bei der Riesenmenge Daten, aber sie funktioniert 8)

Eine kleine Frage habe ich allerdings noch: wie verschlüsselt man denn die Seriennummer?

sk

kalle hat geschrieben:Hallo,

viele Wege führen nach Rom :)

Bei der neuen Version 7.2.x gibt es wieder die Möglichkeit Silent-Parameter zu übergeben.

Auszug aus der Setup.inf:

[Environment]
customParameters=/qb! ALLUSERS=1 ADDLOCAL="ALL" REMOVE="NeroCoverDesigner7CE8D626" DESKTOP_SHORTCUT="0" NERO_SCOUT="FALSE" REBOOT="ReallySuppress"

Modul Bezeichnung

InCDC9AC4AC7
NeroBackItUpCB9D5429
NeroBurningRomBCAFF604
NeroCoverDesigner7CE8D626
NeroHome2FF8B816
NeroImageDriveE38B9E06
NeroMediaHome53BEFA20
NeroPhotoSnapED1EAF52
NeroProductSetup7850B4D2
NeroRecode6035F00C
NeroShowTimeD773A6E2
NeroSoundTrax716FE146
NeroStartSmartB035464E
NeroSuiteInstallerDD1EB5BC
NeroVision57D52359
NeroWaveEditorFA3A3F7B
Tools3E343E95

Die Dokumentation ist beim Support der Nero AG zu erhalten.

[Encryption]
SerialNumber=*M?n4;'987:g4-r/d6.)(|;!l~$<

[Set:Product]
call "..\Nero\SetupX.exe" SERIALNUMBER=%SerialNumber% %customParameters%

call "%ProgamFilesDir%\Nero\Nero 7\Nero Toolkit\NeroBurnRights.exe" /all /sec_class

gruß kh

jbeimel
Moderator
Moderator
Beiträge: 642
Registriert: 15. Dez 2004, 09:16
Kontaktdaten:

Beitrag von jbeimel » 23. Aug 2006, 12:36

Eine kleine Frage habe ich allerdings noch: wie verschlüsselt man denn die Seriennummer?
Configurator -> Depot, Menü Extras -> Verschlüsselte Anwendung erzeugen..., hier Passwort für Setup.
Jens Beimel
Principal Consultant


Matrix42 AG
info@matrix42.de
http://www.matrix42.de

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG.

sk
Beiträge: 147
Registriert: 14. Dez 2004, 10:09
Kontaktdaten:

Beitrag von sk » 24. Aug 2006, 09:45

Guten Morgen,

vielen Dank für die Info, hat leider nicht geklappt, war aber auch eh nur "nicetohave" :-)

Dafür hab ich jetzt das Problem, dass SetupX kein TMP verzeichniss auf dem Sourcedir erzeugen kann. Das ist soweit auch richtig, die Rechte haben die Standarduser da auch nicht. Bloß wie beheb ich den fehler?

sk
Gruß

SK

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7541
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 24. Aug 2006, 11:14

Ganz verstehe ich das Problem nicht, aber vielleicht hilft Kopieren der Source-Dateien zum LOKALEN Temp-Dir und von DORT Setup starten?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Vivantes
Beiträge: 18
Registriert: 22. Mär 2005, 10:50
Kontaktdaten:

Beitrag von Vivantes » 26. Sep 2006, 11:36

Guten Tag,

Wir sind gerade dabei Nero 7 Premium zu paketieren.
Leider ist bisher alles fehlgeschlagen, auch alle Tips von hier.

Also wir haben eine nero.msi und auch eine .mst , wenn wir nun mit msiexec diese aufrufen kommt die Meldung Installation bitte mit setupx.exe ausführen.
Wer kann uns helfen mit einer setup.inf oder Lösungen ?

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7541
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 26. Sep 2006, 23:26

Bitte mal als Property "ISSETUPDRIVEN=1" anhängen beim MSI-Call.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Dannemann
Beiträge: 2
Registriert: 15. Jan 2007, 11:58
Kontaktdaten:

Beitrag von Dannemann » 15. Jan 2007, 12:03

Hi,

ich sitze setzt auch schon länger an der Nero sache.
Um eine Installation mit der MSi zu starten, gibt es den Befehl: STARTPARAM="CallFromEXE" DONOTRUNSETUPX="1".

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste