TrueCrypt

Antworten
andi20coe
Beiträge: 322
Registriert: 27. Feb 2005, 15:23
Wohnort: Rosendahl
Kontaktdaten:

TrueCrypt

Beitrag von andi20coe » 09. Nov 2006, 09:19

Hallo!

Hat schon jemand erfolgreich TrueCrypt inkl. des Dienstes/Systemtreibers unattended installiert oder per Switches?

Hab es per Diff versucht, aber nach anfänglichen korrekten Installationen wurde wohl bei den letzten ca. 15 Installationsversuchen der Dienst nicht korrekt installiert / gestartet. Hab CheckServices auf 0 gesetzt.

Oder kann jemand noch andere Open Source Verschlüsselungsprogramme empfehlen?

Mit freundlichen Grüßen

Andrè Döking
Ärztekammer Westfalen-Lippe

Thomas_
Beiträge: 11
Registriert: 20. Dez 2006, 11:35
Wohnort: Freiburg im Breisgau
Kontaktdaten:

Beitrag von Thomas_ » 10. Jan 2007, 14:07

Hallo,

haben Sie inzwischen eine Lösung für Truecrypt gefunden. Wir würden dieses Utility nämlich auch gerne verteilen.

Gruß
Thomas Eckermann
Fraunhofer Institut IAF
Freiburg

Thomas_
Beiträge: 11
Registriert: 20. Dez 2006, 11:35
Wohnort: Freiburg im Breisgau
Kontaktdaten:

Beitrag von Thomas_ » 25. Apr 2007, 10:53

Hallo,

ich habe nach längerer Suche inzwischen eine Lösung gefunden, die zumindest im Moment, noch ganz gut funktioniert:
http://forums.truecrypt.org/viewtopic.p ... ght=silent

Habe die Datei sc.exe aus dem Ressourcekit ins src Verzeichnis kopiert und mit den Befehlen aus dem obigen Forumsbeitrag, zusätzlich zu den DIFF Ergebnissen, folgendes in die setup.inf eingetragen:
Installation:
Call "%src%\sc.exe" create truecrypt type= kernel start= auto error= normal binpath= "%system%\drivers\truecrypt.sys" DisplayName= truecrypt
Call net start truecrypt

Deinstallation:
- deleteservice "truecrypt"
; - call sc.exe delete truecrypt (sollte auch funktionieren)
- call net stop truecrypt

Gruß
Thomas Eckermann
Fraunhofer IAF
Freiburg

ploeger
Beiträge: 2
Registriert: 28. Jun 2007, 11:48
Kontaktdaten:

Beitrag von ploeger » 06. Jul 2007, 09:15

Hallo!

Bei mir hat das normale Diff mit Truecrypt 4.3a recht gut funktioniert. Ich musste nur aus der Kopierliste den zweiten Eintrag mit "truecrypt" löschen (warum auch immer er ihn doppelt hatte) und im [Services]-Bereich den System_Start auf Auto_Start umlegen, dann klappte alles.

Bis denne,
Dennis

impag
Beiträge: 18
Registriert: 05. Mai 2006, 15:25
Wohnort: Zürich
Kontaktdaten:

Beitrag von impag » 15. Okt 2007, 14:17

Code: Alles auswählen

[Set:Product]
1:TrueCrypt\TrueCrypt Website.url,      %CommonPrograms%, NORMAL,                86

1:Mount.bat,                          ,                 NORMAL,             0
1:DismountAll.bat,                          ,                 NORMAL,             0
1:License.txt,                          ,                 NORMAL,             25445
1:TrueCrypt Format.exe,                 ,                 NORMAL,            909248
1:TrueCrypt Setup.exe,                  ,                 NORMAL,            531904
1:TrueCrypt User Guide.pdf,             ,                 NORMAL,            691799
1:truecrypt-x64.sys,                    ,                 NORMAL,            198144
1:TrueCrypt.exe,                        ,                 NORMAL,            833984
1:Windows\System\drivers\truecrypt.sys, %System%,         SHAREDDLL SERVICE, 188672, truecrypt
1:truecrypt.sys,                        ,                 NORMAL,           188672, truecrypt
;1:Windows\System\DWRCShell.dll,       %System%,        SHAREDDLL,           69632
;1:, %App%, CREATE DIRECTORY CASCADED, 0


[Reg:OnUninstallProduct]


[Reg:Product]
HKCR,".tc","",0x00000000,"TrueCryptVolume"
HKCR,"TrueCryptVolume","",0x00000000,"TrueCrypt Volume"
HKCR,"TrueCryptVolume\DefaultIcon","",0x00000000,"%App%\TrueCrypt.exe,1"
HKCR,"TrueCryptVolume\Shell",,0x00000010
HKCR,"TrueCryptVolume\Shell\open",,0x00000010
HKCR,"TrueCryptVolume\Shell\open\command","",0x00000000,"""%App%\TrueCrypt.exe"" /v ""%%1"""
Klappt bei mir.

holger.rauch
Beiträge: 22
Registriert: 22. Nov 2011, 19:03
Kontaktdaten:

Re: TrueCrypt

Beitrag von holger.rauch » 10. Aug 2012, 08:52

Hallo zusammen,

ich versuche mich aktuell an der TrueCrypt 7.1a und werde so langsam irre!!!!! TrueCrypt 7.1a hat ja nach wie vor keinen Silentschalter im Installer und erfordert etwas "Handarbeit"!

Kurz mal zu meinen bisherigen Versuchen:
Umgebung: Win7 x64 SP1

1. Manuelle Installation über die exe-Datei funktioniert einwandfrei
- Als Admin lässt es sich starten
- Als Benutzer lässt es sich starten und schreit nach Adminrechten (ausführen als Administrator bringt keine Veränderung)

2. Installation als Paket einer Portableversion entspricht der Variante 1

3. wie Variante 2 und anschließend mit sc.exe den Dienst erstellen = entspricht der Variante 1

4. Installation als Paket mit der msi-Datei

5. Ich habe eine Diff-Analyse gemacht, aber auch hier ist das gleiche Ergebnis!

Hat irgendjemand eine Ahnung, wie ich Trucrypt einfach nur ans Laufen bekomme??????????


Danke schon mal für sachdienliche Hinweise
Holger

Benutzeravatar
lennu
Beiträge: 581
Registriert: 01. Aug 2005, 16:20
Wohnort: Bonn
Kontaktdaten:

Re: TrueCrypt

Beitrag von lennu » 17. Jun 2013, 16:09

Hallo,

ist zwar ein uralter Thread - aber hat es jemand hinbekommen, TrueCrypt 7.1a so zu paketieren, dass ein Anwender ohne Adminrechte TC-Container erstellen und mounten kann?

Gruß,
Lennu
Lennart Freyberg
Sysadmin
Deutsche Steinzeug Cremer & Breuer AG

fkreichel
Beiträge: 1
Registriert: 07. Aug 2013, 11:51
Kontaktdaten:

Re: TrueCrypt

Beitrag von fkreichel » 08. Aug 2013, 08:41

Bei mir läuft das hier:

Code: Alles auswählen

[SetupInfo]
Author                  = Frank Reichel
CreationDate            = 02.08.2012 13:53:50
InventoryID             = 
Description             = TrueCrypt
Method                  = Diff + Anpassungen
Tested on               = 
Dependencies            = 
Command line options    =/AW /S2 
Last Change             = 
Build                   = 

[VarDefInfo]
; <Variable>, <Type: 0=Computer 1=User>, <Allow NULL values: 0=No 1=Yes>

[Setup]
Version=10.5
ShowCaption=1
BlockInput=0
Platform=*

[Requirements]

[Application]
ProductName=TrueCrypt
DeveloperName=Tools
Version=7.1a
Revision=0
SetupName=%ProductName% %Version% %SetupWizard%
Text1="%ProductName% %Version%",         Arial,           30, , 00FFFF, 4,    , LEFT BOLD ITALIC
Text2="%DeveloperName%",                 Arial,           24, , 00FFFF, 4,    , LEFT BOLD ITALIC
Text8="%Company%",                       Arial,           18, , 00FFFF, 4,  10, RIGHT BOLD ITALIC
Text9="%InstallationFor% %WindowsUser%", Arial,           16, , 007F00, 4, -18, BOTTOM ITALIC LEFT
BackgroundColor=FF0000,000000
CopyDialogRect=0%, 0%, 100%, 100%, HCENTER VCENTER
UserKeyName=%DeveloperName%\%ProductName%
MachineKeyName=%DeveloperName%\%ProductName%\%Version%
UninstallKeyName=%DeveloperName% %ProductName% %Version%
UninstallDisplayName=%ProductName% %Version%
UninstallString=%ReinstallString% /U
ReinstallString="%CommonSetupDir%\Setup.exe" "%App%\%SetupInfDir%\Setup.inf"
ReinstallMode=1
SrcDir=..
ApplicationDir=%ProgramFilesDir%\%ProductName%
SetupInfDir=Install
DataDir=%Personal%
Prompts=
AskUninstallOld=1
ShellLinks=1
CommonShellLinks=1
CreateUnresolvableShellLinks=1
UseStringSection=Strings:09
UseSysStringSection=SysStrings:09
DateWarning=1
SizeWarning=1
Reboot=0
PreventExternalReboot=1
StartServicesOnReboot=0
CallTimeOut=3600
AbortAfterCallTimeOut=1
DisableCancelButton=1
ShowEndMessage=1
EndMessage=%EndMessageDesc%


[Strings:07]
Disk1=Installationsmedium 1
EndMessageDesc=Die Installation wurde erfolgreich abgeschlossen!
ErrorLogMessage=Die Installation/Deinstallation wurde mit einer Fehlermeldung abgebrochen!
InstallationFor=Installation für:
InstallerDesc=Dienstprogramm zum Installieren einzelner Komponenten.
InstallerName=Installationsprogramm
SetupWizard=Installations-Assistent
Uninstallation=deinstallieren

[Strings:09]
Disk1=Installation media 1
EndMessageDesc=Installation was completed successfully!
ErrorLogMessage=The installation/uninstallation aborted with an error message!
InstallationFor=Installation for:
InstallerDesc=Service program to install single components.
InstallerName=Setup program
SetupWizard=Installation Wizard
Uninstallation=Uninstallation

[SysStrings:07]
Users=Benutzer

[SysStrings:09]
Users=Users

[Environment]
CommonSetupDir=%CommonFilesDir%\Setup%SetupBits%
V_MachineValuesPath=\\%EmpirumServer%\Values$\MachineValues\%DomainName%
V_UserValuesPath=%HKLM,"Software\matrix42\Software Depot","HomeServer"%\Values$\UserValues\%UserDomain%

; Maschinenabhängige Variablen
; machine dependent variables
;VM_<Variable>=%%%V_MachineValuesPath%\%ComputerName%.ini,%ComputerName%,<Variable>%%

; Userabhängige Variablen
; user dependent variables
;VU_<Variable>=%%%V_UserValuesPath%\%WindowsUser%.ini,%WindowsUser%,<Variable>%%

; !!! Setzen der entsprechenden ReplaceEnv Befehle für die Variablen im Abschnitt [Product] nicht vergessen!!!
; !!! Don't forget to set the appropriate ReplaceEnv instructions for the variables in the section [Product]!!!

[Prompts]

[Services]

[Processes]

[EventSources]

[Encryption]

[Disks]
1=%Disk1%

[Options]
Installer = %InstallerName%, COPYALWAYS, Installer, "%InstallerDesc%"
Product   = %ProductName%,   COPYALWAYS, Product,   "%ProductDesc%"

[Installer]
1:..\..\..\..\User\Setup.exe,          %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupDeu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\SetupEnu.chm,       %CommonSetupDir%, OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP, 0
1:..\..\..\..\User\Mx42SynSem.dll,     %System%,         OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP WINDOWS32, 0
1:..\..\..\..\User\x64\Mx42SynSem.dll, %System%,         OPTIONAL USEFILENAME DIRECTORY NOSIZEWARNING SETUP WINDOWS64, 0
1:%SetupInfDir%\Setup.inf,                             , NORMAL,                                             0
1:%Temp%\Setup64.exe,                  %CommonSetupDir%\Setup.exe, OPTIONAL NOSIZEWARNING SETUP ALWAYS WINDOWS64,      0

[FileCheckMachine]
ReplaceEnv V_MachineValuesPath
If DoesFileExist ("%V_MachineValuesPath%\%ComputerName%.ini") == "0" Then "FileIsntThere" EndIf

[FileCheckClient]
ReplaceEnv V_UserValuesPath
If "%UserDomain%" <> "%ComputerName%" Then "CheckClientFile" EndIf

[CheckClientFile]
If DoesFileExist ("%V_UserValuesPath%\%WindowsUser%.ini") == "0" Then "FileIsntThere" EndIf

[FileIsntThere]
ErrorLogMsg Values$\MachineValues\%DomainName%\%ComputerName%.ini or Values$\UserValues\%UserDomain%\%WindowsUser%.ini not found!
Abort


[Product]
;#FileCheckMachine, MACHINE
;#FileCheckClient, CLIENT
;ReplaceEnv <Variable>

#Set:Product32, DONTDELETE WINDOWS32
#Set:Product64, DONTDELETE WINDOWS64
#Reg:OnUninstallProduct, DELETE
#Set:Uninstall, DELETE
#Reg:Product
#Ini:Product
#Security:Product

[Set:Product32]
1:Windows\System\drivers\truecrypt.sys, %System%, SHAREDDLL,  231760
1:Language.de.xml,                      ,         NORMAL,     286426
1:License.txt,                          ,         NORMAL,      24521
1:TrueCrypt Format.exe,                 ,         NORMAL,    1610704
1:TrueCrypt User Guide.pdf,             ,         NORMAL,     923969
1:truecrypt-x64.sys,                    ,         NORMAL,     231376
1:TrueCrypt.exe,                        ,         NORMAL,    1516496
1:truecrypt.sys,                        ,         NORMAL,     231760
call "%WINDIR%\System32\sc.exe" create truecrypt type= kernel start= system error= normal binPath= "System32\Drivers\truecrypt.sys" DisplayName= truecrypt
sleep 5000
call "%WINDIR%\System32\sc.exe" start truecrypt

[Set:Product64]
1:Windows\System\drivers\truecrypt-x64.sys, %System%, SHAREDDLL,  231760
1:Language.de.xml,                      ,         NORMAL,     286426
1:License.txt,                          ,         NORMAL,      24521
1:TrueCrypt Format.exe,                 ,         NORMAL,    1610704
1:TrueCrypt User Guide.pdf,             ,         NORMAL,     923969
1:truecrypt-x64.sys,                    ,         NORMAL,     231376
1:TrueCrypt.exe,                        ,         NORMAL,    1516496
1:truecrypt.sys,                        ,         NORMAL,     231760
call "%WINDIR%\System32\sc.exe" create truecrypt type= kernel start= system error= normal binPath= "System32\Drivers\truecrypt-x64.sys" DisplayName= truecrypt
sleep 5000
call "%WINDIR%\System32\sc.exe" start truecrypt


[Reg:OnUninstallProduct]

[Set:Uninstall]
-call "%WINDIR%\System32\sc.exe" delete truecrypt
-sleep 5000
-call "%WINDIR%\System32\sc.exe" stop truecrypt

[Reg:Product]
HKCU,"Software\Microsoft\Windows\CurrentVersion\Run","TrueCrypt",0x00000000,"""C:\Program Files\TrueCrypt\TrueCrypt.exe"" /q preferences /a logon /a favorites"

[Ini:Product]

[Security:Product]

[Shell:Product]
%SystemTools%\TrueCrypt, %App%\TrueCrypt.exe, , %App%
Ich kann allerdings nicht sagen, mit welchen Windows-Versionen das alles geht, wir haben nur XP und Win7.

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 17 Gäste