Citrix Ica-Client 10.1.5

Antworten
gruwewasser
Beiträge: 16
Registriert: 13. Dez 2006, 15:13
Kontaktdaten:

Citrix Ica-Client 10.1.5

Beitrag von gruwewasser » 27. Jun 2008, 13:06

Hallo,

habe ein Problem mit einem Packet.
Das Packet funktioniert soweit einwandfrei.
Leider habe ich ein Problem mit dem User Teil diese Packetes.
Hier der Teil der nicht funktioniert. Ich hätte gerne das bei jedem User der sich an dem Rechner anmeldet 2 Dateien ins Profil kopiert werden. Leider macht er es mit dem folgenden Befehl nicht.


Vielen Dank für Eure Unterstützung.

#Set:Product, DONTDELETE
#Reg:OnUninstallProduct, DELETE
#Reg:Product, DONTDELETE
#Ini:Product, DONTDELETE
#Set:Client, CLIENT DONTDELETE
#Security:Product
#Set:Uninstall, DELETE
#Set:ChangeMSISourcelist, DONTDELETE


[Set:Client]
1:AppData\ICAClient\APPSRV.ini, %AppData%, ALWAYS REPLACEVARS,0
1:AppData\ICAClient\PN.ini, %AppData%, ALWAYS REPLACEVARS,0

fdooo
Beiträge: 96
Registriert: 14. Aug 2006, 15:07
Kontaktdaten:

Beitrag von fdooo » 27. Jun 2008, 14:14

Wir haben das zwar getrennt gelöst (Extra Paket für die Konfiguration) aber im Prinzip geht es um das gleiche.

#Set:Product
#Set:Installation, DONTDELETE
#Set:Konfiguration, CLIENT
#Set:Deinstallation, DELETE
#Reg:OnUninstallProduct, DELETE
#Reg:Product
#Ini:Product
#Security:Product

[Set:Product]


[SET:Installation]
mkdir "c:\temp\ICA_Conf"
call xcopy /s /H /R /E /Y "%src%\ICAClient\*.*" "c:\temp\ICA_Conf\ICAClient\*.*"

[SET:Konfiguration]
call xcopy /S /H /R /E /Y "c:\temp\ICA_Conf\ICAClient\*.*" "%APPDATA%\ICAClient\*.*"


Es geht super.

Benutzeravatar
MSC
Beiträge: 324
Registriert: 03. Jul 2006, 09:03
Kontaktdaten:

Beitrag von MSC » 27. Jun 2008, 14:15

Hi,

bei der Userteil-Installation wird das %APP% als %SRC% verwendet, deshalb müssen die beiden Dateien bei der Machine-Installation ins %App% kopiert werden. In obigem Script werden die Dateien z.B. unter %App%\Appdata\ICAClient\APPSRV.INI gesucht.

Also Im MachinTeil folgendes ergänzen:
[Set:CopyFiles]
1:AppData\ICAClient\APPSRV.ini, , ALWAYS,0
1:AppData\ICAClient\PN.ini, , ALWAYS,0

Damit sollten die beiden Dateien im ApplicationDir abgelegt werden. Bitte testen, bevor es eingesetzt wird ;-)

MFG Mario

gruwewasser
Beiträge: 16
Registriert: 13. Dez 2006, 15:13
Kontaktdaten:

Beitrag von gruwewasser » 27. Jun 2008, 14:23

Viele Dank für eure Hilfe :)

Habt ihr auch den ICA-Client 10.15 im Nutzung?
Hattet ihr auch die Probleme mit der Authentifizierung?
Habt ihr die Instalaltion über MSI anpssungen über MST realisiert?
WElche Parameter habt ihr im MST ergänzz?

mfg

Michael

Benutzeravatar
Trickser
Beiträge: 560
Registriert: 11. Okt 2006, 10:51
Wohnort: Jülich
Kontaktdaten:

Beitrag von Trickser » 28. Jun 2008, 18:13

Hi,

der ICA-Client hat doch einen eingebauten Repackager, da wär es ziemlicher Humbug das Ding mit Empirum zu Repaketieren.

Aufruf des Packagers: Ica32pkg.msi /A

Gruß,

Micha.

m.striecks
Beiträge: 34
Registriert: 18. Mär 2005, 20:30
Wohnort: Berlin
Kontaktdaten:

Beitrag von m.striecks » 28. Jun 2008, 18:25

Hallo zusammen,
wir versuchen auch die angepasste APPSRV.ini per Paket in das Benutzerprofil zu kopieren, bzw. versuchen das bereits im Servergespeicherten Benutzerprofil zu speichern.
"[Set:CopyFiles]
1:AppData\ICAClient\APPSRV.ini, , ALWAYS,0 "

Trotzdem haben wir das Problem das die APPSRV.ini beim Starten des Programms Citrix-Client 10.1.5 scheinbar Neu vom Programm erstellt wird und die kopierte Datei überschreibt. In der alten Version 9... hatten wir keine Probleme mit dem Citrix-Client.
Vielleicht hat jemand eine Idee.

Gruß
Markus

Benutzeravatar
Frank Dethlefsen
Beiträge: 433
Registriert: 06. Apr 2006, 22:01
Wohnort: Bochum
Kontaktdaten:

Beitrag von Frank Dethlefsen » 28. Jun 2008, 20:21

Jeder Benutzerteil, den man nicht braucht, ist ein guter Benutzerteil...

Ich erstelle ein ICA-Paket in der Regel deshalb so:

msiexec /A Ica32Pkg.msi
Quellendateien unkomprimiert ablegen
\Citrix\ICA Classic\appsrv.src austauschen durch die angepasste appsrv.ini
\Citrix\ICA Classic\pn.src austauschen durch die angepasste pn.ini
\Citrix\ICA Classic\pn.ini austauschen durch die angepasste pn.ini
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

gruwewasser
Beiträge: 16
Registriert: 13. Dez 2006, 15:13
Kontaktdaten:

Beitrag von gruwewasser » 30. Jun 2008, 10:40

Vielen Dank.

Problem ist aber das wir zum Beispiel mit Servergespeicherten Profilen arbeiten.
Dies hat zur Folge das ich zum Beispiel den Installationpfad ändern muss.
Citrix ist ja so glorreich und ändert regelmäßig die Pfade.
Ich muss in ica-client installieren und nicht wie vorgeschlagen ica client.
Deswegen komm ich glaube nich tan der Anpassung über mst vorbei.
Habe mir mit dem Parameter /a eine angepasstes msi erstellt.
Trotzdem passe ich diese über mst noch etwas genauer an.
Was habt ihr alles zusätzlich angepasst.

mfg

Michael

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste