INI-Datei ändern

Antworten
Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

INI-Datei ändern

Beitrag von Jens Altrock » 22. Apr 2009, 14:34

Hi!

Wahrscheins nur ein Anfängerfehler, aber ich komme nicht weiter...

Ich möchte eine ini-Datei (namentlich okft.ini) von unserem Finanzwesen anpassen, und zwar folgenden Abschnitt:

Code: Alles auswählen

[background]
normal=192,192,192, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,128,128, 255,255,255
Das ganze habe ich folgendermassen in der setup.inf untergebracht (fehlende Abschnitte zwischendurch durch ... markiert):

Code: Alles auswählen

...
#Ini:Product
#Ini:okft.ini
#Security:Product
...
[Ini:okft.ini]
Path="C:\akdbprg\okft\ini"
background,normal,248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255
Funktioniert aber leider so nicht, dachte ich hätte mich an die Hilfe gehalten, aber irgend etwas ist da wohl noch falsch... Vielleicht kann mir ja jemand auf den richtigen Pfad helfen.

AFiedler
Beiträge: 265
Registriert: 15. Nov 2005, 16:02
Wohnort: Köln
Kontaktdaten:

Beitrag von AFiedler » 22. Apr 2009, 15:05

Das müsste mit den fehlenden Hochkomma zusammen hängen:

[Ini:okft.ini]
Path="C:\akdbprg\okft\ini"
background,normal,"248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255"

Gruß

Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

Beitrag von Jens Altrock » 22. Apr 2009, 15:10

Nein, funktioniert weder mit noch ohne (hab ich vergessen zu schreiben :( )
Leider sagt Empirum auch dass es eine error Datei geschrieben hat, aber da wo die sein sollte ist keine...

AFiedler
Beiträge: 265
Registriert: 15. Nov 2005, 16:02
Wohnort: Köln
Kontaktdaten:

Beitrag von AFiedler » 22. Apr 2009, 15:27

Probiers mal so:

[Ini:Product]
"C:\akdbprg\okft\ini","background",,"248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255"

Benutzeravatar
MSC
Beiträge: 324
Registriert: 03. Jul 2006, 09:03
Kontaktdaten:

Beitrag von MSC » 22. Apr 2009, 15:35

So fluppts doch wunderbar (Emp2008 R2)

...
[Ini:okft.ini]
Path=C:\Temp\okft
background,normal,248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255
...

mfg Mario

Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

Beitrag von Jens Altrock » 22. Apr 2009, 15:42

@AFiedler: Das ist ja die Frage, da fehlt doch der Name der INI Datei oder sehe ich das falsch?

Aber muss das nochmal in Ruhe testen , vielleicht hab ich mir auch irgendwo selbst nen Fehler reingebaut...

AFiedler
Beiträge: 265
Registriert: 15. Nov 2005, 16:02
Wohnort: Köln
Kontaktdaten:

Beitrag von AFiedler » 22. Apr 2009, 15:44

Ok habs überlesen dann müsste das so aussehen:

[Ini:Product]
"C:\akdbprg\okft\ini\okft.ini","background",,"248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255"

Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

Beitrag von Jens Altrock » 22. Apr 2009, 16:14

Auf keinem der Beiden Wege schreibt er mir die Werte in die Ini-Datei :(

Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

Beitrag von Jens Altrock » 22. Apr 2009, 16:21

Was mir noch aufgefallen ist, wenn ich das so mache:

Code: Alles auswählen

[Ini:okft.ini]
Path=C:\akdbprg\okft\ini
background,normal,"248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255" 
springt er beim Einzelstepdebug nur in die erste Zeile, und dann wieder zurück in [Product]. Die zweite Zeile wird komplett übersprungen.

Jens Altrock
Beiträge: 420
Registriert: 15. Apr 2009, 10:17
Kontaktdaten:

Beitrag von Jens Altrock » 22. Apr 2009, 16:24

So jetzt aber, hab den Fehler gefunden -.-
Aufruf muss so sein:

Code: Alles auswählen

[Ini:Product]
"C:\akdbprg\okft\ini\okft.ini","background",,"normal=248,236,194, 212,212,212, 255,255,255, 192,192,192, 212,212,212, 255,255,255, 0,0,255, 255,255,255"

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 20 Gäste