Frage zu Kopierbefehl

Antworten
C-Riouz
Beiträge: 162
Registriert: 08. Dez 2007, 17:13
Wohnort: Südhessen
Kontaktdaten:

Frage zu Kopierbefehl

Beitrag von C-Riouz » 29. Sep 2010, 18:28

Wenn ein Kopierbefehl z.B. folgendermaßen lautet:

1:history.txt, , NORMAL, 23016


Was hat die Zahl 23016 zu bedeuten? Und wie krieg ich die Zahl raus wenn ich eine weitere zu kopierende Datei manuell nachtragen will? Ich dachte zunächst an die Dateigröße, aber das ging schief.


Gruß

Benutzeravatar
FruF
Beiträge: 204
Registriert: 26. Jan 2009, 12:33
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von FruF » 29. Sep 2010, 19:21

Dateigrösse =) Gute Intuition.

Is nicht nötig, im Notfall lass die Zahl weg.
Für ein "Verständiss" empfehle ich die SetupDEU.chm

Viel Spass

Phadda
Beiträge: 654
Registriert: 18. Jun 2009, 14:53
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Phadda » 30. Sep 2010, 07:51

seh als eine art "checksum" die filegröße an, ist diese größer/kleiner wie die in der setup.inf angegeben größe, gibts ein error ... ich schmeiss die auch immer raus, wenn du mal eine datei hast die manuell immer angepasst wird, bat kix cmd etc udn die größe ändert sich, holst dir ein faules ei ans board ;)

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Walter_Schulz » 30. Sep 2010, 09:31

C-Riouz hat geschrieben:Ich dachte zunächst an die Dateigröße, aber das ging schief.
Das ist die Groesse der Datei in Bytes. Windows kennt hier zwei Angaben. Einmal der auf dem Datentraeger benoetigte Platz (Menge der belegten Bloecke mal Blockgroesse), einmal die tatsaechliche Groesse der Datei.

Ciao!
Walter Schulz

C-Riouz
Beiträge: 162
Registriert: 08. Dez 2007, 17:13
Wohnort: Südhessen
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von C-Riouz » 30. Sep 2010, 11:33

Wenn ich die Größenangabe rausnehme bekomme ich bei den entsprechenden Zeilen im Setup die Meldung "Bitte legen Sie die Diskette ein..." bla.

Wie kann ich das abstellen?

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Walter_Schulz » 30. Sep 2010, 11:44

1:history.txt, , NORMAL, 0

Ciao, Walter
Zuletzt geändert von Walter_Schulz am 30. Sep 2010, 12:10, insgesamt 2-mal geändert.

C-Riouz
Beiträge: 162
Registriert: 08. Dez 2007, 17:13
Wohnort: Südhessen
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von C-Riouz » 30. Sep 2010, 11:53

Nehm ich Größe 0 erhalte ich die Fehlermeldung:

Falsche Flags: 0!

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Walter_Schulz » 30. Sep 2010, 11:58

Bitte mal die Setup.inf hier als Code (siehe oben, 5. Icon von links) einstellen.

C-Riouz
Beiträge: 162
Registriert: 08. Dez 2007, 17:13
Wohnort: Südhessen
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von C-Riouz » 30. Sep 2010, 12:03

Code: Alles auswählen

[SetupInfo]
Author			= Frank Dethlefsen, Senior Consultant, matrix42 AG, fdethlefsen@matrix42.de
CreationDate		= 11.03.2006
InventoryID		= FDN04
Description		= External Programs for Empirum Management Console Version 2.0 English
Method (Diff/MSI/...)	= Scripted
Tested on W2k/NT/...	= Win2000, WinXP, Win2003, WinVista
Dependencies		= Matrix42\EMC\11.0 (Empirum Management Console 11)
Command line options	= /S2
Last change		= 05.05.2010
Build			= 0

[VarDefInfo]
; <Variable>, <Type: 0=Computer 1=User>, <Allow NULL values: 0=No 1=Yes>

; --------------------------------------
; ---   CHANGELOG   --------------------
; --------------------------------------
;2010-05-05   MSC   Angepasst fü Version V12 P02
; --------------------------------------
[Setup]
Version=10.5
ShowCaption=1
BlockInput=0
Platform=x86

[Requirements]

[Application]
ProductName=External Programs for EMC
ProductNameShort=EPFEMC
Version=2.0
VersionDirSuffix=100
Revision=0
ServiceRelease=0
DeveloperName=matrix42
DeveloperNameShort=matrix42
SetupName=%ProductName% %Version% %SetupWizard%
Text1="%ProductName% %Version%",         Arial,           30, , 00FFFF, 4,    , LEFT BOLD ITALIC
Text2="%DeveloperName%",                 Arial,           24, , 00FFFF, 4,    , LEFT BOLD ITALIC
Text8="%Company%",                       Arial,           18, , 00FFFF, 4,  10, RIGHT BOLD ITALIC
Text9="%InstallationFor% %WindowsUser%", Arial,           14, , 007F00, 4, -14, BOTTOM ITALIC LEFT
BackgroundColor=FF0000,000000
BackgroundPicture=
BackgroundSound=
Logo=
WizardPicture=
CopyDialogRect=0%, 0%, 100%, 100%, HCENTER VCENTER
PrecopyFiles=
UserKeyName=%DeveloperName%\%ProductName%
MachineKeyName=%DeveloperName%\%ProductName%\%Version%
UninstallKeyName=%DeveloperNameShort% %ProductName%
UninstallDisplayName=%ProductName% %Version%
UninstallString=%ReinstallString% /U
ReinstallString="%CommonSetupDir%\Setup.exe" "%App%\%SetupInfDir%\Setup.inf"
ReinstallMode=1
HideUninstall=0
SrcDir=..
ApplicationDir=
SetupInfDir=Install
DataDir=%Personal%
DefaultUser=
DefaultCompany=
Prompts=
RunIfInstalled=
Readme=
Execute=
Expand=0
CopyExistingFiles=0
AskUninstallOld=1
AskLicence=0
AskInfo=0
AskFromCD=0
AskShared=0
AskMode=0
AskDir=0
AskDataDir=0
AskUser=0
UseCompany=1
UseProductID=0
ProductIDLength=0
UseProductIDPerOption=0
UseCheckmarks=2
AutoIniFileMapping=0
ShellLinks=1
CommonShellLinks=1
CreateUnresolvableShellLinks=1
ShowShellFolder=
LicenceText=
InfoText=
RequirementsText=
UseStringSection=Strings:09
UseSysStringSection=SysStrings:09
PrintServer=
PrintEnvironment=
DateWarning=0
SizeWarning=0
Reboot=2
PreventExternalReboot=1
StartServicesOnReboot=0
CallTimeOut=3600
AbortAfterCallTimeOut=1
ReplaceRunOnce=0
DisableCancelButton=1
ShowEndMessage=1
EndMessage=%EndMessageDesc%
SetupExtDll=
SetupHookFunc=
ShowFullPath=0

[Admin]
AdminSetup=0
ApplicationDir=
AskDir=1
AskOptions=0
ClientSrcDir=Client
UninstallString=%ReinstallString% /U
ReinstallString="%Src%\..\..\..\..\User\Setup.exe" "%Src%\%SetupInfDir%\Setup.inf"

[Client]
ClientDir=
AskDir=0
AskOptions=1
Reboot=0
UseUninstallStringFromApplication=1
InstallAtLast=0

[Workstation]
AskOptions=0
AdminUninstallLink=0
AdminUninstallLinkName=%ProductName% %Version%
UserSetupLink=0
UserSetupLinkName=%ProductName% %Version%

[Strings:07]
Disk1=Diskette 1: Installationsdiskette
EndMessageDesc=Die Installation wurde erfolgreich abgeschlossen!
InstallationFor=Installation für:
InstallerDesc=Dienstprogramm zum Installieren einzelner Komponenten.
InstallerName=Installationsprogramm
ProductDesc=Externe Programme für die Empirum Management Console 2008
SetupWizard=Installations-Assistent
Uninstallation=deinstallieren

[Strings:09]
Disk1=Diskette 1: Installation disk
EndMessageDesc=Installation was completed successfully!
InstallationFor=Installation for:
InstallerDesc=Service program to install single components.
InstallerName=Setup program
ProductDesc=External programs for the empirum management console 2008
SetupWizard=Installation Wizard
Uninstallation=Uninstallation

[SysStrings:07]
Users=Benutzer

[SysStrings:09]
Users=Users

[Environment]
CommonSetupDir=%CommonFilesDir%\Setup%SetupBits%
V_MachineValuesPath=%Src%\..\..\..\..\Values\MachineValues\%DomainName%
V_UserValuesPath=%HKLM,"Software\matrix42\Software Depot","HomeServer"%\Values$\UserValues\%UserDomain%

; Maschinenabhängige Variablen
; machine dependent variables
;VM_<Variable>=%%%V_MachineValuesPath%\%ComputerName%.ini,%ComputerName%,<Variable>%%

; Userabhängige Variablen
; user dependent variables 
;VU_<Variable>=%%%V_UserValuesPath%\%WindowsUser%.ini,%WindowsUser%,<Variable>%%

; !!! Setzen der entsprechenden ReplaceEnv Befehle für die Variablen im Abschnitt [Product] nicht vergessen!!!
; !!! Don't forget to set the appropriate ReplaceEnv instructions for the variables in the section [Product]!!!

[Prompts]

[Services]

[EventSources]

[Encryption]

[Disks]
1=%Disk1%

[UserKeyNames]

[Icons]
Product = %ProductNameShort%.ico, 0, 000000, ICON

[Options]
Installer = %InstallerName%, COPYALWAYS, Installer, "%InstallerDesc%"
Product   = %ProductName%,   COPYALWAYS, Product,   "%ProductDesc%"

[OptionDependencies]

[OptionGroups]

[Installer]

[Product]
#Set:Product

[Set:Product]
1:Windows\System\_01Ping.cmd,              %System%, NORMAL,     44
1:Windows\System\_02Reboot.cmd,            %System%, NORMAL,    591
1:Windows\System\_03Manage.cmd,            %System%, NORMAL,    117
1:Windows\System\_04Regedit.cmd,           %System%, NORMAL,     69
1:Windows\System\_05C$.cmd,                %System%, NORMAL,     71
1:Windows\System\_06D$.cmd,                %System%, NORMAL,     69
1:Windows\System\_07Cmd.cmd,               %System%, NORMAL,    113
1:Windows\System\_08EmpInv.cmd,            %System%, NORMAL,      0
1:Windows\System\_09EmpAgent.cmd,          %System%, NORMAL,    996
1:Windows\System\_10List_processes.cmd,    %System%, NORMAL,     76
1:Windows\System\_11Kill_process.cmd,      %System%, NORMAL,    193
1:Windows\System\_12Logbook.cmd,           %System%, NORMAL,    462
1:Windows\System\_13Show_computer.ddc.cmd, %System%, NORMAL,    510
1:Windows\System\_14Show_computer.ini.cmd, %System%, NORMAL,    510
1:Windows\System\_15Show_os.ini.cmd,       %System%, NORMAL,    407
1:Windows\System\_16Debugview.cmd,         %System%, NORMAL,    407
1:Windows\System\_17Hwspy.cmd,             %System%, NORMAL,   1907
1:Windows\System\_18Userliste.cmd	   %System%, NORMAL,      0
1:Windows\System\_19Defragmentieren.cmd	   %System%, NORMAL,      0
1:Windows\System\Alive.exe,                %System%, NORMAL,  73216
1:Windows\System\Netuse.cmd,               %System%, NORMAL,   1658
1:Windows\System\psexec.exe,               %System%, NORMAL, 234536
1:Windows\System\pskill.exe,               %System%, NORMAL, 187184
1:Windows\System\pslist.exe,               %System%, NORMAL, 125744
1:Windows\System\psloggedon.exe,           %System%, NORMAL, 105264
1:Windows\System\psshutdown.exe,           %System%, NORMAL, 207664
1:Windows\System\remote_regedit.exe,       %System%, NORMAL, 500889
1:Windows\System\remote_debugview.exe,     %System%, NORMAL, 500889
1:Windows\System\Dbgview.exe,              %System%, NORMAL, 480296
1:Windows\System\Dbgview.chm,              %System%, NORMAL,  68539
1:Windows\System\Wintail.exe,              %System%, NORMAL,  53248
1:Windows\System\GWIOPM.SYS,               %System%, NORMAL,   3904
1:Windows\System\hex2dec.cmd,              %System%, NORMAL,    623
1:Windows\System\PCI32.EXE,                %System%, NORMAL, 110080
1:Windows\System\RunPCI32.cmd,             %System%, NORMAL,   6305
1:Windows\System\SetEmpirumserver.cmd,     %System%, ALWAYS,      0
es geht um die zwei eigenen dateien

_18Userliste.cmd
_19Defragmentieren.cmd

Phadda
Beiträge: 654
Registriert: 18. Jun 2009, 14:53
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Phadda » 30. Sep 2010, 12:09

Fehlt da das Komma? "," bei 18 und 19?
1:Windows\System\_17Hwspy.cmd, %System%, NORMAL, 1907
1:Windows\System\_18Userliste.cmd %System%, NORMAL, 0
1:Windows\System\_19Defragmentieren.cmd %System%, NORMAL, 0
1:Windows\System\Alive.exe, %System%, NORMAL, 7321

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Walter_Schulz » 30. Sep 2010, 12:10

Richtig:
1:history.txt, , NORMAL, 0
=== Falsch:
1:Windows\System\_18Userliste.cmd %System%, NORMAL, 0
1:Windows\System\_19Defragmentieren.cmd %System%, NORMAL, 0
===
Syntax:
<source>, <dest>, Flags, Size
Falls <dest> leer ist, wird %App% verwendet.

Bitte beim haendischen Editieren der Setup.inf aeusserst penibel vorgehen oder den Package-Editor verwenden.

Ciao, Walter

C-Riouz
Beiträge: 162
Registriert: 08. Dez 2007, 17:13
Wohnort: Südhessen
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von C-Riouz » 30. Sep 2010, 12:17

du hattest recht, das komma nach der cmd hat gefehlt.

ich werd gleich ein termin beim augenarzt machen :)

Danke!!!!!!!!!!!

Bela
Beiträge: 78
Registriert: 04. Jan 2005, 11:15
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Bela » 12. Okt 2010, 16:01

Hallo,

weil ich es gerade hier sehe:

Wo kann ich denn die aktuellen "External Programs for Empirum-Management Console" herunterladen, die auch für Windows 7 funktionieren? (z.B. remote_regedit.exe).

Im Support-Bereich habe ich leider nichts gefunden...

Danke.

Gruß
Bela

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7589
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Frage zu Kopierbefehl

Beitrag von Hendrik_Ambrosius » 12. Okt 2010, 21:17

Habe die letzte mir bekannte Version von 2008 mal hier abgelegt:
http://dl.dropbox.com/u/2271599/Empirum ... 02.0.1.exe
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

Bela
Beiträge: 78
Registriert: 04. Jan 2005, 11:15
Kontaktdaten:

Re: Frage zu Kopierbefehl

Beitrag von Bela » 13. Okt 2010, 09:28

Hallo Herr Ambrosius,

vielen Dank für den Link, aber auch diese Version scheint veraltet zu sein!

Wenn ich mir den Code vom Thread-Ersteller anschaue, dann steht dort z.B.:

1:Windows\System\remote_regedit.exe, %System%, NORMAL, 500889

Sprich, die Datei ist ca. 500kB groß. Ihre Version ist vom 04.01.2008 und ist 229kB groß und führt beim Ausführen unter Windows 7 zur Meldung "Operating System is not supported". Ich denke, der Thread-Ersteller hat wohl eine aktuellere Version. (Ich gehe davon aus, dass größer=neuer ist... :-) Doch woher?

Gruß

Béla

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste