Seite 1 von 1

Versions-Update vermeiden

Verfasst: 04. Feb 2013, 08:31
von sascha.joswig
Hi Leute,

ich habe hier ein neues Paket einer Software von der auf vereinzelten Rechnern noch eine alte Version installiert ist. Den Rest der Geschichte lassen wir mal außen vor ;)

Wie dem auch sei suche ich gerade nach dem Indikator, der erkennt, dass es sich bei dem Paket um ein Update-Paket handelt um zu verhindern, dass er erkennt, dass er die alte Setup.inf suchen muss.

Ich habe bereits die Uninstall-Einträge des alten Pakets entfernt, aber Empirum versucht weiterhin ein Update.

Bitte kurze Info. Danke!

Re: Versions-Update vermeiden

Verfasst: 04. Feb 2013, 09:20
von bboehm
Guten Morgen Sascha,

In der setup.inf findest du den Parameter "AskUninstallOld". Ist der Wert "1" versucht der Agent eine Deinstallation des
alten Pakets, ist der Wert "0" wird keine Deinstallation der älteren Version durchgeführt.

Schöne Grüße
Bernhard

Re: Versions-Update vermeiden

Verfasst: 04. Feb 2013, 09:30
von sascha.joswig
Hi Bernhard,

danke für den Hinweis, aber der Schalter muss zwingend so bleiben wie er ist, da ich auch saubere Versions-Updates habe. Es betrifft nur eine handvoll Rechner, bei denen ich es dirty brauche ;)

Re: Versions-Update vermeiden

Verfasst: 04. Feb 2013, 09:34
von bboehm
Wenn dirty, dann zieh die älteren Versionen mit dem Parameter auf den aktuellen Stand und dann änderst den Wert
im Paket einfach wieder.

Re: Versions-Update vermeiden

Verfasst: 04. Feb 2013, 10:06
von sascha.joswig
Vorher würde ich aber gerne wissen, auf welches Erkennungsmerkmal sich das Update-Paket bezieht.