Seite 3 von 3

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 09:33
von Hendrik_Ambrosius
Dann ist das das Grundproblem. Ohne DDC keine SW-Installation.
Dann bitte auf dem Server Debugview starten, Filter auf Aktivierungsservice, capture global an.
Dann dem PC ein weiteres SW-Paket zuweisen, aktivieren.
Debugview Log checken und posten.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 09:36
von Hendrik_Ambrosius
Komisch ist aber dass das Debugview Log von Ihnen zeigte dass die DDC da ist:
ComJobSmb.cpp(225):INFO Job Smb File found: \\MATRIX42\Configurator$\Values\MachineValues\VAHLE\VCAD1007.ddc

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 11:00
von Vahle
Das ist seltsam denn im Ordner ist nichts zu finden. Ich habe die Datei daher mal manuell erstellt und es nochmal so versucht.

Im Anhang finden Sie den neuen DebugView Log, die von mir angelegt DDC-Datei und ein Screenshot der Statusanzeige. Ich werde es mit dem DebugViewer gleich mal auf dem Server versuchen.

edit: was meinen Sie mit Filter auf Aktivierungsservice?

Vielen Dank.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 11:26
von Hendrik_Ambrosius
Wir sorgen nun erst mal dafür dass die DDC Dateien korrekt automatisch erstellt werden.
Sonst bringt das Debugging auf dem Client nix.
Also Debugview auf dem Server starten und einen Filter auf die ProzessID des Aktivierungsdienstes setzten vor dem Aktivieren des Clients.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 11:39
von Vahle
meinen Sie mit Aktivierungsdienst die Empirum Management Console? Ein anderer Prozess von MAtrix42 ist nicht gestartet.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 11:49
von Hendrik_Ambrosius
Nein, ich meine den Dienst Empirum-Activation aka ACTIVATIONSERVICE.EXE
Wenn der nicht läuft auf dem Master-Server sollten Sie mal die Dienste über Empirum DBUtil einrichten.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 12:47
von Vahle
Ich habe zuerst die selbst erstellte DDC aus dem Ordner genommen und die Installation von Mozilla angestoßen (DebugView hat dabei den Activation dienst beobachtet).
Nach ca. 20min ist nichts passiert. Daher habe ich nochmal per Rechtsklick auf "auf neu freigegebene Software prüfen" geklickt. Da nichts passiert ist, habe ich dann auf dem Client im Depot nachgeschaut ob das Programm installiert wurde. Dies war nicht der Fall. Ein paar Sekunden nachdem ich das Depot wieder geschlossen hatte, begann er mit der Installation. Ich habe mal die LOG hochgeladen.

Ich teste es allerdings nochmal mit dem PDF-XChange Viewer und lasse ihn mal länger als 20 Minuten warten.

P.S.: was mir aufgefallen ist, ist das zwischenzeitlich eine DDC-Datei für den Rechner in dem Ordner war. Nach der Installation war die DDC-Datei nicht mehr zu finden. Sagt Ihnen das was?

Vielen Dank für die Hilfe und die Geduld.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 13:38
von Hendrik_Ambrosius
Aha. Nun kommen wir der Sache langsam auf dem Grund:
MATRIXACTIVATION: LoadData: m_sGlobalDDCFileName: \\MATRIX42\Configurator$\User\swdepot.ddc
Kann es sein, dass Sie unter configurator$\user auf dem Server eine riesige swdepot.ddc Datei haben wo die SW-Verteil-Einträge drin sind?
Das wäre recht unüblich.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 03. Sep 2015, 13:55
von Hendrik_Ambrosius
Wobei... dieser String kommt bei mir auch im Log.
Steht wohl generell drin.
Trotzdem mal checken bitte.

Wenn die DDC Datei nur temporär in dem Ordner ist scheint mir das so als wenn ein Sync-Job diese Dateien löscht.
Nutzen Sie Depot-Server?
Wenn ja bitte mal testweise alle Sync-Dienste beenden um zu sehen ob dann die DDC erhalten bleibt auf dem Master.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 04. Sep 2015, 11:36
von Vahle
Guten Tag,

ich hatte es, wie angekündigt, gestern nochmal länger durchlaufen lassen und diesmal hat es komischerweise funnktioniert.
Die DDC Datei war allerdings wieder nur temporär in dem Ordner. Ich habe sie aber als sie in dem Ordner erschien kopiert um sie Ihnen zu zeigen.

Nach Rücksprache habe ich erfahren das wir ein Depot-Server nutzen. Allerdings nicht für unser Standort wo die Probleme so massiv aufgefallen sind. Ich konnte außerdem keine swdepot.ddc unter den von Ihnen angegebenen Pfad finden. Ich habe mal ein Screenshot mit angehängt. Dazu habe ich die DDC Datei des Rechners und den DebugView Log des Servers hochgeladen.

Vielen Dank und schon mal ein schönes Wochenende.

edit: Anhang vergessen.

Re: Softwareverteilung funktioniert nicht auf allen Rechnern

Verfasst: 04. Sep 2015, 11:54
von Hendrik_Ambrosius
OK; dann ist das Kernproblem dass die DDCs verschwinden.
Wie empfohlen bitte mal alle Depot Syncs temporär abschalten.
Wahrscheinlich läuft da etwas in die falsche Richtung.