Push Agent Problem bei Macintosh 10.11 El Capitan

Unterstützung und Diskussion zur Installation von Empirum (Agentenverteilung, Depotserver ...)

Moderator: MVogt

Antworten
haagm
Beiträge: 29
Registriert: 25. Feb 2014, 17:57
Wohnort: Heidelberg
Kontaktdaten:

Push Agent Problem bei Macintosh 10.11 El Capitan

Beitrag von haagm » 15. Dez 2015, 15:37

Hallo Matrix42 Forum,

wir haben nun 16.0.2 im Einsatz und würden gern unsere Softwareverteilung auch auf unsere Macs erweitern.
Push Agent geht auch soweit ganz gut - nur bekommen wir 10.11 nicht zum Fliegen.

Laut Debugview dürfte es es am folgendem Fehler liegen.

Code: Alles auswählen

[1680] MATRIXAGENTPUSHSRV: CAgentPushTask::SetUseS0Param(bValue=TRUE)
[1680] START: Mac Agent installation starting (Client: itcftp3mac / User: service)
[1680] COMMAND: rm -R /tmp/EmpirumAgentSetup; mkdir /tmp/EmpirumAgentSetup
[1680] ERROR CODE: 1
[1680] OUTPUT: FATAL ERROR: Couldn't agree a client-to-server cipher (available: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com)
[1680] RESULT: Mac Agent temporary installation directory cannot be created/removed
[1680] FINISH: Mac Agent installation finished with errors (Client: itcftp3mac / User: service)

So als Referenz eine Log für Push Agent auf 10.10 Yosemite

Code: Alles auswählen

[1680] MATRIXAGENTPUSHSRV: CAgentPushTask::SetUseS0Param(bValue=TRUE)
[1680] START: Mac Agent installation starting (Client: zdv-mac11 / User: service)
[1680] COMMAND: rm -R /tmp/EmpirumAgentSetup; mkdir /tmp/EmpirumAgentSetup
[1680] OUTPUT: y 
[1680] 
[1680] Password:
[1680] RESULT: Mac Agent temporary installation directory created successfully
[1680] COMMAND: cp -r "//%EmpirumServer%/Configurator$/Packages/Matrix42/EmpirumAgent_for_Mac/16.0" "/tmp/EmpirumAgentSetup"
[....]
Leider finde ich keine Informationen zum Abruf der Scripte die SSH antriggern.
Mit welcher Verschlüsselung funktioniert das nun? bzw wo ist der Schalter um die geforderte Verschlüsselung zu aktivieren?
Jemand ne Idee?

Viele Grüße

Michael H.
Deutsches Krebsforschungszentrum

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7409
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Re: Push Agent Problem bei Macintosh 10.11 El Capitan

Beitrag von Hendrik_Ambrosius » 15. Dez 2015, 23:01

Siehe Releasenotes von Update 2:
Mac: Agent Push on Mac OS 10.11 does not work. Use package based Agent deployment instead.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

haagm
Beiträge: 29
Registriert: 25. Feb 2014, 17:57
Wohnort: Heidelberg
Kontaktdaten:

Re: Push Agent Problem bei Macintosh 10.11 El Capitan

Beitrag von haagm » 17. Feb 2017, 12:52

Hello Hendrik und wer sonst so hier liest.

Ich habe glaube alle Release Note seit dem besagten Update 2 durchgeblättert und konnte kein Fix für das Push Agent problem bei Mac finden. Heißt wahrscheinlich dass sie es nicht gefixt haben oder?
Wobei... Ich ja sogar auf Sierra 10.12 den Agent pushen kann aber es werden keine Konfigurationsdateien auf den Ciient geschrieben

Fehler "no Route to Host"

Wobei die "normale" Verbindung über SMB kein Problem ist. Und an den Rechten sollte es auch nicht scheitern... hm...
Wir verwenden gerade die 16.1.1

Testweise habe ich das mal mit 10.10 gemacht. Gleiches Ergebnis.. Push Erfolgreich aber keine DDC, DDS das auf die Clients geschrieben wird.

mehr aus der Log im Anhang

Vielen Dank im Voraus.


MH aus HD
Dateianhänge
empirum_egant_mac_log.pdf
(7.58 KiB) 85-mal heruntergeladen

Antworten

Zurück zu „Installation und Verteilung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste