Seite 1 von 1

Agent Push schlägt fehl 16.1.3

Verfasst: 08. Jun 2017, 09:20
von Kjartansson
Hey

Wir haben jetzt empirum 16.1.3 aber nach dem update können wir nicht den agent manuel pushen, das slägt immer fehl.

Hoffen einer von euch eine lösung kent.

2017-06-08 09:05:28.407 ANDRESEN NGDKL068 SYSTEM Agent push failed Error Status
2017-06-08 09:05:18.020 ANDRESEN NGDKL068 SYSTEM Agent installation failed Error Status
2017-06-08 09:05:00.323 ANDRESEN NGDKL068 SYSTEM Execute Agent installation Information Detail
2017-06-08 09:04:56.020 ANDRESEN NGDKL068 SYSTEM Copy of config file \\NGDKSDP1\Configurator$\User\Agent16.1.3.xml succeeded Information Detail
2017-06-08 09:04:56.010 ANDRESEN NGDKL068 SYSTEM Copy package files succeeded Information Detail
2017-06-08 09:04:54.317 ANDRESEN NGDKL068 SYSTEM Logon to client succeeded Information Detail

Re: Agent Push schlägt fehl 16.1.3

Verfasst: 13. Okt 2017, 12:09
von CMoehlmann
Was sagt denn DBUGVIEW beim Push? Einfach auf dem Empirumserver das Tool starten und als Filter *MATRIXAGENTPUSHSRV* setzen.

Re: Agent Push schlägt fehl 16.1.3

Verfasst: 07. Mär 2018, 14:59
von AKießling
Hallo zusammen,

ich muss dieses Thema bzw. den Beitrag mal wieder reaktivieren.

Wir haben nun auch auf einigen Clients das Problem, dass das manuelle Pushen des Agents (16.1.0.10) auf bestimmten Clients fehlschlägt.

Laut Agent Push-Log kann die Verbindung (Logon) zum Client noch erfolgreich aufgebaut werden, aber die eigentliche Installation wird dann abgebrochen (Agent push failed).

https://picload.org/view/daollrll/agent ... g.jpg.html

Über den DBUGVIEW beim Push auf dem Empirumserver mit Hilfe des Filters *MATRIXAGENTPUSHSRV* erhalte ich folgende Ausgabe hierbei:

Code: Alles auswählen

00001847	12:56:39	[1332] MATRIXAGENTPUSHSRV: Using ConnectData: User .\admin Password *** ClientHostDomainName  	
00001849	12:56:39	[1332] MATRIXAGENTPUSHSRV: Try to connect to registry of IN-0136	
00001862	12:56:39	[1332] MATRIXAGENTPUSHSRV: Create directory "\\IN-0136\Admin$\Temp\EmpirumAgent_tmp"	
00001864	12:56:39	[1332] MATRIXAGENTPUSHSRV: CreateDirectory(pszDirectory="\\IN-0136\Admin$\Temp\EmpirumAgent_tmp") succeeded	
00001865	12:56:39	[1332] MATRIXAGENTPUSHSRV: RecursiveCreateDirectory(lpszDirectory="\\IN-0136\Admin$\Temp\EmpirumAgent_tmp") succeeded	
00001866	12:56:39	[1332] MATRIXAGENTPUSHSRV: Create directory "\\IN-0136\Admin$\Temp\EmpirumAgent_tmp\Install"	
00001868	12:56:39	[1332] MATRIXAGENTPUSHSRV: CreateDirectory(pszDirectory="\\IN-0136\Admin$\Temp\EmpirumAgent_tmp\Install") succeeded	
00001869	12:56:39	[1332] MATRIXAGENTPUSHSRV: RecursiveCreateDirectory(lpszDirectory="\\IN-0136\Admin$\Temp\EmpirumAgent_tmp\Install") succeeded	
00001870	12:56:39	[1332] MATRIXAGENTPUSHSRV: Copy file "\\VM009-DV.intern.netz\Configurator$\User\Setup.exe" to "\\IN-0136\Admin$\Temp\EmpirumAgent_tmp\Install\Setup.exe"	
00001871	12:56:39	[1332] MATRIXAGENTPUSHSRV: io error: cannot copy from "\\VM009-DV.intern.netz\Configurator$\User\Setup.exe" to "\\IN-0136\Admin$\Temp\EmpirumAgent_tmp\Install\Setup.exe" ([b][color=#FF0000]Für diesen Befehl ist nicht genügend Speicher verfügbar.[/color][/b] 	
Ich verstehe den genauen Fehler - Für diesen Befehl ist nicht genügend Speicher verfügbar. - nicht, welchen Speicher er hierbei meint. Auf der Festplatte, worauf die Daten für den Agent abgelegt werden ist mehr als genug vorhanden.

Diesen Fehler beim Agent-Push erhalte ich auf den verschiedensten Clients von uns. An unserem Matrix42-System wurde jedoch nichts verändert.

Kann mir jemand sagen, was die Ursache hierbei ist?
Wenn ihr noch weitere Informationen benötigt, dann gebt mir bitte Bescheid.

Vielen Dank im Voraus.

Freundliche Grüße

André Kießling

Info-Update:
Jetzt funktioniert der Agent-Push auf den ersten Clients, die zuvor noch nicht funkioniert haben, wieder problemlos.

Lösung:
Ich habe den Empirum-AgentPush Dienst auf unserem Empirum Server neu gestartet!