DeviceMapping.XML

Post Reply
AlfredW
Posts:5
Joined:18. Nov 2020, 15:43
Contact:
DeviceMapping.XML

Post by AlfredW » 27. Apr 2022, 16:00

Hallo,

in unsere Testumgebung (geklonter Empirum Master Server aus der Produktion; Version 19.0.3). Der WinPE-Agent loggt, dass die MAC-Adresse bzw. UUID nicht in der DeviceMapping .xml findet. die Datei "DeviceMapping.xml" habe ich mal testweise verschoben.
Dann habe ich den Empirum Activation Dienst deinstalliert und wieder installiert. Das scheint soweit zu laufen. Ini-Datei bzw. DDC-Datei werden im Verzeichnis "Empirum\Configurator\Values\MaschineValue\<Domain> erzeugt. Nach der Installation des Activation Dienstes kann ich aber nirgends eine Datei "DeviceMapping.xml" finden.
Wer legt diese an?

Gruß

Alfred

BroncosCountry
Posts:4
Joined:25. Sep 2019, 11:59
Contact:

Re: DeviceMapping.XML

Post by BroncosCountry » 28. Apr 2022, 13:13

Hallo,

Du hast richtig vermutet, der Activation Dienst (MATRIXBTQHX64) ist für die Erstellung der DeviceMapping.xml zuständig.
Soweit ich weiß, findet ein Update dieser Datei nur statt, wenn ein neues Gerät in die Datenbank kommt.
Ich würde an deiner Stelle mal das betroffene Gerät neu in die Datenbank bringen, bzw. bei einem Dummy Computerobjekt zufällige Werte in die UUID + MAC Felder eintragen. Dann sollte der Abgleich getriggert werden und deine DeviceMapping.XML Datei sollte weider erscheinen :roll:

LG
Alfred

AlfredW
Posts:5
Joined:18. Nov 2020, 15:43
Contact:

Re: DeviceMapping.XML

Post by AlfredW » 02. May 2022, 16:20

Hallo,

ich habe mal die Logs von DebugView in Real-Life mit dem Log der Testumgebung abgeglichen

Real-Life:
00029456 146.36337280 [4288] ThreadId=7624 [MXCORE] => CREATE ENTRY:78402.3680469 STATE:Running MSG:'11' OID:UpdateDeviceMapping OT:Computer IOI:PE
00029457 146.36343384 [4288] ThreadId=7624 [MXCORE] => UPDATE ENTRY:78402 STATE:3680469 MSG:'Success' EXCEPTION:

In der Testumgebung taucht dieser Eintrag nicht auf.
In DBUtil habe ich den Activation Dienst neu installiert.
Das Passwort des Dienstekonto "Empirum-Backend Task Queue Host (64 bit)" neu eingegeben. Dienst restartet --> funktioniert

Ein Computerkonto neu angelegt. Es taucht dann in nicht zugeordnete Computer auf.

Eine Datei "DeviceMapping.xml" wird immer noch nicht im Verzeichnis \Empirum\Configurator\Values angelegt.
Der Share Values$ zeigt auf das richtige Verzeichnis.

Gruß

Alfred

munzur
Posts:80
Joined:23. Jun 2020, 19:26
Contact:

Re: DeviceMapping.XML

Post by munzur » 03. May 2022, 10:01

Moin Alfred,

wie sieht die Hardware auf dem Testserver aus? CPU?

AlfredW
Posts:5
Joined:18. Nov 2020, 15:43
Contact:

Re: DeviceMapping.XML

Post by AlfredW » 04. May 2022, 16:01

Hallo,

Hardware ist alles virtuell
Im Backtracking-Log steht, dass irgend ein Server "fehlt".
ich habe den Activation-Dienst deinstalliert und nach einem Neustart wieder installiert.

Gruß

Alfred

munzur
Posts:80
Joined:23. Jun 2020, 19:26
Contact:

Re: DeviceMapping.XML

Post by munzur » 05. May 2022, 09:04

Hi,

läuft das jetzt wieder?

Ich hatte dasselbe Problem mit meiner Testumgebung, da fehlte es an Power.

Passen die Hardwareeigenschaften denn zu den Systemvoraussetzungen?

User avatar
Frank Dethlefsen
Posts:489
Joined:06. Apr 2006, 22:01
Location:Bochum
Contact:

Re: DeviceMapping.XML

Post by Frank Dethlefsen » 11. May 2022, 20:10

Moin!

Einer der mindestes Voraussetzung für Empirum sind 2 CPUs oder besser mehr.
Falls nur eine CPU zugewiesen ist, wird ein Teil der Aufgaben nicht abgearbeitet.
Unter anderem wird dann die DeviceMapping.xml nicht erstellt bzw. aktualisiert.
:roll:
Frank Dethlefsen
Consultant und Coach
UPDATENOW GmbH
Frank.Dethlefsen@updatenow.de
https://empirum.blogspot.de/

AlfredW
Posts:5
Joined:18. Nov 2020, 15:43
Contact:

Re: DeviceMapping.XML

Post by AlfredW » 25. May 2022, 16:50

Hallo,

Du bist mein Held. Das war das Problem. Bei der Übertragung des virt. Servers sind wohl Einstellungen "verloren" gegangen.
Jetzt geht es. Da wäre ich im Leben nicht drauf gekommen.

Gruß

Alfred

Post Reply

Return to “Empirum”

Who is online

Users browsing this forum: No registered users and 1 guest