Fehler bei Agentenverteilung (Msvcrt.dll / Msvcp60.dll)

Unterstützung und Diskussion zur Installation von Empirum (Agentenverteilung, Depotserver ...)

Moderator: MVogt

Antworten
M. Niemann

Fehler bei Agentenverteilung (Msvcrt.dll / Msvcp60.dll)

Beitrag von M. Niemann » 10. Jan 2005, 14:32

Da wir nun auf Empirum 2005 umgestellt haben, mussten somit auch alle Agenten neu ausgerollt werden. Dabei bekomme ich bei dem ein oder anderen Rechner (sehr vereinzelt) die Fehlermeldung, dass "Version 6 von Msvcrt.dll / Msvcp60.dll im Systemverzeichnis nicht vorhanden!" ist.

Der Agent ist anscheinend nicht in der Lage diese Rechner über die normale Verteilung mit den neuen Versionen zu versorgen. Ist nun wieder Turnschuhadministration gefragt oder kann man das Problem auch anders umschiffen?

Benutzeravatar
maierch
Beiträge: 113
Registriert: 21. Dez 2004, 18:36
Wohnort: Freiburg
Kontaktdaten:

Beitrag von maierch » 10. Jan 2005, 15:01

Hallo Herr Niemann,

man könnte den Agent auch über Loginscrip installieren.

den Fehler hatte ich auch schon gehabt. Das Problem war, allerdings bedingt durch die Umstellung von Novell auf ADS, das die Admin$ Freigaben auf den Clients nicht vorhanden waren und der Agent dieses Share benötigt.

MFG

Christian Maier

M. Niemann

Beitrag von M. Niemann » 10. Jan 2005, 15:57

Hallo Herr Maier,

leider kann es an einer fehlenden ADMIN$-Freigabe nicht liegen, da diese auf dem betroffenen Rechner vorhanden ist.

Verteilung über ein LoginScript kommt für unsere Umgebung leider auch nicht in Frage, da wir nur ausgewählte Maschinen in der Softwareverteilung haben. Wir sind hier also auf die Verteilung über die Konsole angewiesen.

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7586
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 10. Jan 2005, 17:18

Verstehe ich das richtig - versuchen Sie den Agenten über die Agent-Verteilung zu aktualisieren?
Das finde ich sehr umständlich. Packen Sie doch einfach die AGENTNT.EXE aus, erhöhen Sie die Revision, importieren Sie die setup.inf in das SWDEPOT und verteilen Sie das Update auf diesem Weg.
Erheblich stressfreier.
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

mei
Beiträge: 7
Registriert: 11. Jan 2005, 14:05
Wohnort: Hannover
Kontaktdaten:

Distributionmanager.dll ??

Beitrag von mei » 11. Jan 2005, 14:14

Hallo !

dies scheint ein generelles Problem mit der Agenteninstallation zu sein. Wir haben das bei unserem Kunden auch (1 von 30 Maschinen).
Angeblich läßt sich der Fehler aber durch den Austausch der Distributionmanager.dll beheben. Version 10.0.0.46 soll den Fehler nicht mehr beinhalten.

Gruß,

M.Rodriguez

Benutzeravatar
Hendrik_Ambrosius
Moderator
Moderator
Beiträge: 7586
Registriert: 13. Dez 2004, 23:10
Wohnort: Adendorf/Lüneburg

Beitrag von Hendrik_Ambrosius » 11. Jan 2005, 19:10

Ich hatte dieses Phänomen heute auch das erste Mal - allerdings war das auch als Zielsystem ein W2K ohne Service Pack.
Kann das die Ursache sein?
Hendrik Ambrosius / Senior Consultant
Mobile: +49 172 408 4447 | hendrik.ambrosius@matrix42.com
Matrix42 AG | Elbinger Straße 7 | 60487 Frankfurt am Main | Germany | www.matrix42.com

Disclaimer: I participate in this forum on a voluntary basis. Views expressed are not necessarily those of Matrix42 AG or of the support team.

mei
Beiträge: 7
Registriert: 11. Jan 2005, 14:05
Wohnort: Hannover
Kontaktdaten:

Beitrag von mei » 12. Jan 2005, 09:46

Der Fehler tritt auf verschiedenen Betriebsystemen auf. Bei uns betrifft er Windows XP SP1 und SP2. Seit einspielen der neuen DLL ist kein Fall mehr aufgetreten.
un cordial saludo

[i]M.Rodriguez[/i]
CompuNet Hannover

M. Niemann

Beitrag von M. Niemann » 12. Jan 2005, 12:01

Gibt es schon wieder einen neuen Patch? Ich habe den Server erst am Montag aufgesetzt und alle bis dato verfügbaren Hotfixes eingespielt.

Vielleicht könnte man ja bei matrix42 einen Newsletter einrichten, in dem man sich selber eintragen kann, wenn man über neue Hotfixes benachrichtigt werden möchte.

Ich werde gleich mal schauen, ob es was neues gibt.

Achja, bei uns ist es ein Windows XP ServicePack1 Rechner.

Antworten

Zurück zu „Installation und Verteilung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste