Regkeys werden nicht direkt gesetzt, Berechtigungsproblem?

Antworten
mwirth
Beiträge:38
Registriert:17. Mär 2010, 13:00
Kontaktdaten:
Regkeys werden nicht direkt gesetzt, Berechtigungsproblem?

Beitrag von mwirth » 12. Aug 2011, 16:07

Hallo,

ich versuche gerade das ein oder andere Paket zu erstellen, momentan habe ich mir den TeamViewer vorgenommen um das ganze auch einfach wieder in Erinnerung zu rufen. Dabei tritt nun folgendes Problem auf:

Zunächst verhält sich die Installation wie erwartet, ich möchte aber anschließend noch ein paar Registry-Keys setzen die zum einen unter HKLM und zum anderen unter HKCU liegen. Mir ist jetzt aufgefallen, dass wenn ich auf meinem Testrechner das Paket über das Softwaredepot installieren, keiner der Regkeys geschrieben wird, die Installation ansich ist aber in Ordnung. Nun dachte ich an einen generellen Gedankenfehler meinerseits, aber dann habe ich das Paket einfach noch mal runtergeschmissen und erneut ohne zurücksetzen des Rechners das Paket installieren lassen und siehe da, die RegKeys werden gesetzt. Nach weiterer überlegung verhält es sich so, dass TeamViewer die eigenen RegKeys bei der Deinstallation nicht löscht, dass ist auch der Grund warum es dann beim zweiten mal funktioniert. Jetzt meine Frage, habe ich da ein Berechtigungsproblem beim schreiben der Keys? Gibt es einen Trick wie ich das auch beim ersten mal hinbekommen kann?

Ich teste momentan auf WinXP (x86).

Wäre dankbar für jeden Hinweis!

Danke

Benutzeravatar
r.wiegel
Beiträge:873
Registriert:05. Feb 2010, 13:45
Wohnort:Regensburg
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von r.wiegel » 12. Aug 2011, 17:16

verwenden Sie bitte den /AW-Schalter (für HKCU-Einträge). Werden Einstellungen auch nach einem Reboot nicht gesetzt?

Grüße
Roman
Viele Grüße
Roman Wiegel
IT-Consultant

MR Datentechnik - Vertriebs- und Service GmbH

mwirth
Beiträge:38
Registriert:17. Mär 2010, 13:00
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von mwirth » 15. Aug 2011, 12:47

Hallo,

also die Keys scheinen nach dem Neustart zu funktionieren, alles unter HKCU ist aber nicht zu finden (/AW gesetzt).

Danke auf jeden Fall für die Antwort!

Gruß

Walter_Schulz
Beiträge:876
Registriert:17. Dez 2004, 12:29
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von Walter_Schulz » 15. Aug 2011, 13:07

Falls die Maschine das Paket *ohne* /AW bekam, ist ein nachtraegliches Setzen des Schalters wirkungslos. Das Paket ohne /AW deinstallieren, danach mit /AW wieder installieren, dann sollten auch die HKCU-Eintraege greifen.

Ciao!
Walter Schulz

mwirth
Beiträge:38
Registriert:17. Mär 2010, 13:00
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von mwirth » 15. Aug 2011, 13:17

Ich hatte den Testrechner per Snapshot zurückgesetzt, da war also keinerlei Installation vorher!

Ich glaube ich werde noch viel Zeit investieren müssen um mich hier durch zu hangeln ...

Benutzeravatar
r.wiegel
Beiträge:873
Registriert:05. Feb 2010, 13:45
Wohnort:Regensburg
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von r.wiegel » 16. Aug 2011, 09:06

Zu AW: wenn Sie den AW-Schalter in Setup.inf eingetragen haben, dann muss das Paket neu eingebunden werden, damit die Änderung in DB landet (alternativ kann man das in Paketeigenschaften \Prüfung \Befehl eintragen oder auch "Versionen abgleichen").

Prüfen Sie bitte, ob Sie nach Einstellungen in Regestry an richtigen Stellen suchen:
TeamViewer \Extras \Optionen \Erweitert \Erweiterte Einstellungen Anzeigen\TeamViewer Einstellungen\ eine *.reg exportieren.
Übrigens, Sie können alles einstellen, exportieren und dann in Ihrem Paket den Befehl reg IMPORT "%SRC%*\settings.reg" (cmd ->reg /?) eintragen.

Prüfen Sie bitte den Zusammenhang mit dem Wert Platform=x86. (probieren Sie mit *)

Viel Erfolg

Grüße
Roman
Viele Grüße
Roman Wiegel
IT-Consultant

MR Datentechnik - Vertriebs- und Service GmbH

mwirth
Beiträge:38
Registriert:17. Mär 2010, 13:00
Kontaktdaten:

Re: Regkeys werden nicht direkt gesetzt, Berechtigungsproble

Beitrag von mwirth » 17. Aug 2011, 07:21

Hallo,

ich habe noch so oft hin und her probiert .... nun funktioniert es. Ich weiß ehrlich gesagt garnicht mehr was nun der ausschlaggebende Punkt war. Es funktioniert jedenfalls erst, wenn der Rechner einen Neustart gemacht hat, abmelden allein zeigt keine Wirkung. Das verstehe ich zwar nicht, aber das erreichen meines Zieles ist erstmal das wichtigste!

Danke an alle Beteiligten!

Antworten

Zurück zu „Paketierung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 11 Gäste