Ordner mit Symbol erstellen (Desktop.ini)

Unterstützung und Diskussion zur Installation von Empirum (Agentenverteilung, Depotserver ...)

Moderator: MVogt

Antworten
Benutzeravatar
0711
Beiträge: 28
Registriert: 04. Jan 2012, 08:18
Kontaktdaten:

Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von 0711 » 04. Jan 2012, 08:29

Hallo,

ich versuche über die setup.inf einen Ordner (inkl. angepasstem Ordnersymbol) im Startmenü des Benutzers anzulegen. Das Anlegen des Ordners, kopieren des Symbols und erzeugen der Desktop.ini mit den entsprechenden Einträgen funktioniert. Nur hab ich das Problem, dass das Symbol nicht für den Ordner angezeigt wird. Das klappt wohl erst wenn man einen Befehl über die Kommandozeile abschickt: Attrib +S [Startmenüordner]. Danach wird das Symbol angezeigt. Nur bekomme ich das nicht hin, dass dieser Befehl von der setup.inf irgendwie noch mit ausgeführt wird.

Code: Alles auswählen

[Set:Product]
1:install\B_SW.ico, C:\temp\_images\B_SW.ico,	ALWAYS, 100
1:, %UserStartMenu%\xxx, CREATE DIRECTORY, 0
Call cmd /c ATTRIB +S %UserStartMenu%\xxx\"   <== Das hier klappt wohl nicht :(
; 1:, %App%, CREATE DIRECTORY CASCADED, 0

[Ini:Product]
"%UserStartMenu%\xxx\Desktop.ini",".ShellClassInfo",,"IconFile=%%SystemDrive%%\temp\_images\B_SW.ico"
"%UserStartMenu%\xxx\Desktop.ini",".ShellClassInfo",,"IconIndex=0"
Hat jemand nen Tipp für mich, wie ich das zum laufen bekomme?
(Per Diff hab ich auch nichts rausgefunden)

Besten Dank
Marco

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von Walter_Schulz » 04. Jan 2012, 09:05

Call cmd /c ATTRIB +S "%UserStartMenu%\xxx\"

Ciao!
Walter Schulz

Benutzeravatar
0711
Beiträge: 28
Registriert: 04. Jan 2012, 08:18
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von 0711 » 04. Jan 2012, 09:36

Stimmt, das erste " hatte ich vergessen - nachdem ich da was versucht hab.

Leider liegt es aber nicht daran. Das Attribut S fehlt weiterhin nach dem Erstellen des Ordners.

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von Walter_Schulz » 04. Jan 2012, 09:42

Code: Alles auswählen

    [Set:Product]
    1:install\B_SW.ico, C:\temp\_images\B_SW.ico,   ALWAYS, 100
    1:, %UserStartMenu%\xxx, CREATE DIRECTORY SYSTEM, 0
;    Call cmd /c ATTRIB +S %UserStartMenu%\xxx\"   <== Das hier klappt wohl nicht :(
    ; 1:, %App%, CREATE DIRECTORY CASCADED, 0

    [Ini:Product]
    "%UserStartMenu%\xxx\Desktop.ini",".ShellClassInfo",,"IconFile=%%SystemDrive%%\temp\_images\B_SW.ico"
    "%UserStartMenu%\xxx\Desktop.ini",".ShellClassInfo",,"IconIndex=0"

Benutzeravatar
0711
Beiträge: 28
Registriert: 04. Jan 2012, 08:18
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von 0711 » 05. Jan 2012, 09:29

also prinzipiell klappt der Parameter SYSTEM für CREATE DIRECTORY - danke dafür :).
Wenn ich einen Ordner z.B. direkt auf C: anlegen lasse, dann hat er das Attribut, aber sobald ich den Ordner im Startmenü anlegen will, fehlt das System Attribut - das ist seltsam :shock: das muss doch klappen?

Walter_Schulz
Beiträge: 876
Registriert: 17. Dez 2004, 12:29
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von Walter_Schulz » 05. Jan 2012, 09:55

Bitte ein bisschen ausfuehrlicher. Kann hier nicht nachvollziehen, was genau gemeint ist und mit welchen Parametern was wo klappt oder auch nicht.

Ciao!
Walter Schulz

Benutzeravatar
0711
Beiträge: 28
Registriert: 04. Jan 2012, 08:18
Kontaktdaten:

Re: Ordner mit Symbol erstellen (Desktop.ini)

Beitrag von 0711 » 05. Jan 2012, 10:15

Also wenn ich versuche mit CREATE DIRECTORY SYSTEM einen Ordner "xxx" auf C:\ anzulegen, dann wird das auch gemacht und das Attribut "S" für den Ordner "xxx" auf C:\ ist vorhanden.

Aber wenn ich versuche mit CREATE DIRECTORY SYSTEM einen Ordner "XYZ" im Benutzer-Startmenü (%UserStartMenu%) anlegen zu lassen, dann wird zwar der Ordner "XYZ" unter C:\Dokumente und Einstellungen\[Benutzer]\Startmenü\ angelegt - aber das Attribut "S" für den Ordner "XYZ" im Benutzer-Startmenü fehlt.

Antworten

Zurück zu „Installation und Verteilung“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast