Advanced Agent und .net Framework 4.5/4.5.1

Moderatoren: MVogt, moderators

Antworten
Benutzeravatar
Lammsalat
Beiträge: 33
Registriert: 03. Feb 2010, 18:20
Kontaktdaten:

Advanced Agent und .net Framework 4.5/4.5.1

Beitrag von Lammsalat » 22. Okt 2014, 15:13

Hallo Zusammen,

aus gegebenem Anlass (Paketierung DWG TrueView 2015) benötige ich auf einzelnen Systemen .Net Framework 4.5 bzw. 4.5.1. Da mit der Installation von 4.5./4.5.1 automatisch die Vorgängerversion deinstalliert wird funktioniert auf den Systemen meine ERIS.exe nicht mehr.

Ist der Advanced Agent mit .Net Framework 4.5.x kompatibel? Hab ich ein Update verpasst? Hat jemand nen Tipp wie man beides zum laufen bekommen könnte?
Gruß Michael
I don't know - what is Lammsalat?

Benutzeravatar
bboehm
Beiträge: 554
Registriert: 07. Apr 2008, 18:47
Wohnort: München
Kontaktdaten:

Re: Advanced Agent und .net Framework 4.5/4.5.1

Beitrag von bboehm » 22. Okt 2014, 15:59

Hallo Michael,

Du ziehst mit der Deinstallation dem Agent praktisch seine Runtime unterm Hintern weg, damit dass nicht passiert,
haben wir in im Skript von 4.5 den Parameter "AskUninstallOld" auf 0 gesetzt.

Damit bei einer Neuinstallation des Rechners nicht zuerst 4.0 vom Agent und dann per Paket 4.5 installiert wird,
könntest du auch noch in der "EmpirumAgent.bat", die neue Version installieren:

Code: Alles auswählen

Call \\%EmpirumServer%\Configurator$\User\Setup.exe "\\%EmpirumServer%\Configurator$\Packages\Microsoft\DotNet Framework\4.5.50938\Install\Setup.inf" /S0
Diese Zeile muss auf alle Fälle vor der Agent-Installation in die Batch eingefügt werden.

Schöne Grüße
Bernhard
IT-Administrator mit Migrationshintergrund bei Fraunhofer-Gesellschaft

Produktionssystem: W2k19, Empirum 20.0.2, MS SQL 2017 Enterprise
Testsystem: W2k19, Empirum 20.0.2, MS SQL 2017 Express

Benutzeravatar
Lammsalat
Beiträge: 33
Registriert: 03. Feb 2010, 18:20
Kontaktdaten:

Re: Advanced Agent und .net Framework 4.5/4.5.1

Beitrag von Lammsalat » 23. Okt 2014, 09:32

Hallo Bernhard,

danke für die Antwort.
Der "AskUninstallOld" Parameter war noch gar nicht am Zug, da die händische Installation schon das Dot Net 4.0 deinstalliert hat und ERIS nicht mehr wollte

Mittlerweile funktioniert es auf unerklärliche Weise aber doch. Ich kanns mir auch nicht wirklich erklären was jetzt anders war. Jedenfalls hat die händische installation geklappt und das Empirum Paket dann auch.

Sehr strange das ganze.
Gruß Michael
I don't know - what is Lammsalat?

Antworten

Zurück zu „Software Management“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste